Engine HOT - A/C off on 2006 STS-V - Page 3
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 3 of 5 FirstFirst 1 2 3 4 5 LastLast
Results 31 to 45 of 73
Like Tree2Likes
Cadillac STS-V Series Forum Discussion, Engine HOT - A/C off on 2006 STS-V in Cadillac V-Series Forums; Ugh, this stupid light keeps coming on. Replacing Thermo, and Water Pump since it's leaking. The damn dealer wanted around ...
  1. #31
    rakoom2002 is offline Cadillac Owners Fanatic
    Automobile(s): STS-V
    Join Date
    Nov 2010
    Age
    29
    Posts
    174

    Re: Engine HOT - A/C off on 2006 STS-V

    Ugh, this stupid light keeps coming on. Replacing Thermo, and Water Pump since it's leaking. The damn dealer wanted around $1000 to fix both lol. Luckily one of their retired mechanics just lives up the street from me.

  2. #32
    KingOfLacs is offline Cadillac Owners Fanatic
    Automobile(s): 2006 STS-V, Stepside Chevy, 1966 Chevelle
    Join Date
    Dec 2011
    Age
    31
    Posts
    253

    Re: Engine HOT - A/C off on 2006 STS-V

    temp gauge is not working as of last night. After reading this post it looks like I have the same issue with bad t=stat (engine hot a/c off). Dublin Caddy ordered parts will have to wait till Friday their coming from reno. I was going to put the stock factory t-stat back in whadda think. Also going for a tune and exhaust any input would be helpful.

    Joe

  3. #33
    KingOfLacs is offline Cadillac Owners Fanatic
    Automobile(s): 2006 STS-V, Stepside Chevy, 1966 Chevelle
    Join Date
    Dec 2011
    Age
    31
    Posts
    253

    Re: Engine HOT - A/C off on 2006 STS-V

    Ok factory delco t-stat in no more hot engine shoot on my dash hell yes

  4. #34
    Chuck. is offline Cadillac Owners Member
    Automobile(s): 08 STS-V
    Join Date
    Oct 2011
    Age
    29
    Posts
    20

    Re: Engine HOT - A/C off on 2006 STS-V

    I had the same problem replaced t-stat and it has not come back its been a month.

  5. #35
    Bradkoen is offline Cadillac Owners Member
    Automobile(s): NONE
    Join Date
    Jan 2011
    Location
    Austin, Tx
    Age
    43
    Posts
    15

    Re: Engine HOT - A/C off on 2006 STS-V

    I have the same problem even after changing the Tsat. The water pump was replaced 2 months ago under warranty. Any other suggestions? I might go try unplugging the positive battery cable for 30 seconds, but I am not optimistic about this working.

  6. #36
    PGA2B's Avatar
    PGA2B is online now Cadillac Owners Connoisseur
    Automobile(s): Black Raven STS V
    Join Date
    Jun 2009
    Location
    Surprise, AZ
    Posts
    2,481

    Re: Engine HOT - A/C off on 2006 STS-V

    You might pull out the T-Stat and test it. There have been some bad right out of the box.

  7. #37
    Bradkoen is offline Cadillac Owners Member
    Automobile(s): NONE
    Join Date
    Jan 2011
    Location
    Austin, Tx
    Age
    43
    Posts
    15

    Re: Engine HOT - A/C off on 2006 STS-V

    Replaced the new Tstat with yet another Tstat and got the same results. Not to sure how to test them, cause I dropped them in hot boiling water and could see anything change. So, I decided I would try the removal of the positive battery terminal for 30 seconds and whahla, the temp. gauge started to working and the error message went away. Darn, what a way to spend my day off.

  8. #38
    PGA2B's Avatar
    PGA2B is online now Cadillac Owners Connoisseur
    Automobile(s): Black Raven STS V
    Join Date
    Jun 2009
    Location
    Surprise, AZ
    Posts
    2,481

    Re: Engine HOT - A/C off on 2006 STS-V

    When you put it on boiling water it should open. It should open somewhere near the rated temp.

  9. #39
    550HP STSV is offline Banned
    Automobile(s): Heavily Modified STS-V
    Join Date
    May 2010
    Location
    Cleveland, Ohio, United States
    Posts
    1,734

    Re: Engine HOT - A/C off on 2006 STS-V

    Jamie, pay your damn cell phone bill. I just called it and it said its disconnected. call me

  10. #40
    PGA2B's Avatar
    PGA2B is online now Cadillac Owners Connoisseur
    Automobile(s): Black Raven STS V
    Join Date
    Jun 2009
    Location
    Surprise, AZ
    Posts
    2,481

    Re: Engine HOT - A/C off on 2006 STS-V

    Quote Originally Posted by 550HP STSV View Post
    Jamie, pay your damn cell phone bill. I just called it and it said its disconnected. call me 866-236-5031
    It would help if you called the right number..........

  11. #41
    550HP STSV is offline Banned
    Automobile(s): Heavily Modified STS-V
    Join Date
    May 2010
    Location
    Cleveland, Ohio, United States
    Posts
    1,734

    Re: Engine HOT - A/C off on 2006 STS-V

    is 816-885-xxxx not your old number?

  12. #42
    PGA2B's Avatar
    PGA2B is online now Cadillac Owners Connoisseur
    Automobile(s): Black Raven STS V
    Join Date
    Jun 2009
    Location
    Surprise, AZ
    Posts
    2,481

    Re: Engine HOT - A/C off on 2006 STS-V

    Optimum word being "OLD"

    Now get back to the topic!

  13. #43
    KingOfLacs is offline Cadillac Owners Fanatic
    Automobile(s): 2006 STS-V, Stepside Chevy, 1966 Chevelle
    Join Date
    Dec 2011
    Age
    31
    Posts
    253

    Re: Engine HOT - A/C off on 2006 STS-V

    Did It again just replaced t-stat think it could be the actual temp sensor? Temp gauge not working light comes on engine hot / ac off oil temp is between 158-165.

  14. #44
    PGA2B's Avatar
    PGA2B is online now Cadillac Owners Connoisseur
    Automobile(s): Black Raven STS V
    Join Date
    Jun 2009
    Location
    Surprise, AZ
    Posts
    2,481

    Re: Engine HOT - A/C off on 2006 STS-V

    Are you throwing any codes? Could be the temp sensor but I don't know of any easy way to test it.

  15. #45
    KingOfLacs is offline Cadillac Owners Fanatic
    Automobile(s): 2006 STS-V, Stepside Chevy, 1966 Chevelle
    Join Date
    Dec 2011
    Age
    31
    Posts
    253
    Yup finally threw a code had to drive it for a while. Scanned it P0128 coolant temp below Thremostat regulating temp. Cleared it we shall see if it comes back on. I haven't driven it since then i will chime in if it does.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting