Tranny issue?
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 9 of 9
Cadillac STS-V Series Forum Discussion, Tranny issue? in Cadillac V-Series Forums; I've got a little irritating tranny issue. I purchased my V new, in May. Every now and then, usually on ...
  1. #1
    fast impala is offline Cadillac Owners Fanatic
    Automobile(s): 2008 STS-V, sold to fish!
    Join Date
    Apr 2008
    Location
    Gladewater, TX
    Posts
    114

    Question Tranny issue?

    I've got a little irritating tranny issue. I purchased my V new, in May. Every now and then, usually on a cold start, it will hesitate, when you make a slow, coasting, sharp, right-hand turn. It doesn't die, just add some throttle, and it drives fine. If you keep throttle, and don't coast, it doesn't do it. No CEL's, and only under those conditions. It will do it in D, and SD. It doesn't do it in manual shift mode. It is very intermittent.

    The very first time it did it, the car was less than two weeks old. I was coasting through a right-hand turn, uphill, and the car just wouldn't go. No CEL, didn't die, just no power. I turned the car off, put it in park, and it drove fine, after that.

    I mentioned this to the dealer, when I went in to get my plates. They hadn't had any problems like this, of course, they've only sold two of them.

    It almost seems like the PCM isn't telling the tranny what gear to select, or maybe the fly-by-wire throttle has some little gremlin.

    It's not a real issue, just a little irritating.

    Anyone have any thoughts or similar experience?

    TIA

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Dr. Design is offline Cadillac Owners Connoisseur
    Automobile(s): STS, XLR, STS V-Series, CTS V-Series, XTS....
    Join Date
    Aug 2003
    Location
    Design Center
    Age
    36
    Posts
    3,322

    Re: Tranny issue?

    What year is this STS-V, 08? You might want to make sure they have all the latest updates on your V as GM is constantly putting out software updates for these vehicles. As your service advisor to look into this. He can pull the history through the VIN#. Besides your dealership should be all over this issue, even if they have only sold 2...

    Good luck.

    Dr. Design

    Quote Originally Posted by fast impala View Post
    I've got a little irritating tranny issue. I purchased my V new, in May. Every now and then, usually on a cold start, it will hesitate, when you make a slow, coasting, sharp, right-hand turn. It doesn't die, just add some throttle, and it drives fine. If you keep throttle, and don't coast, it doesn't do it. No CEL's, and only under those conditions. It will do it in D, and SD. It doesn't do it in manual shift mode. It is very intermittent.

    The very first time it did it, the car was less than two weeks old. I was coasting through a right-hand turn, uphill, and the car just wouldn't go. No CEL, didn't die, just no power. I turned the car off, put it in park, and it drove fine, after that.

    I mentioned this to the dealer, when I went in to get my plates. They hadn't had any problems like this, of course, they've only sold two of them.

    It almost seems like the PCM isn't telling the tranny what gear to select, or maybe the fly-by-wire throttle has some little gremlin.

    It's not a real issue, just a little irritating.

    Anyone have any thoughts or similar experience?

    TIA

  4. #3
    LITTLEELVISDAN's Avatar
    LITTLEELVISDAN is offline Cadillac Owners Connoisseur
    Automobile(s): 06 STS-V, 09 Escalade, 2011 Corvette conv GS LT4, 2005 EXT
    Join Date
    Apr 2007
    Location
    Atlanta
    Posts
    1,758

    Re: Tranny issue?

    unplug your pos + battery cable and leave off for 30 min.... reconnect ... see if problem goes away. this will reset your PCM/ECM. These suckers are smart, they remember your driving habbits and adjust accordingly.

    Everytime I leave my house, I back out then pull forward on a down hill slope. The trans eventually learns this patters and starts leaving it out of gear until you apply 1/4 throttle to engage the gear twords the bottom of the hill. Thus making the car lurch forward. resetting the ECM clears it up. I then started doing more random things while leaving the house as not to build up a pattern.

    You may have done the same thing early on and it still remembers. Clear it out and see if that fixes it.

  5. #4
    LITTLEELVISDAN's Avatar
    LITTLEELVISDAN is offline Cadillac Owners Connoisseur
    Automobile(s): 06 STS-V, 09 Escalade, 2011 Corvette conv GS LT4, 2005 EXT
    Join Date
    Apr 2007
    Location
    Atlanta
    Posts
    1,758

    Re: Tranny issue?

    AND if you are having problems with your tranny go buy her something new. You have got to treat your tranny right.......
    .
    .
    .
    .
    I'll be here all week folks....

    don't forget to tip your serving staff..

  6. #5
    fast impala is offline Cadillac Owners Fanatic
    Automobile(s): 2008 STS-V, sold to fish!
    Join Date
    Apr 2008
    Location
    Gladewater, TX
    Posts
    114

    Thumbs up Re: Tranny issue?

    Thanks for the tip, I think it is software related. I specifically asked them to check for updates, when I bought the car. It was built in October of 07.

    This is a good dealership, but I kinda got the "deer in the headlights" look when I mentioned re-flashing it. Their tranny guy had not heard of anything like I described.

    Plus, I've got a D3 package on it now, and it did it before I did the "mod" stuff.

    I race an EFI car, so I'm fairly saavy on a lot of stuff. I knew the computer would do some learning, and maybe it picked up some habit of mine.

    I go down and uphill to the right, every time I leave my house.

  7. #6
    fast impala is offline Cadillac Owners Fanatic
    Automobile(s): 2008 STS-V, sold to fish!
    Join Date
    Apr 2008
    Location
    Gladewater, TX
    Posts
    114

    Question Re: Tranny issue?

    One more thing, are there any issues to just disconnecting the battery? Seems I saw somewhere, where somebody had issues with maybe the radio or some other stuff, when doing it?

  8. #7
    LITTLEELVISDAN's Avatar
    LITTLEELVISDAN is offline Cadillac Owners Connoisseur
    Automobile(s): 06 STS-V, 09 Escalade, 2011 Corvette conv GS LT4, 2005 EXT
    Join Date
    Apr 2007
    Location
    Atlanta
    Posts
    1,758

    Re: Tranny issue?

    Nope, you are good as long as you don't do it for a month. I do mine about once every other month and I haven't lost any presets

  9. #8
    fast impala is offline Cadillac Owners Fanatic
    Automobile(s): 2008 STS-V, sold to fish!
    Join Date
    Apr 2008
    Location
    Gladewater, TX
    Posts
    114

    Thumbs up Re: Tranny issue?

    Thanks,

    I'll definitely give it a try!

  10. #9
    fast impala is offline Cadillac Owners Fanatic
    Automobile(s): 2008 STS-V, sold to fish!
    Join Date
    Apr 2008
    Location
    Gladewater, TX
    Posts
    114

    Thumbs up Re: Tranny issue?

    Well, it worked! I disconnected the battery for thirty minutes, and the right-hand turn stutter is gone. It also seems to drive better. I did baby it a bit, when I first got the V.

    After I re-connected the battery, I went out did some spirited driving, especially in right-hand turns!

    I was surprised to find out, that when I disconnected the battery, it locked all the doors!

    Thanks again, for the tip!

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting