UPDATE: Coolant Smell/Losing Coolant Slowly/No Oil-Sludge in Coolant, No Obvious Leak - Page 2
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 16 to 19 of 19
Cadillac STS Forum - 2005 through 2012 Discussion, UPDATE: Coolant Smell/Losing Coolant Slowly/No Oil-Sludge in Coolant, No Obvious Leak in Past Cadillac Vehicle Discussion; I also had to have my water pump replaced due to a small leak (I'd have to add like a ...
  1. #16
    Midnight is offline Cadillac Owners Fanatic
    Automobile(s): 2005 STS 1SG
    Join Date
    Nov 2009
    Location
    Baltimore
    Age
    39
    Posts
    269

    Re: UPDATE: Coolant Smell/Losing Coolant Slowly/No Oil-Sludge in Coolant, No Obvious

    I also had to have my water pump replaced due to a small leak (I'd have to add like a cup every 2 weeks or something). Engine bay had a coolant smell from it.

  2. #17
    B1n2fra's Avatar
    B1n2fra is offline Cadillac Owners Fanatic
    Automobile(s): 2007 1SG Cadillac sts v8 awd
    Join Date
    Nov 2011
    Location
    Chicago
    Posts
    423
    Quote Originally Posted by EChas3 View Post
    A water pump failure is not all that rare. Models with the V03 Performance Cooling Package have 2 water pumps.

    I had one replaced under warranty but paid for flush & fill because air & Dexcool aren't friends.
    Two water pumps? Where would the second one be located at?

  3. #18
    Ludacrisvp's Avatar
    Ludacrisvp is offline Cadillac Owners Connoisseur
    Automobile(s): 08 STS4 V8 F55 1SG Euro tails & 01 Monte SS Pace Car
    Join Date
    Feb 2009
    Location
    St Michael, MN
    Age
    27
    Posts
    3,158

    Re: UPDATE: Coolant Smell/Losing Coolant Slowly/No Oil-Sludge in Coolant, No Obvious

    this has been posted and asked a couple of times but i've never seen proof.

  4. #19
    1BadCadSTS's Avatar
    1BadCadSTS is offline Cadillac Owners Connoisseur
    Automobile(s): 05 STS4
    Join Date
    Nov 2010
    Posts
    3,591
    Check between the rad and condenser. My dealer failed to find my leak 3 times. I found it and pointed it out to them.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting