Windshield wipers
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 4 of 4
Cadillac STS Forum - 2005 through 2012 Discussion, Windshield wipers in Past Cadillac Vehicle Discussion; So I got my car back after I had all the rings replaced to help with the oil issue. I ...
  1. #1
    robcinnafun is offline Cadillac Owners Member
    Automobile(s): 2005 Cadillac STS
    Join Date
    Feb 2013
    Location
    Quincy, IL
    Posts
    6

    Windshield wipers

    So I got my car back after I had all the rings replaced to help with the oil issue. I realized later after getting it back the windshield wipers aren't working and I have no idea why. I checked the fuse and it's fine. Any ideas?

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    1BadCadSTS's Avatar
    1BadCadSTS is offline Cadillac Owners Connoisseur
    Automobile(s): 05 STS4
    Join Date
    Nov 2010
    Posts
    3,631
    Relay?!

  4. #3
    dannyquest is offline Cadillac Owners Fanatic
    Automobile(s): 06 STS 95,000 miles
    Join Date
    Mar 2012
    Location
    columbus ohio
    Posts
    371

    Re: Windshield wipers

    robcinnafun, When my engine was re-ringed for the same thing, the engine was removed from the bottom of the car. Maybe they forgot to connect the wiper wire harness back up. By the way my car doesn't use any oil, 43,000 miles later. Danny

  5. #4
    Cadillac Cust Svc's Avatar
    Cadillac Cust Svc is offline Cadillac Customer Service
    Automobile(s): All Cadillac vehicles!
    Join Date
    Mar 2010
    Location
    Michigan
    Posts
    11,173

    Re: Windshield wipers

    Quote Originally Posted by robcinnafun View Post
    So I got my car back after I had all the rings replaced to help with the oil issue. I realized later after getting it back the windshield wipers aren't working and I have no idea why. I checked the fuse and it's fine. Any ideas?
    Hello robcinnafun,

    I am sorry your windshield wipers are not working after recently getting your vehicle back. I see Danny offered insight on your situation of a possible wire being disconnected. Have you checked that out yet? If you would like to further discuss your current situation or have other questions, please reach out to us via private message.

    Regards,

    Laura M.
    Cadillac Customer Care

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting