Headlight out; tried ballast, bulb and fuse... now what???
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 7 of 7
Cadillac STS Forum - 2005 through 2012 Discussion, Headlight out; tried ballast, bulb and fuse... now what??? in Past Cadillac Vehicle Discussion; Hi everyone. Had the driver's low beam HID go out. to be safe, I bought a ballast online and already ...
  1. #1
    stevenriz is offline Cadillac Owners Fanatic
    Automobile(s): 2005 STS4 V8 1SG
    Join Date
    Apr 2009
    Location
    Central MA
    Age
    47
    Posts
    288

    Headlight out; tried ballast, bulb and fuse... now what???

    Hi everyone. Had the driver's low beam HID go out. to be safe, I bought a ballast online and already had a couple good bulbs and had an old ballast that worked when I tapped it. Well tried EVERY combination or three ballasts and three bulbs twice and nothing works. Tapped the ballasts too, nothing! Swapped fuse locations and still nothing on the driver side. What else????? Wiring looks ok. help! thanks!!

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    1BadCadSTS's Avatar
    1BadCadSTS is offline Cadillac Owners Connoisseur
    Automobile(s): 05 STS4
    Join Date
    Nov 2010
    Posts
    3,681
    Did you check power and ground at the harness where it plugs into the ballast?

  4. #3
    stevenriz is offline Cadillac Owners Fanatic
    Automobile(s): 2005 STS4 V8 1SG
    Join Date
    Apr 2009
    Location
    Central MA
    Age
    47
    Posts
    288

    Re: Headlight out; tried ballast, bulb and fuse... now what???

    NO I do not have a tester for that. I lowered the bumper and am swapping the light assemblies and will report back. First test, I put the drivers one I was fixing into the passenger harness. No light. Will try the other ballasts and bulbs. Possibly I just have all bad fixtures.... thanks for the reply!

    ----------

    Nothing. Any combination of ballasts and bulbs I get nothing. high beams and the little marker light work. Just no low beam. Might I have a bad assembly? Do I really need to take out the good side and start swapping components to know for sure??? ugh! Can you imagine what the dealer would have told me?? bla bla bla blal..... bla bla bla.... $729 to repair :|

    ----------

    I guess I will put the pig back together and just not drive at night until I get a new assembly. Broke right side bumper bolt too. Very excited about that

  5. #4
    EChas3's Avatar
    EChas3 is offline Cadillac Owners Master
    Automobile(s): 2006 STS4 V8 1SG & 2007 STS V8 1SE
    Join Date
    Jun 2008
    Location
    Cedarburg, WI
    Age
    57
    Posts
    7,378

    Re: Headlight out; tried ballast, bulb and fuse... now what???

    IMHO, anyone wanting to do any electrical work on a car needs a good Volt-Ohmeter and know how to use it. A basic digital one can be had for less than $15.

    Diagnosing issues by swapping parts can take a lot of time and ruin good parts.

  6. #5
    stevenriz is offline Cadillac Owners Fanatic
    Automobile(s): 2005 STS4 V8 1SG
    Join Date
    Apr 2009
    Location
    Central MA
    Age
    47
    Posts
    288
    You're right I should have a tester and may go get one today. Question is does anyone know the pin out on the headlight harness? Or do I just test power going to the ballast? Or all of the above?

  7. #6
    stevenriz is offline Cadillac Owners Fanatic
    Automobile(s): 2005 STS4 V8 1SG
    Join Date
    Apr 2009
    Location
    Central MA
    Age
    47
    Posts
    288

    Re: Headlight out; tried ballast, bulb and fuse... now what???

    Got a tester. There doesn't seem to be power going to the ballast. I checked continuity within the headlight itself and the meter is all over the place. I don't know yet if that is ok or not yet. I did notice the connector to the housing is corroded and one contact is very plyable so maybe that is where the problem lies. Can I just order a harness for the housing? I see that it is removable with a good twist of the connector. Housings are pricey on ebay. over $300!! Thoughts?? thanks!!

    ----------

    found the problem. A contact corroded and is still inside the car harness. I hope I can get it out or else I might be in troublem. Why did it have to be the low beam!!!!! Anyway I will report back what I find. Again if you know of a part number for the housing harness please let me know!

  8. #7
    stevenriz is offline Cadillac Owners Fanatic
    Automobile(s): 2005 STS4 V8 1SG
    Join Date
    Apr 2009
    Location
    Central MA
    Age
    47
    Posts
    288
    Bypassed the corrosion with small length of wire. Hope it lasts!!

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting