Nothing working in instrument cluster on a 1999 STS I bought last week.
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 3 of 3
Cadillac STS Forum - 2005 through 2012 Discussion, Nothing working in instrument cluster on a 1999 STS I bought last week. in Past Cadillac Vehicle Discussion; This morning my wife moved her car and later on she went to go to the store and the battery ...
  1. #1
    gpaxtell is offline Cadillac Owners Member
    Automobile(s): 1999Seville STS
    Join Date
    May 2013
    Age
    47
    Posts
    3

    Cool Nothing working in instrument cluster on a 1999 STS I bought last week.

    This morning my wife moved her car and later on she went to go to the store and the battery was dead. I used a jump box to start it and the dash lights , climate control lights nor any dash items are working. I did get a code to pull from the ECM and it is code P 1604-c loss of instrument panel computer data. If someone could please point me in the right direction to look for. I checked all the fuses under the Hood at the main power distribution block and all of them checked good. Is there another fuse box on this particular vehicle? Thank You all in advance for helping this first time Caddie owner out !

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    ddalder's Avatar
    ddalder is offline Cadillac Owners Connoisseur
    Automobile(s): 2008 STS-4 N* 1SG
    Join Date
    Aug 2008
    Location
    Canada
    Posts
    1,769

    Re: Nothing working in instrument cluster on a 1999 STS I bought last week.

    If you're sure that you've checked all the fuses you may want to seek advice from the folks in the Seville/Eldorado forum. This forum is only for 2005+ vehicles and although someone here may have an idea, your best source of information will probably be over there. In 2005 these cars changed dramatically.

  4. #3
    EChas3's Avatar
    EChas3 is offline Cadillac Owners Master
    Automobile(s): 2006 STS4 V8 1SG & 2007 STS V8 1SE
    Join Date
    Jun 2008
    Location
    Cedarburg, WI
    Age
    56
    Posts
    7,044

    Re: Nothing working in instrument cluster on a 1999 STS I bought last week.

    We had a '98. Just before we traded it, the intermittant stuff began to drive my wife nuts. (A short trip.)

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting