Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 3 of 3

Thread: Dealer unable to diagnose problem!

  1. #1
    chachd is offline Cadillac Owners Member
    Automobile(s): 2006 STS, 2006 SRX
    Join Date
    Jun 2011
    Age
    68
    Posts
    15

    Dealer unable to diagnose problem!

    I just got my STS back a week ago from having the short block replaced due to excess oil consumption. I noticed that when I have it on cruise and there is a slight demand for acceleration that I get a buzzy vibration coming from the drive train. This did not occur before the engine change. I took the service manager for a ride to show him and he thought it might be a problem with the torque converter that might need re-programming. I just got a call from the dealer and they think it needs a trans flush and new filter to the tune of $400.00. I just spent $3,400.00 on the engine and don't see how this could help. It doesn't appear that they know either but are searching for a solution. Any ideas anyone?

    2006 STS
    77,000 miles

    Thanks,
    Chach


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Ludacrisvp's Avatar
    Ludacrisvp is offline Cadillac Owners Connoisseur
    Automobile(s): 08 STS4 V8 F55 1SG Euro tails & 01 Monte SS Pace Car
    Join Date
    Feb 2009
    Location
    St Michael, MN
    Age
    30
    Posts
    4,548

    Re: Dealer unable to diagnose problem!

    I would _NOT_ do a trans flush.
    The service manual for the car recommends against doing one ever.
    If you want to get new fluid just "drop the pan" and change the filter then add what you removed fluid wise, never do a flush.
    Honestly I don't think it has anything to do with your trans.

    my money is on a loose heat shield on the exhaust.
    Mine would do it at about 2,800 RPM when in park, or under light accel / certain engine load situations.

    Dealer said to repair it would mean a _full_ exhaust system, to fix it would be simple with a clamp.

    They put the clamp on it and the noise is gone.

    For me it was the passenger side heat shield, one of the welds on the heat shield had failed but it wasn't apparent with a visual inspection until they could get the right RPM info to replicate it.

    Edit:

    Here is a video I recorded of it before it was fixed.
    You might need to turn up your speakers to hear it.
    Video may not work right away as youtube says 'its still being processed'

  4. #3
    Join Date
    Mar 2012
    Location
    columbus ohio
    Posts
    382

    Re: Dealer unable to diagnose problem!

    chachd, The only thing that a transmission re-program will do is make your wallet thinner by $130. I know this first hand. I agree with luda about the clamp on the exhaust pipe. Danny


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum