STS not starting. Did everything possible. Its driving me crazy.
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 17
Cadillac STS Forum - 2005 through 2012 Discussion, STS not starting. Did everything possible. Its driving me crazy. in Past Cadillac Vehicle Discussion; I have a 2005 STS V6. When you try to start the car, everything cuts off and nothing happens. about ...
  1. #1
    crazyburr is offline Cadillac Owners Member
    Automobile(s): STS
    Join Date
    May 2013
    Age
    28
    Posts
    5

    STS not starting. Did everything possible. Its driving me crazy.

    I have a 2005 STS V6. When you try to start the car, everything cuts off and nothing happens. about a min later, everything turns back on, including gauges, and just sits there. I have changed the battery, the starter, the relays, the starter switch. alternator is good. i have no clue what to do next?

    could it be the Neutral safety switch. when i press the brake before starting it, i hear the NSS click. i have shifted car into neutral to try to start it, it wont work. sometimes if i take off one of the battery terminals, it seems like it resets the car and car will start. i have never had it do this to me in the afternoon, only cold starts in the morning.

    i feel like there is a short somewhere causing this. any help would be much appreciated. thank you.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    KRSTS is offline Cadillac Owners Enthusiast
    Automobile(s): Crystal Red 2008 3.6 DI RWD
    Join Date
    Feb 2010
    Location
    Tidewater VA
    Age
    71
    Posts
    942

    Re: Sts not starting. Did everything possible. Its driving me crazy.

    Get it to a dealer. You have probably spent more by throwing parts at it than a dealer visit will cost you.

  4. #3
    curtc's Avatar
    curtc is offline OCD - Obsessive Cadillac Disorder
    Automobile(s): White Diamond 06 STS V8 RWD 1SF F55 HUD/ACC NAV - 126k
    Join Date
    Jul 2005
    Location
    Burnsville, MN
    Age
    28
    Posts
    5,504

    Re: Sts not starting. Did everything possible. Its driving me crazy.

    Is the SES light on? Have you had the codes scanned?
    Past Cadillac's

    2004 CTS 3.6L - 2011-2012
    2001 Seville Touring Sedan - 2006-2011
    1995 Seville Touring Sedan - 2005-2006

  5. #4
    1BadCadSTS's Avatar
    1BadCadSTS is offline Cadillac Owners Connoisseur
    Automobile(s): 05 STS4
    Join Date
    Nov 2010
    Posts
    3,630
    Check all the fuses? Is the security light on?

    Sounds like my rcdlr when I swapped it to one with the secure car feature. I figured I'd try starting it but no luck. Did exactly what you describe. Had to perform the 30 min security relearn then erase and program the fobs.

  6. #5
    crazyburr is offline Cadillac Owners Member
    Automobile(s): STS
    Join Date
    May 2013
    Age
    28
    Posts
    5

    Re: Sts not starting. Did everything possible. Its driving me crazy.

    Quote Originally Posted by curtc View Post
    Is the SES light on? Have you had the codes scanned?
    no ses light on.
    Quote Originally Posted by 1BadCadSTS View Post
    Check all the fuses? Is the security light on?

    Sounds like my rcdlr when I swapped it to one with the secure car feature. I figured I'd try starting it but no luck. Did exactly what you describe. Had to perform the 30 min security relearn then erase and program the fobs.
    no security light on, and all the fuses are good.

    its weird, once u try to turn it on, the message display turns off and it shows nothing.

  7. #6
    dkozloski's Avatar
    dkozloski is offline Cadillac Owners 10000+ Posts
    Automobile(s): 2006 STS V8 AWD, '95 Ford Ranger
    Join Date
    Jul 2004
    Location
    Fairbanks, Ak
    Age
    74
    Posts
    26,547

    Re: Sts not starting. Did everything possible. Its driving me crazy.

    It sounds to me like a data bus communication problem. You need to scan for codes with a scanner sophisticated enough to scan all the codes and not just ECM.
    Don't mess with Binky Bear!


  8. #7
    Carvone is online now Cadillac Owners Fanatic
    Automobile(s): 07 STS 1SG & 03 ESCALADE
    Join Date
    Nov 2008
    Location
    Jacksonville Florida
    Age
    52
    Posts
    178

    Re: Sts not starting. Did everything possible. Its driving me crazy.

    I had an old Eldorado that used to do this exact same thing, ended up being bad grounds. They were all somewhat corroded, dirty, loose, etc. After cleaning and tightening the problem went away.
    Not saying that it is your problem but something to keep in mind.

  9. #8
    crazyburr is offline Cadillac Owners Member
    Automobile(s): STS
    Join Date
    May 2013
    Age
    28
    Posts
    5

    Re: Sts not starting. Did everything possible. Its driving me crazy.

    Quote Originally Posted by dkozloski View Post
    It sounds to me like a data bus communication problem. You need to scan for codes with a scanner sophisticated enough to scan all the codes and not just ECM.
    Ok I will try to get it scanned at Firestone or dealership and see if anything comes up.
    Quote Originally Posted by Carvone View Post
    I had an old Eldorado that used to do this exact same thing, ended up being bad grounds. They were all somewhat corroded, dirty, loose, etc. After cleaning and tightening the problem went away.
    Not saying that it is your problem but something to keep in mind.
    I was thinking that also. Car was in a bad front end collision and has a rebuilt title. does anyone know where the ground points are on this car?

  10. #9
    crazyburr is offline Cadillac Owners Member
    Automobile(s): STS
    Join Date
    May 2013
    Age
    28
    Posts
    5

    Re: Sts not starting. Did everything possible. Its driving me crazy.

    Does anyone know where the ground points are?

  11. #10
    cdezey is offline Cadillac Owners Member
    Join Date
    Sep 2010
    Location
    NY, NY
    Posts
    50
    Check frame rail

    ----------

    Rails

  12. #11
    MoistCabbage's Avatar
    MoistCabbage is online now Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    20,931
    Unibody cars - no "frame rails".

  13. #12
    cdezey is offline Cadillac Owners Member
    Join Date
    Sep 2010
    Location
    NY, NY
    Posts
    50
    Ok maybe its called k frame, but whatever it exactly its called i think its on the left side.

  14. #13
    C&C's Avatar
    C&C
    C&C is offline Cadillac Owners Connoisseur
    Automobile(s): Cadillac STS (2011)
    Join Date
    Feb 2008
    Location
    Mount Pleasant, SC
    Age
    63
    Posts
    1,594

    Re: Sts not starting. Did everything possible. Its driving me crazy.

    Quote Originally Posted by crazyburr View Post
    Does anyone know where the ground points are?
    Here are a couple pictures that show where they are on an '11 STS (but you can follow the negative (ground) cable and they should lead to the grounding points.

    First photo is chassis ground, second photo is engine ground (check for clean and tightness; easy/peasy).




  15. #14
    crazyburr is offline Cadillac Owners Member
    Automobile(s): STS
    Join Date
    May 2013
    Age
    28
    Posts
    5

    Re: Sts not starting. Did everything possible. Its driving me crazy.

    Very helpful C&C. thanks alot.

    I took off chasis ground and sanded down around it and cleaned off bolt since it had some dirt on it. did this on saturday and car has been starting up.

    but just in case, where exactly is the engine ground? driver or passenger side? and is near the motor mounts?

  16. #15
    dannyquest is online now Cadillac Owners Fanatic
    Automobile(s): 06 STS 95,000 miles
    Join Date
    Mar 2012
    Location
    columbus ohio
    Posts
    371

    Re: Sts not starting. Did everything possible. Its driving me crazy.

    crazyburr, Just below the battery and to the right. Danny

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting