Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 5 of 5

Thread: Cold start anomaly - I hope!

  1. #1
    packardv8 is offline Cadillac Owners Fanatic
    Automobile(s): 2011 Saab 9-4X Premium XWD
    Join Date
    Apr 2012
    Posts
    217

    Cold start anomaly - I hope!

    My wife's '11 3.0 with 10kmi usually starts immediately and drives away with no drama. This morning, temperature was in the high 20s, no colder than normal. However, it cranked for quite a while, seeming to hit once in a while. It started roughly then died. On the third try, it started and seemed fine, but the "check engine" light was illuminated. One quick rev with the throttle and it went out. I suspect the O2 sensor was getting a rich reading from the prolonged cranking.

    Anyone had this experience?

    jack vines


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Join Date
    Mar 2010
    Location
    Detroit, USA
    Posts
    12,711

    Re: Cold start anomaly - I hope!

    Jack,
    Sorry to hear that you all had this odd start-up on the SRX. Keep us posted if it happens again! We're happy to work with you through the process of consulting a dealership on the matter.
    Sarah (Assisting Katie), Cadillac Customer Service

  4. #3
    Huey Driver is offline Cadillac Owners Fanatic
    Automobile(s): 2014 ELR
    Join Date
    Sep 2011
    Location
    Fairfax, VA
    Age
    54
    Posts
    311

    Re: Cold start anomaly - I hope!

    Take it in. Even though the Check Engine Light isnt on, the code is probably still there. Might show why the starting problem existed. Usually the light stays illuminated if the trouble CURRENTLY exists. The codes will stay in memory, but the light will go out, if the condition resolves itself. There might be a set period it stays in memory though. I think my old Trailblazer (OBD-II) would age out after 20 starts or something...

  5. #4
    packardv8 is offline Cadillac Owners Fanatic
    Automobile(s): 2011 Saab 9-4X Premium XWD
    Join Date
    Apr 2012
    Posts
    217

    Re: Cold start anomaly - I hope!

    Started as usual this morning.

    If the problem repeats, I'll consider getting an OBDII scan.

    jack vines

  6. #5
    swgyoooo is offline Cadillac Owners Member
    Automobile(s): 2014 CTS Premium 3.6 AWD
    Join Date
    Oct 2012
    Posts
    58

    Re: Cold start anomaly - I hope!

    I had this happen with my 12 one time. Same problems. When it did start, it was running so rough that the check engine light was flashing. I shut it off, started it again, and it was fine. Started, ran, and idled fine...no lights at all. Drove it 3,000 miles after that till I traded it in, and never another problem. I agree that codes can be stored, but I wouldnt make a special trip to the dealer if it is back to normal.


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum