OnStar says I have a problem with my emission system
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 3 of 3
Cadillac SRX First Generation Forum - 2004 - 2009 Discussion, OnStar says I have a problem with my emission system in Cadillac SRX / XT5 Forums; So I get an email from OnStar that says that I have a problem with the vehicles emissions system and ...
  1. #1
    rlh6805 is offline Cadillac Owners Fanatic
    Automobile(s): 2009 SRX AWD 3.6L
    Join Date
    Jun 2012
    Age
    51
    Posts
    326

    OnStar says I have a problem with my emission system

    So I get an email from OnStar that says that I have a problem with the vehicles emissions system and to push the blue button and have the advisor run a diagnostic. I'm game and want to see what they have to say. I call and they run the test and say that everything is ok. Well then, no problem right?? NOT. I then hook up my Tech 2 and pull the codes. Yep!!! P0301; misfire cylinder 1 sitting in pending status. I pull up the misfire graph and see that the counter on #1 reached 75 which must set the code. If it fails the test once more then the MIL will come on. I also notice that #3 has 39 counts so it's creeping up there too. I am still under warranty but figured I'd wait until a MIL is actually illuminated to bring it in. What's the usual suspects for misfires on these engines? I have 58k miles. Coil, plugs, fuel inj?


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    glake89's Avatar
    glake89 is online now Cadillac Owners Connoisseur
    Automobile(s): 05 srx awd v6 (gone), '07 GXP, 2010 li'l red wagon 3.6
    Join Date
    Aug 2010
    Location
    Interlochen,MI
    Age
    82
    Posts
    2,947

    Re: OnStar says I have a problem with my emission system

    I'm going to say coils, likely wiring connections.
    __________________________________________________ ________________

    This site is too much fun to not be a supporter
    Been fixin' cars for 74 years
    Some of what I know comes from experience, some from reading or listening,-most of it, I just make up

  4. #3
    rlh6805 is offline Cadillac Owners Fanatic
    Automobile(s): 2009 SRX AWD 3.6L
    Join Date
    Jun 2012
    Age
    51
    Posts
    326
    Thread Starter

    Re: OnStar says I have a problem with my emission system

    Quote Originally Posted by glake89 View Post
    I'm going to say coils, likely wiring connections.
    More than likely.

  5. Remove Advertisements
    Cadillac Forums
    Advertisements
     

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

What Cadillac(s) do you own? (Or type NONE)

Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •