Suspension Problem
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 3 of 3
Cadillac Seville / Cadillac Eldorado Forum Discussion, Suspension Problem in Past Cadillac Vehicle Discussion; I have 97 seville and sometimes suspesnsion feel like heaven but too often it feel like no Cadillac at all. ...
  1. #1
    TomFlag is offline Cadillac Owners Member
    Join Date
    Mar 2004
    Posts
    11

    Angry Suspension Problem

    I have 97 seville and sometimes suspesnsion feel like heaven but too often
    it feel like no Cadillac at all. Front struts feel like they hit hard end and
    you feel all bumps of roads . I havent any trouble codes for suspension and there isnt any messages for "service ride control". So is this typical
    problem that struts are finnish or something else, please help guys...?

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    NoFear365@yahoo.com's Avatar
    NoFear365@yahoo.com is offline Cadillac Owners Fanatic
    Join Date
    Oct 2003
    Location
    Staten Island, NY
    Age
    35
    Posts
    327

    Re: Suspension Problem

    My dad has a 97 SLS as well. His car currently rides like an IROC. It's horrible. He ordered 2 new struts and shocks from Arnott yesterday. They should be here by Wednesday. Hopefully this will help.

    I'll keep you posted.

    P.S. It ran him 800 for the 2 struts (passive of course), strut mounts, and 2 shocks.

  4. #3
    addison_ii's Avatar
    addison_ii is offline Cadillac Owners Connoisseur
    Automobile(s): 1994 Sedan Deville
    Join Date
    Mar 2005
    Location
    Twin Cities, Minnesota
    Age
    33
    Posts
    2,146

    Re: Suspension Problem

    Check the stabalizer bar end links and(or) bushings. These seem to be the common cause for the symptons you describe. As another possiblity it could be the strut mount bushing as well.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting