99 SLS Tranny ?????
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 15 of 15
Cadillac Seville / Cadillac Eldorado Forum Discussion, 99 SLS Tranny ????? in Past Cadillac Vehicle Discussion; Hello everyone, I have a question hopefully someone could help me out with this one, I've been searching the forum ...
  1. #1
    White99SLS is offline Cadillac Owners Member
    Automobile(s): 1999 Seville SLS
    Join Date
    Feb 2006
    Location
    Long Island, NY
    Posts
    79

    99 SLS Tranny ?????

    Hello everyone, I have a question hopefully someone could help me out with this one, I've been searching the forum but can't seem to find it. I just recently purchased a 99 SLS and the transmission was working fine up until today. I recently did a few WOT to clear out the oil consumption problem and now the transmission is acting funny. When I drive normal the car runs fine, but if I get on it a little the car starts to shudder a little. From a stop if I mat the gas with the traction control ON the car screeches the tire a little and starts to get up and go. If I take the traction control OFF and I mat the gas from a stop the car goes but it shudders a little and gets up to speed slower than normal it doesn't rev up but while I'm doing that if I turn the traction control back ON the car revs up and goes, like when you put a good load on it it starts to shudder, pretty weird to me, hopefully I'm giving you guys a good description of whats goin on. Anyway does anyone know what this might be?? Any help would be greatly appreciated...........

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    White99SLS is offline Cadillac Owners Member
    Automobile(s): 1999 Seville SLS
    Join Date
    Feb 2006
    Location
    Long Island, NY
    Posts
    79

    Re: 99 SLS Tranny ?????

    It's almost like the tranny slips with the traction control switched OFF but with it on it seems to grab, in between 40 to 44 miles per hour if i go to give the car light gas it starts to shudder a little then it starts to run somewhat ok, anyone have any ideas on what might that be, do I have a failing transmission on my hands or could it be something else, the car has 52,000 miles on it.........

  4. #3
    White99SLS is offline Cadillac Owners Member
    Automobile(s): 1999 Seville SLS
    Join Date
    Feb 2006
    Location
    Long Island, NY
    Posts
    79

    Re: 99 SLS Tranny ?????

    After searching hard through this great forum I think I might of found the answer through this post........

    http://www.cadillacforums.com/forums...ine-trans.html

    From what I get from the post hopefully its only the wires, is it only the 95-97 yr cars with the wire problem or could it be the same for my 99, sorry if this is a stupid question but can doing WOT bursts cause the wires to go bad? I believe the car might not of been driven hard before I bought it because when I did do some of those WOT's a lot of black was coming out the back of the car, it's cleared up now and oil consumption is def down....Looks like I have more searching to do to find info on these wires, as I mentioned earlier any info would be greatly appreciated...........

  5. #4
    mtflight's Avatar
    mtflight is offline Cadillac Owners Connoisseur
    Automobile(s): 1999 White Diamond ETC
    Join Date
    Jan 2005
    Location
    Dallas, TX
    Posts
    2,531

    Re: 99 SLS Tranny ?????

    Traction control off, starts the car in 2nd gear--no 1st.

    This means it is in the wrong gear, essentially, when starting from low speed... It's like doing a WOT on a car, off the line, in 3rd gear.

  6. #5
    White99SLS is offline Cadillac Owners Member
    Automobile(s): 1999 Seville SLS
    Join Date
    Feb 2006
    Location
    Long Island, NY
    Posts
    79

    Re: 99 SLS Tranny ?????

    Well from what I'm gathering with the spark plug wires, I don't know if this is right but with the traction control off theres more load and thats why the car doesn't go anywhere because of the bad wires. Now with the trac control on the car compensates somehow to take the load off so the tires won't spin out....hopefully that sounds right, if not sorry, I'm still learning................When I pulled out one of the wires the rubber looked like it had rust on it and down in the spark plug cavity it looked dirty and some what rusty, it's making me think now more and more its def not the tranny and more those wires, anyone know the part numbers for the spark plugs and the wires?

  7. #6
    White99SLS is offline Cadillac Owners Member
    Automobile(s): 1999 Seville SLS
    Join Date
    Feb 2006
    Location
    Long Island, NY
    Posts
    79

    Re: 99 SLS Tranny ?????

    Just to update, I took a look at the spark plugs and they look okay for 52,000, I borught it to the parts store to show the person there and see what they think and they said it was ok as well but looked like they showed signs of the car running a little lean. With very light throttle at around 40 mph I did hear some popping coming from underneath the hood of the car, so now I'm thinking some type of fuel problem, possibly the filter or maybe the throttle body is dirty, I did feel it stick a few times when I went to drive away and then work fine. Does anyone know where the filter is located on a 99 SLS and if it's difficult to replace. Maybe its something else........AHH it's frustrating, I just want her to run right..........Any info would be greatly appreciated................

  8. #7
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,358

    Re: 99 SLS Tranny ?????

    Plugs are A/C Delco 41-950. Make sure all the plugs have the little platinum tips on both electrodes. They tend to come off and that will widen the gap. Stick with A/C Delco wires if you replace them. You can get a good price at http://www.rockauto.com.

    Your discription sounds exactly like mine. Even the "Popping". My money is on the wires and maybe plugs.

  9. #8
    White99SLS is offline Cadillac Owners Member
    Automobile(s): 1999 Seville SLS
    Join Date
    Feb 2006
    Location
    Long Island, NY
    Posts
    79

    Re: 99 SLS Tranny ?????

    The autoparts store by me doesn't have the AC delco wires instock and i'd have to wait till Monday to get them, is it possible to use other wires or am I looking for trouble, I'd rather not wait around, I like taking care of things as fast as possible so if I can use other wires I would but if its worth it to wait then I will................

  10. #9
    mtflight's Avatar
    mtflight is offline Cadillac Owners Connoisseur
    Automobile(s): 1999 White Diamond ETC
    Join Date
    Jan 2005
    Location
    Dallas, TX
    Posts
    2,531

    Re: 99 SLS Tranny ?????

    Quote Originally Posted by White99SLS
    The autoparts store by me doesn't have the AC delco wires instock and i'd have to wait till Monday to get them, is it possible to use other wires or am I looking for trouble, I'd rather not wait around, I like taking care of things as fast as possible so if I can use other wires I would but if its worth it to wait then I will................
    I'd say it's worth the wait. The Northstar is very particular when it comes to wires and plugs, getting non OEM is asking for trouble. Try finding another dealer through ACdelco.com

  11. #10
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,358

    Re: 99 SLS Tranny ?????

    Quote Originally Posted by mtflight
    I'd say it's worth the wait. The Northstar is very particular when it comes to wires and plugs, getting non OEM is asking for trouble. Try finding another dealer through ACdelco.com

    Rockauto has very fast shipping.

  12. #11
    White99SLS is offline Cadillac Owners Member
    Automobile(s): 1999 Seville SLS
    Join Date
    Feb 2006
    Location
    Long Island, NY
    Posts
    79

    Re: 99 SLS Tranny ?????

    Ordered from Rockauto.com, $150.38 for AC Delco wires and Delco plugs used the 5% discount code........Will update when I receive the parts and install them....Thanks everyone..............

  13. #12
    White99SLS is offline Cadillac Owners Member
    Automobile(s): 1999 Seville SLS
    Join Date
    Feb 2006
    Location
    Long Island, NY
    Posts
    79

    Re: 99 SLS Tranny ?????

    I received the parts from rockauto, was supposed to come tomorrow but they came today, installation took about and hour and a half, she runs like a champ now. With only 52,000 miles on the clock it was, after all, the plugs and wires, now its time to take a look at that throttle body and see if she needs some cleaning. Not to change threads but if I take off from the line with the traction disabled, the car isn't going to take off from first gear, why is that, is that just how the car is programmed? Because from the line I have more power with the traction control engaged and when I switch it off, it doesn't take off as fast?

  14. #13
    iametarq's Avatar
    iametarq is offline Cadillac Owners Connoisseur
    Automobile(s): None
    Join Date
    Dec 2004
    Location
    Petoskey, MI
    Age
    33
    Posts
    3,289

    Re: 99 SLS Tranny ?????

    Thanks for posting your results. I'm due for plugs and wires, by my milage, but I don't have any running problems. The $150 for parts and 1.5 hours labor doesn't sound bad at all.

  15. #14
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,358

    Re: 99 SLS Tranny ?????

    At 52K I can guarantee your TB is in need of cleaning. You'll be shocked when you see it. After my first time, it has become a spring ritual. Disabling the TC diasables 1st gear. It is intentional and is meant to be used when stuck in the snow.

  16. #15
    White99SLS is offline Cadillac Owners Member
    Automobile(s): 1999 Seville SLS
    Join Date
    Feb 2006
    Location
    Long Island, NY
    Posts
    79

    Re: 99 SLS Tranny ?????

    Thanks Ranger, I was going to take a look at it yesterday but didn't get the chance, I'm pretty sure it needs a good cleaning because everynow and then the gas pedal sticks a little as I drive off from being parked overnight............

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting