Post Engine Swap Bugs/Issues
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 7 of 7
Cadillac Seville / Cadillac Eldorado Forum Discussion, Post Engine Swap Bugs/Issues in Past Cadillac Vehicle Discussion; Hey guys, i was hoping i could get some insight to some issues i am having after replacing the motor ...
  1. #1
    Jays03dsg is offline Cadillac Owners Member
    Automobile(s): 2002 Seville STS
    Join Date
    Jan 2005
    Posts
    31

    Post Engine Swap Bugs/Issues

    Hey guys, i was hoping i could get some insight to some issues i am having after replacing the motor due to the infamous head gasket issue. After having a friend complete the swap the car drives fine except for a rough idle which i think is due to an intake gasket not being seeded correctly. The more important issues i am having i will describe below with attached visuals, although they are strictly electric so i am assuming there could be some faulty sensors that were connected.

    1. For my "gauge cluster" picture, the following items are not working at all: Speedometer, Tachometer, Trip odometers, and the display that keeps track of the total miles on the bottom left of the picture. Also, none of the other information on the DIC message area works either (outside temp, battery voltage, instant mpg, total mpg, etc...) the only thing that shows up is the "check tire pressure" and "service air bag" message. The actual Temperature and Gas gauge work fine.

    2. For the rear view "mirror" picture, it does not display the direction in the top right corner, and the On Star buttons are not activated, in addition to there being a red light displayed, rather than a green light.

    3. For the images that show both of the "DIC Buttons", none of them work at all to display any of the information that is normally found within the actual DIC message display.

    4. My Reverse Sensing system along with the "3-Dot" display above the rear seat is not working when i put the car in reverse.

    5. When i try to use my blinkers, they do not work. I only get the front blinker lamp to stay on constantly (until i have either completed a turn or turn the blinker stick off on the steering column), but none of the rear blinker lamps function at all.

    6. I went to use my emergency brake last night, and when i was leaving and put my car into gear, the pedal itself did not return to its normal position. I had to get under the dash on the drivers side and manually unlock it by pulling on the yellow safety tab located behind it.

    I have not come up with any other issues that i could think of after driving it around the past few days, but these are the main issues i have thus far. Any information/insight/advice would be very grateful and much appreciated.
    Thanks guys!!
    Attached Images

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    maeng9981's Avatar
    maeng9981 is offline Cadillac Owners Connoisseur
    Automobile(s): 14 SRX, 12 Sierra, 00 SLS, 99 Deville 50-year Anniversary
    Join Date
    Mar 2009
    Location
    Dallas, TX
    Age
    23
    Posts
    3,188

    Re: Please Help....Post Engine Swap Bugs/Issues

    It seems like there's a Class II communications issue. Are you able to pull codes?

  4. #3
    2manyhotrods's Avatar
    2manyhotrods is offline Cadillac Owners Fanatic
    Automobile(s): 1999 Eldorado ETC coupe.
    Join Date
    Jun 2013
    Location
    Massachusetts
    Posts
    297

    Re: Please Help....Post Engine Swap Bugs/Issues

    Emergency brake not releasing and rough idle point to vacuum leak. Some hose not connected?

  5. #4
    Jays03dsg is offline Cadillac Owners Member
    Automobile(s): 2002 Seville STS
    Join Date
    Jan 2005
    Posts
    31

    Re: Please Help....Post Engine Swap Bugs/Issues

    Quote Originally Posted by maeng9981 View Post
    It seems like there's a Class II communications issue. Are you able to pull codes?
    I am not able to pull any codes from the DIC buttons, and i dont have a handheld code scanner. I will try to stop by and Advanced Auto Parts and see if they are able to pull anything and post with an update when that is complete

    ----------

    Quote Originally Posted by 2manyhotrods View Post
    Emergency brake not releasing and rough idle point to vacuum leak. Some hose not connected?
    I checked under the hood and everything seemed to be connected, but will do some double checking just to make sure.

  6. #5
    basscatt's Avatar
    basscatt is online now Cadillac Owners 10000+ Posts
    Automobile(s): 89 Coupe DeVille, 95 Sedan DeVille, 03 SLS, two 02 DHS's
    Join Date
    Feb 2004
    Location
    Minnesota
    Age
    63
    Posts
    10,101

    Re: Please Help....Post Engine Swap Bugs/Issues

    Quote Originally Posted by 2manyhotrods View Post
    Emergency brake not releasing and rough idle point to vacuum leak. Some hose not connected?
    --------------------------
    parking brake release not vacuum operated in an 02 Seville -

    =========================

    assuming nothing was done on the inside of the car -
    I suspect a couple/few GROUNDS were not re-connected -

    or something was knocked loose at the under hood fuse box -

  7. #6
    Jays03dsg is offline Cadillac Owners Member
    Automobile(s): 2002 Seville STS
    Join Date
    Jan 2005
    Posts
    31

    Re: Post Engine Swap Bugs/Issues

    I stopped at Advanced Auto to have them pull the codes.... there was only one instance for C1246 - "Brake lining sensor open circuit message"; and the remaining nine were multiples of the codes below:
    P0300 - "Cylinder Misfire Detected Random Cylinders"
    P0449 - "Evaporative Emission Vent Valve Solenoid Malfunction"
    P0650 - "Malfunction Indicator Lamp Control Circuit Malfunction"

    I am going to assume because of the multiples, this is quite possibly from the intake gasket as i had to replace the battery tonight and it is still hard to turn over to start in addition to the rough idle/hesitation of the new motor.

    As far as the other issues, i will check the fuses and see if that helps with the DIC buttons & Speedo/Tachometer

    ----------

    Quote Originally Posted by basscatt View Post
    --------------------------
    parking brake release not vacuum operated in an 02 Seville -

    =========================

    assuming nothing was done on the inside of the car -
    I suspect a couple/few GROUNDS were not re-connected -

    or something was knocked loose at the under hood fuse box -
    Basscatt, you assumed correctly, as there was nothing that was done on the inside of the car

  8. #7
    rodnok01's Avatar
    rodnok01 is online now Cadillac Owners Connoisseur
    Automobile(s): 98 DeVille, 97 DeVille d'Elegance
    Join Date
    Feb 2012
    Location
    NC
    Posts
    3,927
    Grounds, fuses and connections first off. Way too many things to miss when putting them back together and knowing th ey were tools...

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting