96 Seville Theft Deterrent Problem
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 12 of 12
Cadillac Seville / Cadillac Eldorado Forum Discussion, 96 Seville Theft Deterrent Problem in Past Cadillac Vehicle Discussion; After car wouldn't start because of bad battery one night, replaced battery, but all it will do is crank - ...
  1. #1
    fmw63 is offline Cadillac Owners Member
    Automobile(s): 1996 Seville SLS
    Join Date
    Nov 2003
    Location
    Hyattsville, MD
    Posts
    27

    96 Seville Theft Deterrent Problem

    After car wouldn't start because of bad battery one night, replaced battery, but all it will do is crank - not start.
    The DIC shows Theft Deterrent message. Had car towed to a local Chevy dealer (the Cadillac dealer was booked for the
    whole next week). They determined (incorrectly) that the problem was the ignition lock cylinder. Actually it was bad,
    but had already done the VATS bypass. They changed the lock cylinder and keys, and supposedly reprogrammed it, but
    still won't start. Before, the code was a P1631. Now when I check codes, there are several: IP1552, PC1631, PC1632, IP2750, and an SD1026. But the thing is, all are history - no current codes. I've installed the Newrockies Pro module to bypass this system, but that hasn't worked either. Neither has doing the 10/10/10 relearn procedure. Is it
    now just a matter of changing parts (PCM or IPC) and trying again? Really can't afford hours and hours of dealer diag time plus parts right now...

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    MoistCabbage's Avatar
    MoistCabbage is offline Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    20,832
    VATS disables the fuel pump and starter, so that's not the issue.

    Post the code definitions, they're meaningless without them.

    Fuel pump running? Spark?

  4. #3
    fmw63 is offline Cadillac Owners Member
    Automobile(s): 1996 Seville SLS
    Join Date
    Nov 2003
    Location
    Hyattsville, MD
    Posts
    27

    Re: 96 Seville Theft Deterrent Problem

    Oh yeah, forgot. fuel pump & spark ok (says Pep Boys).

    codes:
    DTC P1631 Theft Deterrent Start Enable Signal Not Correct
    DTC P1632 Theft Deterrent Fuel Disable Signal Received
    DTC B2750 PASSKey Data Communication Failure
    IP1552 = Loss of KAM


    but all are history, no current codes

  5. #4
    fmw63 is offline Cadillac Owners Member
    Automobile(s): 1996 Seville SLS
    Join Date
    Nov 2003
    Location
    Hyattsville, MD
    Posts
    27
    help! anybody?

  6. #5
    MoistCabbage's Avatar
    MoistCabbage is offline Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    20,832
    Was the fuel pressure checked, or did they just check that the pump was running.

    You fuel and spark, something should be happening.

  7. #6
    fmw63 is offline Cadillac Owners Member
    Automobile(s): 1996 Seville SLS
    Join Date
    Nov 2003
    Location
    Hyattsville, MD
    Posts
    27
    They did check fuel pressure, was ok. "starting disabled" theft deterrent message still there, but no current codes

  8. #7
    fmw63 is offline Cadillac Owners Member
    Automobile(s): 1996 Seville SLS
    Join Date
    Nov 2003
    Location
    Hyattsville, MD
    Posts
    27
    Need some help here guys!

  9. #8
    oldstuff is offline Cadillac Owners Fanatic
    Automobile(s): 66 convert-93-96-97-97-99 Eldorados
    Join Date
    Nov 2013
    Location
    McCleary Wa.
    Age
    78
    Posts
    361

    Re: 96 Seville Theft Deterrent Problem

    Sounds very much like the situation I had. Theft deterent message, Had fuel pressure, Starter would spin the engine but no start, no codes. Turned out to be a ground wire off at the passenger end of the transmission.
    Dave


    Quote Originally Posted by fmw63 View Post
    They did check fuel pressure, was ok. "starting disabled" theft deterrent message still there, but no current codes

  10. #9
    MoistCabbage's Avatar
    MoistCabbage is offline Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    20,832
    What kind of "bypass" is this Newrockies thing? If VATS is fully disabled, the message shouldn't display. And if it does display, the starter and fuel pump shouldn't be working. If someone played with the VATS system, other electrical issues could be causing the no start condition.

  11. #10
    fmw63 is offline Cadillac Owners Member
    Automobile(s): 1996 Seville SLS
    Join Date
    Nov 2003
    Location
    Hyattsville, MD
    Posts
    27

    Re: 96 Seville Theft Deterrent Problem

    Guess I have to check some wires, then. Thanks for the idea.

  12. #11
    fltdriver is offline Cadillac Owners Fanatic
    Automobile(s): 1999 ELdorado
    Join Date
    Feb 2014
    Posts
    103

    Re: 96 Seville Theft Deterrent Problem

    Your TDM could be bad. (Theft Deterrent Module)

  13. #12
    fmw63 is offline Cadillac Owners Member
    Automobile(s): 1996 Seville SLS
    Join Date
    Nov 2003
    Location
    Hyattsville, MD
    Posts
    27

    Re: 96 Seville Theft Deterrent Problem

    checked cables again. seemed ok there. battery needed a jump - was getting run down. left it charging while checking for codes and doing relearn procedure again. Now getting some current codes finally: IP2750 PASS-KEY II Data Communication Failure and a PZ1558 BCM EPROM Checksum Error.

    Is this looking like a bad bcm?

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting