No Sound From Radio
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 5 of 5
Cadillac Seville / Cadillac Eldorado Forum Discussion, No Sound From Radio in Past Cadillac Vehicle Discussion; I have a 1995 STS. Everything on the radio acts like it wants to work(Bose Gold Series). I followed the ...
  1. #1
    stevenm is offline Cadillac Owners Member
    Join Date
    Jun 2005
    Posts
    14

    No Sound From Radio

    I have a 1995 STS. Everything on the radio acts like it wants to work(Bose Gold Series). I followed the flow chart in the shop manual and still nothing comes from the speakers. Any Ideas??

    Steven in Denver,

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    cruzajc1's Avatar
    cruzajc1 is offline Cadillac Owners Enthusiast
    Join Date
    Apr 2004
    Posts
    500

    Re: No Sound From Radio

    let me know what you find out, do you hae the Bose 12 CD changer with cassette?

  4. #3
    RatRacer is offline Cadillac Owners Member
    Join Date
    Jan 2006
    Posts
    1

    Re: No Sound From Radio

    Did you find a solution to this problem? I just got my vehicle back from 1 day in a repair shop where they ran the battery dead, charged it, & now same thing, NO SOUND! All functions of Head Unit are working, appears to be no Amplifier. Checked fuses under seat & all are fine... Anything else I should be looking at???

  5. #4
    mtflight's Avatar
    mtflight is offline Cadillac Owners Connoisseur
    Automobile(s): 1999 White Diamond ETC
    Join Date
    Jan 2005
    Location
    Dallas, TX
    Posts
    2,526

    Re: No Sound From Radio

    Guys, pull the codes.

    After replacing the blower motor I accidentally did not seat one of the grounds properly, and I had the same symptoms you describe.

    The radio comes on and does it's things, but completely quiet. The codes reported a ground missing and something having to do with the serial link line. No communications from Amp.

    I re seated the ground, and it started working like nothing happened.

  6. #5
    irebroff's Avatar
    irebroff is offline Cadillac Owners Member
    Automobile(s): Seville STS 1999
    Join Date
    Nov 2005
    Location
    Germany - Bavarian
    Posts
    86

    Re: No Sound From Radio

    Clear All Codes than it could be working again!

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting