Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 4 of 4

Thread: 83 eldorado accessory ticking, stumped

  1. #1
    jhowson1108 is offline Cadillac Owners Member
    Automobile(s): 1983 eldorado 4.1
    Join Date
    Dec 2013
    Age
    24
    Posts
    2

    83 eldorado accessory ticking, stumped

    Hi all new here, Ive got an eldorado with a 4.1. I replaced a valve cover last week and in the process i removed the outlet hose on the vacuum pump. After completing the repair i started the car and a very loud, rpm dependent tick was noticable. It is coming from the vacuum pump. If i remove the vacuum pumps belt or plug the intake hose to the pump the sound goes away. But ive already replaced the vacuum pump twice and still the same ticking. Any ideas? Or experience?


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    carnut is offline Cadillac Owners Master
    Automobile(s): 1999 BMW 740 Il. 2005 Jag XK8, 1988 Mercedes Benz 300 SE
    Join Date
    Feb 2003
    Location
    california
    Age
    69
    Posts
    6,688

    Re: 83 eldorado accessory ticking, stumped

    Replaced twice? by that do you mean new ones? My 84 sedan had that same noise at mid throttle RPM in park when I bought it. I replaced the pump with a new one and the noise quit.

  4. #3
    jhowson1108 is offline Cadillac Owners Member
    Automobile(s): 1983 eldorado 4.1
    Join Date
    Dec 2013
    Age
    24
    Posts
    2

    Re: 83 eldorado accessory ticking, stumped

    yea, i replaced it with a parts store new one then a rebuilt one offline and no change between all 3

  5. #4
    carnut is offline Cadillac Owners Master
    Automobile(s): 1999 BMW 740 Il. 2005 Jag XK8, 1988 Mercedes Benz 300 SE
    Join Date
    Feb 2003
    Location
    california
    Age
    69
    Posts
    6,688

    Re: 83 eldorado accessory ticking, stumped

    A shot in the dark, but the vacuum pump hose goes to a metal manifold above the driver exhaust manifold. Are there any hoses split or disconnected there? Maybe with a hose off the pump has less internal pressure and might knock.


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum