Ignition/Abs/Traction/Trans/Belt fun stuff issues for the newbie
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 4 1 2 3 4 LastLast
Results 1 to 15 of 52
Cadillac Seville / Cadillac Eldorado Forum Discussion, Ignition/Abs/Traction/Trans/Belt fun stuff issues for the newbie in Past Cadillac Vehicle Discussion; so i bought a 96 Cadillac Eldorado ETC about 2 months ago. Sold my 09 ninja and bought this car ...
  1. #1
    frenzicadi's Avatar
    frenzicadi is offline Cadillac Owners Member
    Automobile(s): 1996 Cadillac Eldorado ETC
    Join Date
    Oct 2013
    Location
    staten island ny
    Posts
    31

    Ignition/Abs/Traction/Trans/Belt fun stuff issues for the newbie

    so i bought a 96 Cadillac Eldorado ETC about 2 months ago. Sold my 09 ninja and bought this car for 1300. has approx 139K miles and shes beautiful, black on black, tinted windows, power power power.
    My work done on the car so far:
    Oil change with part synthetic and k&n filter.
    I am a newbie so i couldnt find this stuff posted on here, and so here are my issues.

    1: Recently and I mean a week ago this noise started from the "belt" area. Its a high, loud screeching noise. its ear deafening, and you cannot put your head down near the belts without being pained to the high heavens. I was driving for a good 30 minutes when it first started. parked it, turned on the next morning and it started again, only to stop once the car was warmed up. i put belt conditioner on it and it still does it every time i havent started the car when the car is cold. im told it could be a seized pulley but i see nothing seized it may be the "adjuster pulley" because i cant see it. opinions?
    2. I have lights on; service engine soon, traction control, and ABS.
    these are my codes:

    P0154 02 Sensor Circuit No Activity Detected (Bank 2 Sensor 1)
    P0155 02 Sensor Heater Circuit Malfunction (Bank 2 Sensor 1)
    P0441 Evaporative Emission Control System Incorrect Purge Flow
    P1350 Ignition Control System
    IP1910
    TC0027

    my thoughts - i need an ignition module - abs/traction module - and oxygen senson - but those are mere guesses.

    3. Car sometimes takes a while to start, it will crank and crank and crank ill stop... again crank crank and start, and sometimes starts right away.

    4. Some mornings i crank the car and i hear a Loud! bang either under the car or kinda under the hood, sounds like a exhaust misfire, im not sure. but it will still start.
    the car has never stalled and never not started in the mornings, just lil things here and there like what i explained.

    5. It kinda seems like it doesnt start hard, i read something that it starts in 2nd gear which would make sense because theres no power off the line, however, by 30-40 if i press down, she flies.

    6. sometimes she bogs, shakes kinda, and then half hesitates after i stand for about 10 minutes without moving and i start driving. doesnt stay the whole time.

    some things that come up on the display is, emissions problem, and ignition problem.

    7. car does not blow HOT air through floor vents on drivers side, passenger works fire and isnt HOT but warm enough to keep me warm during this crazy NY weather. but the fact that my feet dont get warm when i drive annoys me. what could cause this? also, rear vents dont work, you hear it on and you feel a vibration on the shifter, but no air coming out the back.

    8. sometimes the air doesnt turn on at all, i have to keep playing with it over and over off and on low high and eventually it turns on.

    9. cruise control doesnt work. when i first got the car and i got it home, next day opened the hood, i saw the line that runs from the cruise control loose, i connected it correctly, it worked once, and hasnt worked since.

    10. Last but not least, i realized that the automatic pull down wasnt working on the trunk, so one day while i was changing the oil i opened up the back, saw that the wire was disconnected, i connected it and the metal piece that the trunk latches onto went up electronically. i closed the trunk but it didnt close, im guessing its a bad switch. but now my trunk is latched down and left with a gap open. i can open and close the trunk but it wont go all the way down again, its snowing out here and it'll be a little bit till i can get my hands on another switch, is there
    a way i can get that metal piece to go down and close for now??

    ok, i think thats it for now, any help would be incredibly appreciated!!!!!!! this is going to be my daily driver and im in love already, i want her to last me the winter with no problems and i want to fix her ASAP

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Aztec ETC ECS's Avatar
    Aztec ETC ECS is offline Cadillac Owners Connoisseur
    Automobile(s): '02 ETC ECS#533, '05 Escalade, '05 AWD Magnum, '74 455 OLDS
    Join Date
    Feb 2012
    Location
    NYC
    Age
    47
    Posts
    1,828

    Re: Ignition/Abs/Traction/Trans/Belt fun stuff issues for the newbie

    Did you buy this car in Brooklyn?

  4. #3
    frenzicadi's Avatar
    frenzicadi is offline Cadillac Owners Member
    Automobile(s): 1996 Cadillac Eldorado ETC
    Join Date
    Oct 2013
    Location
    staten island ny
    Posts
    31

    Re: Ignition/Abs/Traction/Trans/Belt fun stuff issues for the newbie

    Long Island - guy has a yard full of ambulances - taxis - and a few cars. im guessing this car sat for a few months cuz when i bought it, i turned it off to turn it back on but the battery was dead. we jumped it, drove the 50 miles home, battery hasnt died since

  5. #4
    Aztec ETC ECS's Avatar
    Aztec ETC ECS is offline Cadillac Owners Connoisseur
    Automobile(s): '02 ETC ECS#533, '05 Escalade, '05 AWD Magnum, '74 455 OLDS
    Join Date
    Feb 2012
    Location
    NYC
    Age
    47
    Posts
    1,828

    Re: Ignition/Abs/Traction/Trans/Belt fun stuff issues for the newbie

    Your first 3 guesses sound reasonable.
    Could get costly changing parts.
    You also have an evap & hvac issue.
    One of the switches on the pulldown may be in the wrong position. If not, you can take it apart & adjust it down & leave it unplugged.

  6. #5
    frenzicadi's Avatar
    frenzicadi is offline Cadillac Owners Member
    Automobile(s): 1996 Cadillac Eldorado ETC
    Join Date
    Oct 2013
    Location
    staten island ny
    Posts
    31

    Re: Ignition/Abs/Traction/Trans/Belt fun stuff issues for the newbie

    it seems like the metal part that latches onto the trunk is worked by a motor- that i cant get running because it is now not getting a signal from the switch to go down - how do i get it down?
    as for parts... i found an ignition module (ICM) on ebay for $54 free shipping which seems considerably lower than the 200 market price everywhere else. $100 for a ebtcm which apparently fixes the abs/traction
    issue and gives me back first gear.
    oxygen sensor looking to be 20 bucks... and the switch is also 20.... so its not Terrrrrrible pricing and some i can even do myself for the most part
    any word on my other issues

  7. #6
    Aztec ETC ECS's Avatar
    Aztec ETC ECS is offline Cadillac Owners Connoisseur
    Automobile(s): '02 ETC ECS#533, '05 Escalade, '05 AWD Magnum, '74 455 OLDS
    Join Date
    Feb 2012
    Location
    NYC
    Age
    47
    Posts
    1,828

    Re: Ignition/Abs/Traction/Trans/Belt fun stuff issues for the newbie

    The metal tab on the latch moves a small switch. If it is down, pop it up (small round thing in center of pic).


  8. #7
    frenzicadi's Avatar
    frenzicadi is offline Cadillac Owners Member
    Automobile(s): 1996 Cadillac Eldorado ETC
    Join Date
    Oct 2013
    Location
    staten island ny
    Posts
    31

    Re: Ignition/Abs/Traction/Trans/Belt fun stuff issues for the newbie

    the metal thing on the right of the picture went up when i connected the 5 pin flat wire to the switch. i then shut the trunk and it didnt close. i opened it back up and the switch just isnt working, its not bringing the trunk down. meaning the little circle piece in the middle doesnt move up and down, just up, so now its stuck open a gap cuz the metal piece on the right isnt going back down. the switch doesnt work to bring it down so confused

  9. #8
    frenzicadi's Avatar
    frenzicadi is offline Cadillac Owners Member
    Automobile(s): 1996 Cadillac Eldorado ETC
    Join Date
    Oct 2013
    Location
    staten island ny
    Posts
    31
    Oh. And my techometer doesn't work, the rpm meter... Any known quick fixes or is it linked to one of my various issues?

  10. #9
    Aztec ETC ECS's Avatar
    Aztec ETC ECS is offline Cadillac Owners Connoisseur
    Automobile(s): '02 ETC ECS#533, '05 Escalade, '05 AWD Magnum, '74 455 OLDS
    Join Date
    Feb 2012
    Location
    NYC
    Age
    47
    Posts
    1,828

    Re: Ignition/Abs/Traction/Trans/Belt fun stuff issues for the newbie

    Take the pulldown apart, crank down by hand (not all the way) & leave it unplugged.
    Then you can move on to the rest of your problems.

  11. #10
    frenzicadi's Avatar
    frenzicadi is offline Cadillac Owners Member
    Automobile(s): 1996 Cadillac Eldorado ETC
    Join Date
    Oct 2013
    Location
    staten island ny
    Posts
    31

    Re: Ignition/Abs/Traction/Trans/Belt fun stuff issues for the newbie

    gonna go do that right now.

  12. #11
    Harry Yarnell is offline Cadillac Owners Fanatic
    Automobile(s): 2005 XLR, '96 eldo,'95 eldo,' 89 eldo,'78 eldo,'11CTS-V
    Join Date
    Dec 2004
    Location
    perryman, MD
    Age
    70
    Posts
    457

    Re: Ignition/Abs/Traction/Trans/Belt fun stuff issues for the newbie

    The trunk pulldown issue Is a common problem. It's in the little black box part of the pulldown; dirty contacts. They can be repaired by removing the black box (T-15 torx screw and release of a clip by the electrical connector). Drill out the three rivots and clean the contacts. Reassemble with #2 screws and nuts.
    The HVAC problem may be a disconnected vacuum supply line. When vacuum is missing, the HVAC defaults to DEFROST.

  13. #12
    frenzicadi's Avatar
    frenzicadi is offline Cadillac Owners Member
    Automobile(s): 1996 Cadillac Eldorado ETC
    Join Date
    Oct 2013
    Location
    staten island ny
    Posts
    31

    Re: Ignition/Abs/Traction/Trans/Belt fun stuff issues for the newbie

    Quote Originally Posted by Aztec ETC ECS View Post
    Take the pulldown apart, crank down by hand (not all the way) & leave it unplugged.
    Then you can move on to the rest of your problems.
    ok so i took off the 2 bolts holding a metal plate down, which holds down the metal closed hook piece. you can then grab the hooked piece and take it out together with the metal plate. on the bottom of that there is a round piece that you rotate and it brings down the closed hook metal part. leave it about 4 rotations open from total close and put it back in. trunk is shut tight now. this will do until i get the black box(switch).

    on to the next problem!

    Quote Originally Posted by Harry Yarnell View Post
    The trunk pulldown issue Is a common problem. It's in the little black box part of the pulldown; dirty contacts. They can be repaired by removing the black box (T-15 torx screw and release of a clip by the electrical connector). Drill out the three rivots and clean the contacts. Reassemble with #2 screws and nuts.
    The HVAC problem may be a disconnected vacuum supply line. When vacuum is missing, the HVAC defaults to DEFROST.
    im gonna give cleaning it a shot. the little black box (switch) is sitting in my room but doesnt seem like i can take it apart at all. i see where it connects and it doesnt look dirty at all. the switch may just be bad and i can wait till i get another. its a nifty feature but nothing worth going too crazy over right now.

    as for the hvac. are you talking about my rear vents?
    if youre talking about the front, all heat works well, its just that the passenger side is warmer than the driver side, especially on the feet, not including the feature where you can make it warmer (cuz that would just make me look dump).

  14. #13
    stoveguyy is offline Cadillac Owners Connoisseur
    Automobile(s): 96 STS, 140k
    Join Date
    Aug 2007
    Location
    mpls mn
    Posts
    2,480
    Sounds like a bad pulley bearing. The serp belt has a fixed idler wheel and a tensioner pulley on a spring loaded arm. Both pulleys could be bad.and your o2 sensor sounds bad. B2s1 is used to adjust fuel mixture for computer. U need to change it or check wiring

  15. #14
    frenzicadi's Avatar
    frenzicadi is offline Cadillac Owners Member
    Automobile(s): 1996 Cadillac Eldorado ETC
    Join Date
    Oct 2013
    Location
    staten island ny
    Posts
    31

    Re: Ignition/Abs/Traction/Trans/Belt fun stuff issues for the newbie

    Quote Originally Posted by stoveguyy View Post
    Sounds like a bad pulley bearing. The serp belt has a fixed idler wheel and a tensioner pulley on a spring loaded arm. Both pulleys could be bad.and your o2 sensor sounds bad. B2s1 is used to adjust fuel mixture for computer. U need to change it or check wiring
    well, the noise does stop after about a minute and only happens when the car is freezing cold. and im no expert but i dont think the pulley is "frozen" or jammed up from the cold until the car warms up.
    as for the sensor, im getting some crappy mpg, so im thinking the oxygen sensor has something to do with it. what does b2s1 stand for? short for oxygen sensor?
    and where are these located if i wanted to change it myself?

    btw you guys are awesome and i dont know why i didnt think of joining this forum earlier

  16. #15
    frenzicadi's Avatar
    frenzicadi is offline Cadillac Owners Member
    Automobile(s): 1996 Cadillac Eldorado ETC
    Join Date
    Oct 2013
    Location
    staten island ny
    Posts
    31

    Re: Ignition/Abs/Traction/Trans/Belt fun stuff issues for the newbie

    just ordered an oxygen sensor.
    read up on this site that the connectors to the ebtcm may be dirty from anti freeze so i need to find a good time to get in there and clean er up. if thats all it is, avs/traction should be fixed. is there an easier way than others to get in there? over the car or under the car? need to take anything out?

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting