Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Page 2 of 2 FirstFirst 12
Results 16 to 21 of 21

Thread: Another stalling Seville.

  1. #16
    BAM19040 is offline Cadillac Owners Member
    Automobile(s): 1998 Cadillac Seville SLS
    Join Date
    Apr 2011
    Location
    Wisconsin
    Age
    26
    Posts
    29

    Re: Another stalling Seville.

    I have a buddy with a junked seville. I'll see if he still has the MAF. And taking it pass 5k while driving.


  2. #17
    MoistCabbage's Avatar
    MoistCabbage is offline Cadillac Owners 10000+ Posts
    Automobile(s): 2001 Seville STS, 1990 Seville (RIP), 1972 Sedan Deville
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    29
    Posts
    26,323
    His Seville will have to be '99 or older.

  3. #18
    BAM19040 is offline Cadillac Owners Member
    Automobile(s): 1998 Cadillac Seville SLS
    Join Date
    Apr 2011
    Location
    Wisconsin
    Age
    26
    Posts
    29

    Re: Another stalling Seville.

    Oh yea I forgot some of the N* have it on the TB don't they? I'll check into it.

  4. #19
    MoistCabbage's Avatar
    MoistCabbage is offline Cadillac Owners 10000+ Posts
    Automobile(s): 2001 Seville STS, 1990 Seville (RIP), 1972 Sedan Deville
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    29
    Posts
    26,323
    Yes. '00+ have a combined MAF/IAT sensor upstream of the TB.

  5. #20
    BAM19040 is offline Cadillac Owners Member
    Automobile(s): 1998 Cadillac Seville SLS
    Join Date
    Apr 2011
    Location
    Wisconsin
    Age
    26
    Posts
    29

    Re: Another stalling Seville.

    Lol. MAF code popping solved. Was 100% my fault and we just wont go into what it was to save me a little dignity. Ill report back when the ckps are in!

  6. #21
    BAM19040 is offline Cadillac Owners Member
    Automobile(s): 1998 Cadillac Seville SLS
    Join Date
    Apr 2011
    Location
    Wisconsin
    Age
    26
    Posts
    29

    Re: Another stalling Seville.

    Sorry for the double post but just wanted to let anyone who cared know that CKP sensors were the culprit to my stalls/extended cranking. Took about 2 hours, a swivel attachment, a very long extension, and a lot of cuss words but I got them changed out with AC Delco ones and havn't stalled out since. No relearn was needed either. I did end up removing the oil filter adapter, made it so much easier. Make sure to replace the 2 o-rings on the oil filter adapter if you remove it and make sure you don't leave the old o-rings off of the old crank sensors on the block. Thanks for all the help guys, now to figure out why I keep getting the same o2 sensor code after 3 different o2 sensors have been installed..

Page 2 of 2 FirstFirst 12

Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum