92' STS no crank problem
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 11 of 11
Cadillac Seville / Cadillac Eldorado Forum Discussion, 92' STS no crank problem in Past Cadillac Vehicle Discussion; I have a STS that has been setting all summer and today when I went to start it the battery ...
  1. #1
    wk4036 is offline Cadillac Owners Member
    Automobile(s): 92 Seville STS
    Join Date
    Jan 2006
    Location
    SW Michigan
    Age
    49
    Posts
    9

    92' STS no crank problem

    I have a STS that has been setting all summer and today when I went to start it the battery was dead so I put the charger on it for most of the day and when I went to start it the normal lights come on in the instrument cluster doing the tests but it won't crank. Another thing I noticed is that nothing shows in the information window and the bottom of the cluster.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    STS_Seville_Hunter is offline Cadillac Owners Enthusiast
    Automobile(s): 91 ETC, 91 STS, 98 Eldo Convertable, '93 Seville
    Join Date
    Sep 2008
    Location
    DHS/Palm Springs, CA
    Age
    27
    Posts
    641

    Re: 92' STS no crank problem

    Try a new battery.

  4. #3
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    74,794

    Re: 92' STS no crank problem

    What is the voltage both static and while attempting to crank? Chances are you have a dead cell.

  5. #4
    wk4036 is offline Cadillac Owners Member
    Automobile(s): 92 Seville STS
    Join Date
    Jan 2006
    Location
    SW Michigan
    Age
    49
    Posts
    9
    Thread Starter

    Re: 92' STS no crank problem

    I will try a know good battery and report back

  6. #5
    wk4036 is offline Cadillac Owners Member
    Automobile(s): 92 Seville STS
    Join Date
    Jan 2006
    Location
    SW Michigan
    Age
    49
    Posts
    9
    Thread Starter

    Re: 92' STS no crank problem

    Well I put the tester on the battery and it shows 13 volts static and while turning the key to start, the dash lights dim while turning the key but there is no voltage going to the small wire that engages the starter solenoid.

  7. #6
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    74,794

    Re: 92' STS no crank problem

    Not sure about the dash lights, but if the headlamps dim, it probably is a dead cell.

    Are you saying you have zero voltage while cranking? You should still have about 9 or 10 with 1 dead cell.

  8. #7
    wk4036 is offline Cadillac Owners Member
    Automobile(s): 92 Seville STS
    Join Date
    Jan 2006
    Location
    SW Michigan
    Age
    49
    Posts
    9
    Thread Starter

    Re: 92' STS no crank problem

    The voltmeter at the battery hardly moves when key is turned to start position but dash lights dim, also checked the smaller wire at the started solenoid that actuates the solenoid and there is no voltage when the key is turned to the start position.

  9. #8
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    74,794

    Re: 92' STS no crank problem

    Sounds like it might be a bad starter switch (not the lock cylinder) down on the column.

  10. #9
    RetiredSFC 97 is offline Cadillac Owners Member
    Automobile(s): 1999 STS
    Join Date
    Feb 2013
    Location
    Columbia, Mo
    Posts
    56

    Re: 92' STS no crank problem

    Well, what happened? Any progress? In my opinion it's the battery or the starter and/or wires to starter. I can't count the number of batteries I've had that tested good and they were bad. Went through it this past winter with my tractor. It made me mad trying to find the problem until I said the heck with it and went and bought a new battery. Solved it. What made it worse was I had some mice chew up some wires around the instrument cluster so who wouldn't think that's where the problem was? I changed that out and still no dice. Then bought a new battery.

    I just had this same issue on my Dodge Pick up. Oreilly said the batt was good and didn't want to honor a warranty I had on the battery. I took them the pick up and they tested the alt and it was good so they reluctantly honored the warranty. Problem solved.

    Your car didn't die all on it's own just from sitting. It's a starter or batt issue, or both, or a wire somewhere that got chewed up by a mouse is my opinion.

  11. #10
    wk4036 is offline Cadillac Owners Member
    Automobile(s): 92 Seville STS
    Join Date
    Jan 2006
    Location
    SW Michigan
    Age
    49
    Posts
    9
    Thread Starter

    Re: 92' STS no crank problem

    Well I finally got a chance to fiddle with it again and put my remote starter button on the starter and also found out that even though a battery checks good it may not be so I put a new battery in it and it will crank with the remote button and start for about 2 seconds and then die and if I turn the key off and back to run it will run for about 2 seconds and die again but that is all the time I had to spend on it.

  12. #11
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    74,794

    Re: 92' STS no crank problem

    Have you checked your fuel pressure?

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting