Struggling with my 00 STS...
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 16
Cadillac Seville / Cadillac Eldorado Forum Discussion, Struggling with my 00 STS... in Past Cadillac Vehicle Discussion; I have some questions that i'm hoping you guys can give me some insight on... a few weeks ago my ...
  1. #1
    eldorado_97's Avatar
    eldorado_97 is offline Cadillac Owners Enthusiast
    Automobile(s): 2000 STS, W/Nav
    Join Date
    Feb 2007
    Location
    Baldwin, Wisconsin
    Age
    24
    Posts
    562

    Question Struggling with my 00 STS...

    I have some questions that i'm hoping you guys can give me some insight on... a few weeks ago my car started overheated and we found a leaking hose and replaced the thermostat and water pump and hose of course, and ever since then the car will every day run hotter "than it used to" I understand you folks say its ok if it runs up a notch or two on the temp gauge but it never did it far this often and with cooler temperatures outside. I also noticed it was leaking around the coolant tank cap so I bought a brand new OEM cap and i'm still having the same issue. My question to you all is what can I do to fix it.. also to note if the temp is going up slightly all i have to do is accelerate the car to a higher rpm and the needle will go right back to half so I'm not really sure how to feel about this. You can literally drive the snot out of it and it wont overheat but it runs much hotter and as i said im loosing coolant out the cap.. that's just the big problem i'm still dealing with a check gas cap message and a slight shimmy.. all of witch I can take care of myself. My current codes are P 0440 (gas cap message) and P 0741 (TCC lockup) that's it that's all.. nothing else... Thank you!!! Looking forward to some reply's whether they be positive of not i'm just looking for some answers to move forward with..

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    MoistCabbage's Avatar
    MoistCabbage is offline Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    21,915
    Have you checked the purge line yet?

  4. #3
    eldorado_97's Avatar
    eldorado_97 is offline Cadillac Owners Enthusiast
    Automobile(s): 2000 STS, W/Nav
    Join Date
    Feb 2007
    Location
    Baldwin, Wisconsin
    Age
    24
    Posts
    562

    Re: Struggling with my 00 STS...

    See thats just it.. I checked it a while back and Im not sure if im checking the right line?

  5. #4
    MoistCabbage's Avatar
    MoistCabbage is offline Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    21,915
    It's the small diameter hose running between the nipple near the top of the surge tank, and the hollow bolt/nipple near the water pump. That the one you checked?

  6. #5
    eldorado_97's Avatar
    eldorado_97 is offline Cadillac Owners Enthusiast
    Automobile(s): 2000 STS, W/Nav
    Join Date
    Feb 2007
    Location
    Baldwin, Wisconsin
    Age
    24
    Posts
    562

    Re: Struggling with my 00 STS...

    I checked it before this all went down but not since can I check it while the car is hot? :/

  7. #6
    MoistCabbage's Avatar
    MoistCabbage is offline Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    21,915
    No, because you can't open the system while it's under pressure.

    When it's cold, remove the surge tank cap, disconnect the purge line from the tank, and hold it over the open tank hole. Start the engine. There should be a slow, steady stream.

  8. #7
    eldorado_97's Avatar
    eldorado_97 is offline Cadillac Owners Enthusiast
    Automobile(s): 2000 STS, W/Nav
    Join Date
    Feb 2007
    Location
    Baldwin, Wisconsin
    Age
    24
    Posts
    562

    Re: Struggling with my 00 STS...

    Ok purge line is not blocked...

  9. #8
    MoistCabbage's Avatar
    MoistCabbage is offline Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    21,915
    Water pump belt and tensioner in good shape? Belt not slipping at all?

    No debris on the front of the condenser?

  10. #9
    eldorado_97's Avatar
    eldorado_97 is offline Cadillac Owners Enthusiast
    Automobile(s): 2000 STS, W/Nav
    Join Date
    Feb 2007
    Location
    Baldwin, Wisconsin
    Age
    24
    Posts
    562

    Re: Struggling with my 00 STS...

    New belt, tensioner is good and condenser is clean I use a soft toothbrush lol

  11. #10
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,836

    Re: Struggling with my 00 STS...

    a few weeks ago my car started overheated and we found a leaking hose and replaced the thermostat and water pump and hose
    Why in the world did you waste the time and money replacing a WP?


    also to note if the temp is going up slightly all i have to do is accelerate the car to a higher rpm and the needle will go right back to half
    Boy, that sure sounds like a slipping WP belt, air in the system or low coolant.

  12. #11
    eldorado_97's Avatar
    eldorado_97 is offline Cadillac Owners Enthusiast
    Automobile(s): 2000 STS, W/Nav
    Join Date
    Feb 2007
    Location
    Baldwin, Wisconsin
    Age
    24
    Posts
    562

    Re: Struggling with my 00 STS...

    Sorry I forgot to say that my water pump was leaking and the thermostat gasket was all shriveled up so that's why I changed them.. I'm still betting my money on air in the system but its been almost a month now... and the other thing is occasionally I can hear like a sloshing noise in the dash heater core?

  13. #12
    Submariner409's Avatar
    Submariner409 is offline If it won't run, chrome it
    Automobile(s): 2002.5 F55 STS/65500mi, 2004 Ford F150 SuperCab4x4
    Join Date
    Feb 2006
    Location
    MD Eastern Shore - Kent Island
    Age
    74
    Posts
    45,006

    Re: Struggling with my 00 STS...

    Heater core noise = air in the system.

  14. #13
    eldorado_97's Avatar
    eldorado_97 is offline Cadillac Owners Enthusiast
    Automobile(s): 2000 STS, W/Nav
    Join Date
    Feb 2007
    Location
    Baldwin, Wisconsin
    Age
    24
    Posts
    562

    Re: Struggling with my 00 STS...

    Ok.. well then how do i get the air out?

  15. #14
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,836

    Re: Struggling with my 00 STS...

    Make sure that the purge line is clean and the system will purge itself. If the purge line is clear and you still hear air the heater core and the engine is overheating, the "air" is being introduced to the system. Most likely by a bad HG. Might be time for a block test.

  16. #15
    98cadillac is offline Cadillac Owners Fanatic
    Automobile(s): 1998 Cadillac Seville STS
    Join Date
    Feb 2013
    Posts
    306

    Re: Struggling with my 00 STS...

    Quote Originally Posted by Ranger View Post
    Make sure that the purge line is clean and the system will purge itself. If the purge line is clear and you still hear air the heater core and the engine is overheating, the "air" is being introduced to the system. Most likely by a bad HG. Might be time for a block test.
    Unfortunately, Ranger is correct. Exhaust gases are most likely coming into the system from a bad head gasket.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting