93 STS spark plug not firing
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 12 of 12
Cadillac Seville / Cadillac Eldorado Forum Discussion, 93 STS spark plug not firing in Past Cadillac Vehicle Discussion; Hi i got a 93 sts that had a little miss then i noticed smoke out of the exhaust very ...
  1. #1
    decimatedsouls is offline Cadillac Owners Member
    Automobile(s): 93 cadillac seville sts
    Join Date
    Jun 2013
    Age
    34
    Posts
    4

    93 STS spark plug not firing

    Hi i got a 93 sts that had a little miss then i noticed smoke out of the exhaust very rich fuel odor so i pulled the plugs and 1 of them was soaked in gas so i cleaned the plugs and then replaced the plug wires the car ran great for about 20 minutes on a test drve then started acting up again and the plug was gas soaked again. Bad plug or maybe coil pack not delivering good spark any ideas

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Submariner409's Avatar
    Submariner409 is offline If it won't run, stick on fender vents
    Automobile(s): 2002.5 F55 STS/65500mi, 2004 Ford F150 SuperCab4x4
    Join Date
    Feb 2006
    Location
    MD Eastern Shore - Kent Island
    Age
    74
    Posts
    44,593

    Re: 93 STS spark plug not firing

    If your STS has the Northstar engine it's probably time for new spark plug wires - the expensive AC Delco set from RockAuto - and a thorough coil and ICM cleaning. Check the ICM ground wire and its terminals also.

    Use the diagrams in my albums for proper spark plug - coil wire hookup.

    Don't overlook the possibility of a sticky fuel injector. In addition to the plug wires and coil cleaning you might want to run a 20 oz. jug of Chevron TECHRON through a tank of Top Tier gasoline. (Google both - top tier gasoline and chevron techron .)

  4. #3
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,372

    Re: 93 STS spark plug not firing



    1 wet plug? Sounds like you have one not firing. Gotta be a bad plug, wire or coil.

  5. #4
    decimatedsouls is offline Cadillac Owners Member
    Automobile(s): 93 cadillac seville sts
    Join Date
    Jun 2013
    Age
    34
    Posts
    4

    Re: 93 STS spark plug not firing

    Hi my 93 seville sts has the 4.6 northstar i put new wires on cleaned up the coil pack plugs and grounds the icm
    Is clean and grounds are good and coil is new still the same cylinder is not firing and plug gas soaked so i swapped
    The plug with another the car ran good for a few min then started missing again checked plugs again the same cylinder
    Is still not firing even with a different plug new wires and new coil??? Is the icm bad i thought if the icm was bad
    None of the plugs would fire

  6. #5
    EcSTSatic's Avatar
    EcSTSatic is online now Cadillac Owners Connoisseur
    Automobile(s): 1999 STS - diamond white
    Join Date
    Dec 2004
    Location
    Wichita, KS
    Posts
    4,635

    Re: 93 STS spark plug not firing

    Not sure I'm following. Did you swap a couple wires too?

  7. #6
    basscatt's Avatar
    basscatt is online now Cadillac Owners Master
    Automobile(s): 89 Coupe DeVille, 95 Sedan DeVille, 03 SLS, two 02 DHS's
    Join Date
    Feb 2004
    Location
    Minnesota
    Age
    63
    Posts
    9,860

    Re: 93 STS spark plug not firing

    Quote Originally Posted by decimatedsouls View Post
    Hi my 93 seville sts has the 4.6 northstar i put new wires on cleaned up the coil pack plugs and grounds the icm
    Is clean and grounds are good and coil is new still the same cylinder is not firing and plug gas soaked so i swapped
    The plug with another the car ran good for a few min then started missing again checked plugs again the same cylinder
    Is still not firing even with a different plug new wires and new coil??? Is the icm bad i thought if the icm was bad
    None of the plugs would fire
    ------------------------
    after all you have done -
    I think you have a fuel injector stuck open -
    and dumping so much raw fuel the spark plug CAN'T fire -

    with the engine running -
    use a stethoscope - or something similar -
    and listen to each injector -
    you should hear a strong rhythmatic clicking - from each one -

    next would be to measure the resistance of each one with a DVM -

  8. #7
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,372

    Re: 93 STS spark plug not firing


  9. #8
    decimatedsouls is offline Cadillac Owners Member
    Automobile(s): 93 cadillac seville sts
    Join Date
    Jun 2013
    Age
    34
    Posts
    4
    Thanks for the reply i got it fixed it was a bad injector runs like a champ but now im having a charging issue

    ----------

    93 sts 4.6 acdelco alt is about 1 year old and the battery about the same both have been bench tested about 5x and are good but when i start the engine it reads 11.5volts if i rev the engine up one time the volts jump up to 13.5 to 14.2 and its normally good all day when i start it up and shut it off, every so often when i start it up after work it does the same thing 11.5 till i rev it up one time then 13.5 to 14.2 even when the battery is under a load, grounds and wires all good any thoughts? And where does that little red alt wire go after it disappears into the wire harness to the dash or in the engine compartment somewhere thats the only wire i havent been able to inspect?

  10. #9
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,372

    Re: 93 STS spark plug not firing

    when i start the engine it reads 11.5volts if i rev the engine up one time the volts jump up to 13.5 to 14.2 and its normally good all day
    Just an educated guess, but that sounds suspiciously like an alternator problem.

  11. #10
    decimatedsouls is offline Cadillac Owners Member
    Automobile(s): 93 cadillac seville sts
    Join Date
    Jun 2013
    Age
    34
    Posts
    4
    Yeah thats what i thought but its been tested multiple times on and off the car and tests fine still trying to figure out where that little red alt wire goes if it goes to the dash or the engine compartment

  12. #11
    Submariner409's Avatar
    Submariner409 is offline If it won't run, stick on fender vents
    Automobile(s): 2002.5 F55 STS/65500mi, 2004 Ford F150 SuperCab4x4
    Join Date
    Feb 2006
    Location
    MD Eastern Shore - Kent Island
    Age
    74
    Posts
    44,593

    Re: 93 STS spark plug not firing

    Somehow the alternator is missing the excitation voltage signal at engine start - that voltage what "starts' the alternator/regulator. You need a charging circuit diagram.

    Many modified cars (and boat engines) use a one-wire alternator - they must be revved to about 1500 engine rpm to "start" - after that they're fine for the rest of that trip. You can find them in any hot rod or speed parts catalog.

  13. #12
    el_dorado_mex's Avatar
    el_dorado_mex is offline Cadillac Owners Fanatic
    Automobile(s): 1996 El Dorado and 1991 Cheyenne Pickup
    Join Date
    Jul 2012
    Location
    Puerto Escondido, Mexico
    Age
    36
    Posts
    106
    Same thing here, figured that the regulator wiring is somewhat sensible, thin wires... Learned to live with it, no charge at stoplights and ok when above 900 rpm.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting