Head Unit not working
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 11 of 11
Cadillac Seville / Cadillac Eldorado Forum Discussion, Head Unit not working in Past Cadillac Vehicle Discussion; Ok so today (and also two day ago) I hopped the the 01 eldo to get ready to go to ...
  1. #1
    Cadillac Kyle's Avatar
    Cadillac Kyle is offline Cadillac Owners Fanatic
    Automobile(s): 1993 eldorado etc, 1997 eldorado etc, 2001 eldorado etc
    Join Date
    Feb 2013
    Location
    Midway, GA
    Age
    27
    Posts
    103
    Ok so today (and also two day ago) I hopped the the 01 eldo to get ready to go to work. When I entered the car, I noticed that I didn't hear that familiar sound of the ant.raising up. I tried pressing the power button on the hu but nothing would happen. Two days ago when it happened I just locked it back up, went back into the house and returned 2-3 mins later and it magically worked when I turned the car on. Today the same thing just happened except this time it didn't come back on. I thought maybe by changing the driver (from user 1 to user 2) it would cut it on but nope. I also noticed that the 1 2 buttons for memory where working intermittently and the set button was not working at all. I heard no chimes as far as the buttons where concerned. This just came out the blue. I have no current codes (other that p0410 sec air pump thing) and the only memory codes I have (which are history) are b2120- lumbar up/down I believe and a new one i haven't seen which is b1656-EEPROM write error. Not sure what that one means. I did have my battery out for a day due to the previous overheating problem I had but everything is/was great and perfect up till two days ago. Any help would be deeply appreciated. I miss my music

    Edit: also something that I noticed as well was when I turned my lights on (where u can control intensity w/ knob) for two miles or so all was good (had it turnt all the way down before off) but then all of a sudden the greens on all the lights where on as if I had my lights off. Bo matter what I tried, I couldn't get my green lights to dim anymore

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    stoveguyy is offline Cadillac Owners Connoisseur
    Automobile(s): 03 STS
    Join Date
    Aug 2007
    Location
    mpls mn
    Posts
    2,509

    Re: Head Unit not working

    sounds like power issue. check fuses, and possibly hu wire harness connections. btw, do you have 3 eldos right now?

  4. #3
    Cadillac Kyle's Avatar
    Cadillac Kyle is offline Cadillac Owners Fanatic
    Automobile(s): 1993 eldorado etc, 1997 eldorado etc, 2001 eldorado etc
    Join Date
    Feb 2013
    Location
    Midway, GA
    Age
    27
    Posts
    103
    Thread Starter
    As of this moment I only have 2, 97 and 01...the 93 was wrecked ;( well whenever the rain lets up I will go have a look. Is there a particular fuse I should be checking? I would rather do that first before tearing up the interior

  5. #4
    stoveguyy is offline Cadillac Owners Connoisseur
    Automobile(s): 03 STS
    Join Date
    Aug 2007
    Location
    mpls mn
    Posts
    2,509

    Re: Head Unit not working

    i dont think the fuse is bad. but you might have a loose connection. even at fuse block. friend got car and it died. turns out main fuse was GONE. turned over fuse block and wires were twisted together and had come loose. wtf??? this was after owning car for 1 yr. who knew?

  6. #5
    Cadillac Kyle's Avatar
    Cadillac Kyle is offline Cadillac Owners Fanatic
    Automobile(s): 1993 eldorado etc, 1997 eldorado etc, 2001 eldorado etc
    Join Date
    Feb 2013
    Location
    Midway, GA
    Age
    27
    Posts
    103
    Thread Starter
    Well strangest thing (and as I expected) got back in the car roughly 15 mins ago and...presto! Back working again. I have no idea what's causing it to work one minute and not the next and then again. It's quite confusing

  7. #6
    stoveguyy is offline Cadillac Owners Connoisseur
    Automobile(s): 03 STS
    Join Date
    Aug 2007
    Location
    mpls mn
    Posts
    2,509
    Hu and amps have circuit boards. Any component can fail. Bad solder joint, bad capacitor, and so on. Elec parts die and sometimes they work/don't work/sorta work. Your clock does not lose track of time so HU is not loosing all power.

  8. #7
    Cadillac Kyle's Avatar
    Cadillac Kyle is offline Cadillac Owners Fanatic
    Automobile(s): 1993 eldorado etc, 1997 eldorado etc, 2001 eldorado etc
    Join Date
    Feb 2013
    Location
    Midway, GA
    Age
    27
    Posts
    103
    Thread Starter
    Correct my hu doesn't lose all power becUse time always is being displayed. It seems like everytime the car sits over night, it won't immediately work when cut back on. It usual takes a 15 min drive and a cut off and a return to car to get it working again. The ant. Doesn't raise ,only when it works (that's my way of telling if its gonna cut on) I'm kind of lost as to what I should check or even how to troubleshoot this problem (not electrical inclined at all) I would really like to figure this out as I commute 25 mi (50 total) daily and I would go crazy not having anything to listen to. I open to ever and all suggestions. Worst case scenario, Im gonna throw out (maybe bash with a bat) the head unit and go for DVD/nav screen but would really like to just keep what I got. Another question just hit me. I have an 01 eldo would an 01 STS nav work with my car?

  9. #8
    N*Caddy's Avatar
    N*Caddy is offline Cadillac Owners Master
    Automobile(s): 1997 Cadillac STS (BOSE w/AUX In, Massage Seats, URPAS, "Z")
    Join Date
    Nov 2006
    Location
    Toronto, Canada
    Age
    36
    Posts
    6,405

    Re: Head Unit not working

    Looks like you have data communication issues (IPC or PZM).
    As for nor NAV, is a very complicated answer but the fast answer is NO.

  10. #9
    Cadillac Kyle's Avatar
    Cadillac Kyle is offline Cadillac Owners Fanatic
    Automobile(s): 1993 eldorado etc, 1997 eldorado etc, 2001 eldorado etc
    Join Date
    Feb 2013
    Location
    Midway, GA
    Age
    27
    Posts
    103
    Thread Starter
    Quote Originally Posted by N*Caddy
    Looks like you have data communication issues (IPC or PZM).
    As for nor NAV, is a very complicated answer but the fast answer is NO.
    Ok thank you northstar. Before I start puttin it in my head that Imma replace the hu with aftermarket (which will have me making another thread lol) is there anyway I can trouble shoot an exact problem or reason for the "sometimes it works sometimes it doesn't" behavior? I would really like to keep the look stock. I know I can get another hu and have it tech2'd but how do I know it's my hu that's the problem? I think it has something to do more with the antenna than anything but all help would be appreciated. Thank yall

  11. #10
    Cadillac Kyle's Avatar
    Cadillac Kyle is offline Cadillac Owners Fanatic
    Automobile(s): 1993 eldorado etc, 1997 eldorado etc, 2001 eldorado etc
    Join Date
    Feb 2013
    Location
    Midway, GA
    Age
    27
    Posts
    103
    Thread Starter
    Bump...anyone? Anything?

  12. #11
    stoveguyy is offline Cadillac Owners Connoisseur
    Automobile(s): 03 STS
    Join Date
    Aug 2007
    Location
    mpls mn
    Posts
    2,509
    2nd hu is quickest fix. Might cost a few $ but it will tell u right off if hu is issue. Usually the cd section of hu dies and it's rare for the fm tuner section to go out. I have almost never seen a dead hu mentioned here. It's always people who want to tear out stock stuff and put in aftermarket

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting