Gauge Cluster Problem
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 6 of 6
Cadillac Seville / Cadillac Eldorado Forum Discussion, Gauge Cluster Problem in Past Cadillac Vehicle Discussion; So today I was messing around with my rearview mirror trying to convert it to an onstar (7 pin to ...
  1. #1
    STSClint's Avatar
    STSClint is offline Cadillac Owners Fanatic
    Automobile(s): 2007 STS 1SB, 2012 Cadillac Escalade Platinum
    Join Date
    Sep 2012
    Location
    New England
    Posts
    131

    Gauge Cluster Problem

    So today I was messing around with my rearview mirror trying to convert it to an onstar (7 pin to 16 pin) mirror on my STS. After trying different wire combinations I realized that it wouldnt work... Then it was time to go to work and as I drove down the road I realized that my gas gauge and temp gauge were working but the speedo, tac, and blinkers were NOT. The info buttons and trip buttons didnt work either. Did I simply blow a fuse or did I do something worse?


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Mafiaman111 is offline Cadillac Owners Fanatic
    Automobile(s): 2001 Deville 159k
    Join Date
    Oct 2010
    Location
    Pennsylvania
    Posts
    449

    Re: Gauge Cluster Problem

    you could have shorted the cluster out and ruined it but it wouldn't hurt to check fuses

  4. #3
    N*Caddy's Avatar
    N*Caddy is offline Cadillac Owners Master
    Automobile(s): 1997 Cadillac STS (BOSE w/AUX In, Massage Seats, URPAS, "Z")
    Join Date
    Nov 2006
    Location
    Toronto, Canada
    Age
    38
    Posts
    6,405

    Re: Gauge Cluster Problem

    I would assume you burned a fuse or worst case scenario something on the DIM. You need to check the FSM to understand what could have happened. Not that I want to sound like a snob or something, but you should have checked the FSM before starting to mess with the mirror wires. The OnStar mirror harness does have all the wires a non-OnStar mirror has plus some more. You also need the VCM for this to work.

  5. Remove Advertisements
    Cadillac Forums
    Advertisements
     

  6. #4
    STSClint's Avatar
    STSClint is offline Cadillac Owners Fanatic
    Automobile(s): 2007 STS 1SB, 2012 Cadillac Escalade Platinum
    Join Date
    Sep 2012
    Location
    New England
    Posts
    131
    Thread Starter
    Alright so I didnt fry my whole electical system like the stealership told me? And thanks for the help! I shall check the fuses under the back seat! Owners manual here I come!

  7. #5
    STSClint's Avatar
    STSClint is offline Cadillac Owners Fanatic
    Automobile(s): 2007 STS 1SB, 2012 Cadillac Escalade Platinum
    Join Date
    Sep 2012
    Location
    New England
    Posts
    131
    Thread Starter

    Re: Gauge Cluster Problem

    Hello again. Thanks again to all who have helped thus far... Yesterday I checked all of the possible fuses (both under the rear seat and under the bonnet). I found that my DIM fuse was shot so I replaced it, turned the car on and the Tachometer and Speedometer still did not work... HOWEVER my SERVICE CHARGING SYSTEM message went away (it was still there after putting in a new Delco). So this leads me to believe that the module itself is at fault...? I have been getting A LOT of DIM codes recently so maybe it just decided to die? Any help or suggestions would be appreciated.

  8. #6
    N*Caddy's Avatar
    N*Caddy is offline Cadillac Owners Master
    Automobile(s): 1997 Cadillac STS (BOSE w/AUX In, Massage Seats, URPAS, "Z")
    Join Date
    Nov 2006
    Location
    Toronto, Canada
    Age
    38
    Posts
    6,405

    Re: Gauge Cluster Problem

    To chnage the DIM you need a TECHII to program your VIN (same idea as with the HU).

  9. Remove Advertisements
    Cadillac Forums
    Advertisements
     

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

What Cadillac(s) do you own? (Or type NONE)

Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •