1976 Seville problems - Germany
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 3 1 2 3 LastLast
Results 1 to 15 of 37
Cadillac Seville / Cadillac Eldorado Forum Discussion, 1976 Seville problems - Germany in Past Cadillac Vehicle Discussion; ...
  1. #1
    Markus_E is offline Cadillac Owners Member
    Automobile(s): 1976 Seville
    Join Date
    Jan 2013
    Location
    Germany
    Age
    36
    Posts
    19

    1976 Seville problems - Germany

    Hello
    Iīm Markus from Germany. I got an 1976 Seville since a few days. But it is not running. I ordered an shop manual but itīs not arrived jet. And checked some things whitout special information.
    The enging fire uo really nice and run on all 8 Zylinders when i spray brake cleaner into the throttle body.

    I check both fuel pumps and they are dead. Now i got an old fuel pump from an other car. I tried to get fuel to the rails. After an while it fired up and runs. But not at all Zylinders. The fast idle works, when it get a little bit warmer the idle drops to normal speed. But it wonīt run really good when the idle drops. And the engine stops. Okay thats only an interim solution with a lot of fuel leaks

    Now iīm thinking if i buy the pumps and 2 or 3 injectors and try to get it run. Or if i start to make an conversion to carburetor. Maybe somebody can help me with his experience.

    And maybe somebody knows where i get an in tank sending unit. Because this is completely rusted,

    Thanks for helping me

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    basscatt's Avatar
    basscatt is online now Cadillac Owners Master
    Automobile(s): 89 Coupe DeVille, 95 Sedan DeVille, 02 DHS, 03 SLS
    Join Date
    Feb 2004
    Location
    Minnesota
    Age
    62
    Posts
    8,400

    Re: 1976 Seville Problems

    the early fuel injection system was full of problems -

    you will be much happier with a carburetor -

  4. #3
    brougham is offline Cadillac Owners Master
    Automobile(s): 1991 Cadillac Brougham D'Elegance 5.7 Litre
    Join Date
    Jun 2003
    Location
    Canada
    Posts
    5,268

    Re: 1976 Seville Problems

    Isn't that car throttle body? A problem with the distributor or also the HEI can cause problems like you are having.
    Because of where you are it would probably be easier in the long run to convert to a carberator then finding parts in the future.

  5. #4
    Markus_E is offline Cadillac Owners Member
    Automobile(s): 1976 Seville
    Join Date
    Jan 2013
    Location
    Germany
    Age
    36
    Posts
    19

    Re: 1976 Seville Problems

    i will think about the conversion or to get it run like its origin.
    But first we have to get the Car Registered again in Germany. Some of the owners before lost the documents of the car. In germany that is a kind of bullshit you never seen.

    if that makes to much trouble and cost to much money it will go out in parts. But i wanīt to get the car on the streets again. It is in a very good condition.

  6. #5
    fleetwood69 is offline Cadillac Owners Member
    Automobile(s): 80 Fleetwood Limo, 77 seville, 80 seville
    Join Date
    Feb 2013
    Age
    49
    Posts
    1

    Cool Re: 1976 Seville Problems

    Hi

    Been in the same mess,

    Parts hard to find, and expensive efi-parts

    easier to get a carburettor with intake from oldsmobile in the same era, and cheaper.

    So i would go for carburettor conversion or newer tbi conversion from 1986-95 Chevrolet(Thats another story)

    Come back and tell!

    ///erik

  7. #6
    Markus_E is offline Cadillac Owners Member
    Automobile(s): 1976 Seville
    Join Date
    Jan 2013
    Location
    Germany
    Age
    36
    Posts
    19

    Re: 1976 Seville Problems

    I will keep you updated. But we fight with the german registration office. they are allways so complicated

  8. #7
    KurtAustinTx is offline Cadillac Owners Member
    Automobile(s): 1963 CDV & 1976 Seville
    Join Date
    Jan 2010
    Posts
    13

    Re: 1976 Seville Problems

    Hi Markus, I bought a 76 Seville 4 years ago. When I got it it ran way too rich & would foul out the plugs quickly. The problem was the ambient air temperature sensor in the throttle body. If that and/or the coolant temperature sensor are bad, the car will run badly. The shop manual is very helpful. I also used this site before my manual arrived http://www.cadillacseville.org/, lots of good info & troubleshooting. Unfotunately I don't know see a source for the sending unit. Over time, I replaced both fuel pumps & 1 injector. The car is currently running great on the fuel injection.

    Kurt

  9. #8
    Markus_E is offline Cadillac Owners Member
    Automobile(s): 1976 Seville
    Join Date
    Jan 2013
    Location
    Germany
    Age
    36
    Posts
    19

    Re: 1976 Seville Problems

    Okay i will get a try. I ordered both fule pumps a filter and the air temp sensor. But i didnīt find a coolant temperature sensor. Do you have an store for that?

    I repaired the in tank sending unit. It was completely rusty and it didnīt work. I hope it will do the job. Cleaning the fuel tank and waiting for the spare parts.

    Maybe i have a little bit luck

  10. #9
    Markus_E is offline Cadillac Owners Member
    Automobile(s): 1976 Seville
    Join Date
    Jan 2013
    Location
    Germany
    Age
    36
    Posts
    19

    Re: 1976 Seville Problems

    so some good and bad news. The car runs with the new fuel pumps very good at a copule of time.
    But now it wonīt start any more. Also when i spray brake cleaner in the throttle body. I got sparks on the spark plugs and the voltage is there on the distributor. Fuel is also coming.

  11. #10
    Aztec ETC ECS's Avatar
    Aztec ETC ECS is offline Cadillac Owners Connoisseur
    Automobile(s): '02 ETC ECS#533, '05 Escalade, '05 AWD Magnum, '74 455 OLDS
    Join Date
    Feb 2012
    Location
    NYC
    Age
    46
    Posts
    1,614

    Re: 1976 Seville Problems

    If you plan on converting to a carb & use the original pump setup, you will need a regulator to cut the pressure down to 5-7 lbs.
    Personally, I'd go with an Edelbrock Performer with the choke & EGR allowance and a Q-jet.

  12. #11
    Markus_E is offline Cadillac Owners Member
    Automobile(s): 1976 Seville
    Join Date
    Jan 2013
    Location
    Germany
    Age
    36
    Posts
    19

    Re: 1976 Seville Problems

    that will be plan b, if i donīt get it to run.

    I tried some things today, and the car starts perfect. But the engine stops after a second. But i can keep it run with the brake cleaner.

    ----------

    that will be plan b, if i donīt get it to run.

    I tried some things today, and the car starts perfect. But the engine stops after a second. But i can keep it run with the brake cleaner.

  13. #12
    cadillac kevin's Avatar
    cadillac kevin is offline Cadillac Owners Master
    Automobile(s): chevy 350 powered 86 FWB, 00 safari h.t. 66 toro, 83 lesabre
    Join Date
    Dec 2010
    Location
    St. Louis, MO
    Posts
    5,408
    How are the injectors? Fuel filters?

  14. #13
    Markus_E is offline Cadillac Owners Member
    Automobile(s): 1976 Seville
    Join Date
    Jan 2013
    Location
    Germany
    Age
    36
    Posts
    19

    Re: 1976 Seville Problems

    How can i check the injectors?

    The fuel filter outside the tank is the old one. I try tomorrow to change it. I canīt open the housing till now

  15. #14
    Markus_E is offline Cadillac Owners Member
    Automobile(s): 1976 Seville
    Join Date
    Jan 2013
    Location
    Germany
    Age
    36
    Posts
    19

    Re: 1976 Seville Problems

    Okay i get some more infos.
    I changed the fuel filter and nothing changes.
    i checked the pressure regulator with my compressor. And round about 40psi it opens.
    Both of the temperatur sensors have about 900Ohm when iīm right the coolant and air sensors are the same or do they only look like the same from above?!
    The injectors are clicking with ignition on and turning the throttle slowly.

    The car keeps running, when i pump the gas Pedal fast. I have no second man for measure the speed sensor. Could that be the symptom for that?

  16. #15
    Markus_E is offline Cadillac Owners Member
    Automobile(s): 1976 Seville
    Join Date
    Jan 2013
    Location
    Germany
    Age
    36
    Posts
    19

    Re: 1976 Seville Problems

    and again some tests.
    The speed sensor gives me the trigger signal, when i measure the resistant. And the 9V is clean.
    The fuel flow must be okay. When i calculate it, itīs round about 115L per Hour.
    When i squeeze the tube after the fuel pressure regulator that i get a higher pressure nothing changes. Also when i plug of the vacuum.

    Now i havenīt really an idea, what it could be. I try to get an fuel pressure meter to check it in the car.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting