1997 SLS - maybe not the fuel pump thats bad? - Page 2
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 16 to 19 of 19
Cadillac Seville / Cadillac Eldorado Forum Discussion, 1997 SLS - maybe not the fuel pump thats bad? in Past Cadillac Vehicle Discussion; Test the gas pressure with ignition ON and engine off. Compare it with the fuel pressure w/engine running. Check the ...
  1. #16
    N*Caddy's Avatar
    N*Caddy is offline Cadillac Owners Master
    Automobile(s): 1997 Cadillac STS (BOSE w/AUX In, Massage Seats, URPAS, "Z")
    Join Date
    Nov 2006
    Location
    Toronto, Canada
    Age
    35
    Posts
    6,374

    Re: 1997 SLS - maybe not the fuel pump thats bad?

    Test the gas pressure with ignition ON and engine off.
    Compare it with the fuel pressure w/engine running.
    Check the fuel pump relay.
    Pull the codes.

  2. #17
    stomped is offline Cadillac Owners Member
    Join Date
    Jan 2014
    Posts
    2

    Re: 1997 SLS - maybe not the fuel pump thats bad?

    1997 cadilac deville no gas to rail i replaced fuel pump still no gas i switched the relay with the ac relay still no gas what should i do next

  3. #18
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    72,244

    Re: 1997 SLS - maybe not the fuel pump thats bad?


    Sounds like you are mot getting power to the pump. I'd say you need to start tracing the wires back from the pump and see where you are loosing power. I assume you checked the fuse?

  4. #19
    2kflhr's Avatar
    2kflhr is offline Cadillac Owners Fanatic
    Automobile(s): 2010 Escalade, '97 Eldorado ETC, '97 SS Camaro
    Join Date
    Dec 2004
    Location
    Mooresville, NC
    Age
    55
    Posts
    412

    Re: 1997 SLS - maybe not the fuel pump thats bad?

    Could it be the fuel pump relay being you stated you can cycle the switch several times and it works?

    Typically or from what I've experienced the fuel pump quits all at once and usually on a cold start never to pump again. Maybe, just maybe you can rap the tank one good time and get it to kick in but I would only trust it to get it to where I was goinf to repalce it.

    I had one repalced in a Yukon awhile back and it was aournd $800-850 at a dealership but luckily under warranty.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting