2002 STS - aftermarket radio install not working correctly - Page 2
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 16 to 30 of 30
Like Tree1Likes
Cadillac Seville / Cadillac Eldorado Forum Discussion, 2002 STS - aftermarket radio install not working correctly in Past Cadillac Vehicle Discussion; The GMOS-6 is the correct one. I believe you lose single chime warnings regardless....
  1. #16
    MoistCabbage's Avatar
    MoistCabbage is online now Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    20,386
    The GMOS-6 is the correct one. I believe you lose single chime warnings regardless.

  2. #17
    N*Caddy's Avatar
    N*Caddy is offline Cadillac Owners Master
    Automobile(s): 1997 Cadillac STS (BOSE w/AUX In, Massage Seats, URPAS, "Z")
    Join Date
    Nov 2006
    Location
    Toronto, Canada
    Age
    35
    Posts
    6,374

    Re: 2002 STS - aftermarket radio install not working correctly

    Actually the best adapter is NO adapter and install back the OEM HU.
    That alone and all your problems are over.
    All cars (almost since the late '80s) have the stereo part of the car's data bus.
    '02 is especially a interesting year, is when the HU was upgraded, the CD changer is now controlled trough the car dataline rather than the E&D line. Your RDS logo should be white not yellow (if you still have the original HU). So if somebody sell to you a sound system doohickey that works from '98 to '03, unless is a fuse does not know anything about these cars.
    12-inch subs and such, definitely you are under 25...no pawn intended. This is the diagonally opposite car to the one you would do such “upgrade”, I am thinking Civic and similar.

  3. #18
    old_school is offline Cadillac Owners Member
    Automobile(s): 2002 SLS
    Join Date
    Jul 2012
    Location
    SE Florida
    Posts
    82

    Re: 2002 STS - aftermarket radio install not working correctly

    i know the best adapter would be no adapter and install back the OEM HU but the 2 12's and new amp just did not sound nice with the factory radio i guess i would have to live with no chime warnings but would i at les get my electronic working ok again with the GMOS-6 is this the correct one here

    http://www.sonicelectronix.com/item_...s-GMOS-06.html

    also if i get the GMOS-6 would i also need to get the pac to get back the steering wheel control if so is this the correct one here

    http://www.sonicelectronix.com/item_...AC-SWI-RC.html

  4. #19
    Submariner409's Avatar
    Submariner409 is offline If it won't run, stick on fender vents
    Automobile(s): 2002.5 F55 STS/65500mi, 2004 Ford F150 SuperCab4x4
    Join Date
    Feb 2006
    Location
    MD Eastern Shore - Kent Island
    Age
    74
    Posts
    43,371

    Re: 2002 STS - aftermarket radio install not working correctly

    You will not be the first or last to have ongoing electrical/electronic nightmares caused by changing to an aftermarket sound system. Wait until you can't get into the car at 2 one morning - and when you manually unlock it, it won't start. Even long-time professional installers have problems with these cars, so you're already behind the 8 ball.

  5. #20
    old_school is offline Cadillac Owners Member
    Automobile(s): 2002 SLS
    Join Date
    Jul 2012
    Location
    SE Florida
    Posts
    82

    Re: 2002 STS - aftermarket radio install not working correctly

    hopefuly that wont happend and if it does its back to install the OEM HU and problems fix but saying manually unlock it, it won't start one day i dont think so so anyone know if this is the right GMOS-6 and the right pac should of bought the 86 chevy caprice classic that i wanted to get and stayed away from the cadlilac seville too much headache

    http://www.sonicelectronix.com/item_...s-GMOS-06.html

    http://www.sonicelectronix.com/item_...AC-SWI-RC.html

  6. #21
    Submariner409's Avatar
    Submariner409 is offline If it won't run, stick on fender vents
    Automobile(s): 2002.5 F55 STS/65500mi, 2004 Ford F150 SuperCab4x4
    Join Date
    Feb 2006
    Location
    MD Eastern Shore - Kent Island
    Age
    74
    Posts
    43,371

    Re: 2002 STS - aftermarket radio install not working correctly

    Your links are missing something - they lead to a different page from their title. The links in one of your earlier posts are OK, and the -06 jumper harness should do most of the job you want.

    Remember - you have interrupted the data bus system AND the TheftLock system. Unless you correctly resolve the data transmission faults - chimes, lights, module memories - one day the car WILL lock itself down. It has happened before; in here, Deville, and down in the Audio, Video, Security install Forum.

    FWIW, The Cadillac is not the headache: You created a big one when you started to fool with the sound system before doing all your homework.

  7. #22
    old_school is offline Cadillac Owners Member
    Automobile(s): 2002 SLS
    Join Date
    Jul 2012
    Location
    SE Florida
    Posts
    82

    Re: 2002 STS - aftermarket radio install not working correctly

    yes sorry the links were worng yeah i know i should of not mess with the radio and just installed the 2 12's and amp and left the radio alone but am already in the boat hopefuly i wont have any problems with car locking its self down but with my luck it porbley does happen

    http://www.sonicelectronix.com/item_...s-GMOS-06.html

    http://www.sonicelectronix.com/item_...AC-SWI-RC.html

    Edit : correctly resolve the data transmission faults - chimes, lights, module memories how can i do this puting back the stock radio and when you say one day the car will lock itself down if this happenes what would i need to do just put the stock radio back to get everthing working again as befor or are you saying that it would fry my car computer system were i would have to put money to get this fixed or it would be just put the stock radio back and everthing fix

  8. #23
    old_school is offline Cadillac Owners Member
    Automobile(s): 2002 SLS
    Join Date
    Jul 2012
    Location
    SE Florida
    Posts
    82

    Re: 2002 STS - aftermarket radio install not working correctly

    can anyone tell me if the Axxess GMOS-06 and the Metra GMOS-6 are the same

  9. #24
    eldorado_97's Avatar
    eldorado_97 is offline Cadillac Owners Enthusiast
    Automobile(s): 2000 STS, W/Nav
    Join Date
    Feb 2007
    Location
    Baldwin, Wisconsin
    Age
    24
    Posts
    562

    Re: 2002 STS - aftermarket radio install not working correctly

    Ok.... I bought one of those GMOS-06 modules they are junk along with all of the other ones they make.. yeah they work but they are cheap quality for a lot of money, I put one in my Seville and yeah.. it worked just fine and I had my steering wheel controls hooked up with the swi jack but the chimes were just emulated by the module and sounded horrible, any aftermarket radio will not run the speakers well at all specially the Bose and it will sound 4 to 5 times worse than with the factory radio designed for them. Just my 2 cents but.. if you are dead set on getting it to work if you install the two modules in the links you posted above correctly.. then it will work, you will have some chimes not all, and the car should be just fine. And to answer your last posts yes I believe they are they same things just different names stamped on them.

  10. #25
    EROD316's Avatar
    EROD316 is offline Cadillac Owners Member
    Automobile(s): 2000 Cadillac STS
    Join Date
    Jan 2007
    Location
    QUEENS, NY
    Age
    43
    Posts
    10

    Re: 2002 STS - aftermarket radio install not working correctly

    Yes he is right, these cadillac are very sensitive machine especially when it comes to the electronics. I have found phone chargers, the made in china ones not make a cadillac start. Each module on the Class 2 line works together, so when one interrupts and adds something that was not designed by the manufacturer, the class 2 line voltage changes and causes promblems you cant even imagine would happen.

  11. #26
    Cadillac Kid03's Avatar
    Cadillac Kid03 is offline Cadillac Owners Connoisseur
    Automobile(s): 2003 SLS, 1992 Z28
    Join Date
    Mar 2011
    Location
    In a Van down by the river.
    Age
    22
    Posts
    1,194

    Re: 2002 STS - aftermarket radio install not working correctly

    And this thread pretty much sums up why i will not be doing any aftermarket radios.

  12. #27
    MoistCabbage's Avatar
    MoistCabbage is online now Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    20,386
    A phone charger won't cause the car not to start, unless something plugged into it drains the battery. The power outlets/lighter outlets have absolutely nothing to do with the serial data bus.

  13. #28
    Dadillac's Avatar
    Dadillac is offline Cadillac Owners Connoisseur
    Automobile(s): 2011 Kia Optima SX 2013 Kia Optima SXL
    Join Date
    Nov 2004
    Location
    Woodbridge NJ
    Age
    48
    Posts
    2,779

    Re: 2002 STS - aftermarket radio install not working correctly

    Well I must be a rare case then. I installed an Alpine unit in my deceased '02 SLS. Aside from single pulse chimes not working (not that big a deal) I had no issues that I can remember. Had that head unit in there for 7 years. Only time the car wouldn't start is when the battery dies when it was 7 years old. So do not worry about installing an aftermarket stereo. Just use the Metra GMOS-06 interface and you will be good to go

    Don

  14. #29
    EROD316's Avatar
    EROD316 is offline Cadillac Owners Member
    Automobile(s): 2000 Cadillac STS
    Join Date
    Jan 2007
    Location
    QUEENS, NY
    Age
    43
    Posts
    10
    There is a gm bulletin that talks about weird electronic issue with aftermarket phone chargers.

  15. #30
    cadi509's Avatar
    cadi509 is offline Cadillac Owners Connoisseur
    Automobile(s): 2006 STS V Tango int
    Join Date
    Jan 2010
    Location
    Yakima, Wa
    Age
    25
    Posts
    2,087
    Many people complain about the aftermarket stereo stuff I've done it in both my sevilles with zero issues ever...... If you know what your doing it will work.... But the model stereo I had was getting outdated and I wanted navigation so I went oem..... I've considered doing an entire upgrade to all pioneer components but the price for an OCD guy like me is a little steep........ Good aftermarket brands like pioneer, alpine will blow oem out of the water anyway of the week

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting