1988 EL Dorado Flooding on cold start
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 8 of 8
Cadillac Seville / Cadillac Eldorado Forum Discussion, 1988 EL Dorado Flooding on cold start in Past Cadillac Vehicle Discussion; My 88 ELDO has 140 thousand miles and always ran smooth but recently it began hard cold starts with a ...
  1. #1
    saintaso is offline Cadillac Owners Member
    Automobile(s): 1988 el dorado
    Join Date
    Apr 2012
    Posts
    4

    Angry 1988 EL Dorado Flooding on cold start

    My 88 ELDO has 140 thousand miles and always ran smooth but recently it began hard cold starts with a gas smell, then it wouldn't start at all. my mechanic changed the MAF and a co sensor, ran for 2 days then no start. Swaped out the ECM and got it started for 3 days. Now it won't start and seems like it's getting too much gas and floods right out!
    Any ideas on what could be causing this?

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    MoistCabbage's Avatar
    MoistCabbage is offline Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    21,529
    Quote Originally Posted by saintaso
    my mechanic changed the MAF
    Well he must be very talented....seeing as your car doesn't have a MAF sensor.

    and a co sensor
    What's that? You mean an O2 sensor?

    First off, go to the top of the Seville/Eldorado page, and read the "sticky" thread on how to pull codes. List any codes you may find, AND THEIR DEFINITIONS, here (there's a link within the sticky with definitions, your car is OBD I).


    If you're getting a fuel smell from the exhaust, the engine is either running rich, or there's a misfire. Do you know if the mechanic checked the FPR?

    BTW,

  4. #3
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,475

    Re: 1988 EL Dorado Flooding on cold start

    If not the FPR, then maybe a stuck open injector(s).

  5. #4
    saintaso is offline Cadillac Owners Member
    Automobile(s): 1988 el dorado
    Join Date
    Apr 2012
    Posts
    4

    Re: 1988 EL Dorado Flooding on cold start

    Ha....my bad..I read it incorrectly...MAP sensor it is!....and 02 sensor...thanx for that.
    No gas smell from exhaust just from the engine at the carb...I'll try getting the codes.
    Thank you

  6. #5
    MoistCabbage's Avatar
    MoistCabbage is offline Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    21,529
    Lol, you also don't have a carb. Your car has throttle body fuel injection. Maybe it is a stuck injector as ranger said (You don't see an external leak on that area, right?). That, or no spark.

  7. #6
    saintaso is offline Cadillac Owners Member
    Automobile(s): 1988 el dorado
    Join Date
    Apr 2012
    Posts
    4

    Re: 1988 EL Dorado Flooding on cold start

    OH boy...I have to catch up...thanx again for that info. With much patience I got it started today. Dosen't seem to be a leak around the throttle body but the gas smell is present. drove with lots of hesitation but idles fine. After it's warm, it starts fine These are codes from the dash:
    E022...(current) open TPS signal (VCC)
    E055..(current)..closed throttle angle out of range (TPS)
    E052 ....(history)...PCM memory reset
    B552....(history)...BCM memory reset
    PS> also found out that the TPS sensor was replaced

  8. #7
    drewsdeville is offline Cadillac Owners Master
    Automobile(s): 2011 Crown Vic LX
    Join Date
    Oct 2004
    Location
    Oak Creek, WI
    Posts
    5,310

    Re: 1988 EL Dorado Flooding on cold start

    That TPS is the problem. If it's been replaced recently, check to see if it's disconnected. Else, check wiring to it. Once you get a signal to the ECM, make sure that it is correctly adjusted.

  9. #8
    saintaso is offline Cadillac Owners Member
    Automobile(s): 1988 el dorado
    Join Date
    Apr 2012
    Posts
    4

    Re: 1988 EL Dorado Flooding on cold start

    Thanx much.........I'll check a thread on adjustment procedure..It should have been done but you never know..found that when they say it's "old" most times it means..I don't know how to fix it!!!

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting