Problem with 2000 STS RSS c0579
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 9 of 9
Cadillac Seville / Cadillac Eldorado Forum Discussion, Problem with 2000 STS RSS c0579 in Past Cadillac Vehicle Discussion; Front struts have been replaced with arnott struts this code just came on a few days ago ?...
  1. #1
    dwight.j.carter's Avatar
    dwight.j.carter is offline Cadillac Owners Connoisseur
    Automobile(s): 2003 Seville STS
    Join Date
    Aug 2004
    Location
    Des Moines, Iowa, United State
    Age
    35
    Posts
    2,059

    Problem with 2000 STS RSS c0579

    Front struts have been replaced with arnott struts this code just came on a few days ago ?

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    MoistCabbage's Avatar
    MoistCabbage is online now Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    22,685

    Re: Problem with 2000 STS RSS c0579

    In the future post definition as well.

    C0579 - Left Front Solenoid Circuit Open

  4. #3
    dwight.j.carter's Avatar
    dwight.j.carter is offline Cadillac Owners Connoisseur
    Automobile(s): 2003 Seville STS
    Join Date
    Aug 2004
    Location
    Des Moines, Iowa, United State
    Age
    35
    Posts
    2,059
    Thread Starter

    Re: Problem with 2000 STS RSS c0579

    so does that mean the sensor on the left front one is bad ? I would think i can get a resistor to go in there since the fronts are arnott.

  5. #4
    MoistCabbage's Avatar
    MoistCabbage is online now Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    22,685

    Re: Problem with 2000 STS RSS c0579

    No, not the height sensor. There's multiple threads on using resistors, do a search. I'm wondering why theres not a code for both fronts if both were replaced with non active struts?

  6. #5
    JimD is offline Cadillac Owners Connoisseur
    Automobile(s): '98 STS (RIP @ 206,xxx miles)
    Join Date
    Sep 2003
    Location
    Atlanta area
    Posts
    4,834

    Re: Problem with 2000 STS RSS c0579

    Quote Originally Posted by dwight.j.carter View Post
    so does that mean the sensor on the left front one is bad ? I would think i can get a resistor to go in there since the fronts are arnott.
    Your code (C0579) is not a sensor. The code is telling you that the circuit to the strut solenoid coil is open. Since your Arnott struts do not have a solenoid, there was some value of resistance placed in the solenoid wiring (when the Arnott struts were installed) that would mimic the inductive reactance of the solenoid coil.

    That Arnott resistance has failed or become disconnected or something.

    And yes, you can mimic the original strut solenoid coil inductive reactance with a 4.7K Ohm resistor; Radio shack item #217-1124.

  7. #6
    dwight.j.carter's Avatar
    dwight.j.carter is offline Cadillac Owners Connoisseur
    Automobile(s): 2003 Seville STS
    Join Date
    Aug 2004
    Location
    Des Moines, Iowa, United State
    Age
    35
    Posts
    2,059
    Thread Starter

    Re: Problem with 2000 STS RSS c0579

    So get this it's raining here i went out to the store and it isn't coding in the rain. We will see if it comes back when it stops raining here. lol

  8. #7
    dwight.j.carter's Avatar
    dwight.j.carter is offline Cadillac Owners Connoisseur
    Automobile(s): 2003 Seville STS
    Join Date
    Aug 2004
    Location
    Des Moines, Iowa, United State
    Age
    35
    Posts
    2,059
    Thread Starter

    Re: Problem with 2000 STS RSS c0579

    Arnott sent me a new sensor to put on that should fix it.

  9. #8
    N*Caddy's Avatar
    N*Caddy is offline Cadillac Owners Master
    Automobile(s): 1997 Cadillac STS (BOSE w/AUX In, Massage Seats, URPAS, "Z")
    Join Date
    Nov 2006
    Location
    Toronto, Canada
    Age
    36
    Posts
    6,405

    Re: Problem with 2000 STS RSS c0579

    Is not a sensor, originally is a coil (part of a solenoid) and what Arnott sent you is a resistor (to trick the CVRSS module).

  10. #9
    johnny kannapo's Avatar
    johnny kannapo is offline Cadillac Owners Connoisseur
    Automobile(s): 1996 Eldorado
    Join Date
    Oct 2009
    Location
    Pigseye, Mn
    Age
    54
    Posts
    2,815

    Re: Problem with 2000 STS RSS c0579

    Check the connection at that wheel.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting