What I found with my 97 ETC ABS/TC problem
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 19
Like Tree3Likes
Cadillac Seville / Cadillac Eldorado Forum Discussion, What I found with my 97 ETC ABS/TC problem in Past Cadillac Vehicle Discussion; Hello all of you members ,I have been a member for sometime now and a ETC owner for 12 years. ...
  1. #1
    Racer704 is offline Cadillac Owners Member
    Automobile(s): 97 ETC
    Join Date
    Jun 2006
    Posts
    83

    What I found with my 97 ETC ABS/TC problem

    Hello all of you members ,I have been a member for sometime now and a ETC owner for 12 years. Been a great car but has it like many cars some quirks that were difficult to sort out.I would like to thank all the board member with all there responses to others here with there problems as its helped me many times.

    I am a ex GM tech. from late 70's to early 90's but the Northstar was something i have learned over time and love it. To the point here,I had to replace a water pump and i decided to at the same time replace the leaking crossover seals.

    Went well but after about a week and 200 plus miles i got and forgive me as i dont remember the codes but the ABS/TC lights came on and I also noticed I had no low gear. Talked to a few differant Caddy tech at differant dealers and was told the tranny issues were seperate...didnt belive them for a minute and I dont debate i just move on.

    I do remember that there was a open and a short to ground code for the ABS/TC so when i started to do a pin check I noticed that those and 5 other pins were all messed up from the antifreeze as my controll unit sets under the water pump housing so all leaks from hoses and or pump went right down onto that connector.

    Cleaned them very good and added dilectric grease and presto chango all is fixed and happy including my low gear that came back...I knew they were related as i down shift manuly all the time but was told it was the shift noids and there was a upgraded kit...anyway i hope this may help others as it was a simple fix ...
    Marky Thunder likes this.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    N*Caddy's Avatar
    N*Caddy is offline Cadillac Owners Master
    Automobile(s): 1997 Cadillac STS (BOSE w/AUX In, Massage Seats, URPAS, "Z")
    Join Date
    Nov 2006
    Location
    Toronto, Canada
    Age
    36
    Posts
    6,405

    Re: What I found with my 97 ETC ABS/TC problem

    The disabling of the first gear is well known feature of the car, this is done every time the T/C is not operation to protect your transmission.
    The following very common issue could occur with the EBTCM:
    1. The BPMV pump motor ground bolted in the back of the motor case it gets corroded (because the module is located down low on the subframe out in the element), great for weight distribution not so great for anything else.
    2. The EBTCM connector is known to get soaked in coolant when work is done to the T-stat, hoses, water pump and crossover (kind of impossible to be done with engine in the car how did you pulled that one?).

    I am always surprised how much more I know about my car than the "guru" leed tech of any GM dealership. You then have to realize these cars are quite rare and unlike any other GM cars. They do know a heck lot more than me about Cavaliers, Grand AM, Saturns and so on though.

  4. #3
    Racer704 is offline Cadillac Owners Member
    Automobile(s): 97 ETC
    Join Date
    Jun 2006
    Posts
    83

    Re: What I found with my 97 ETC ABS/TC problem

    Quote Originally Posted by N*Caddy View Post
    The disabling of the first gear is well known feature of the car, this is done every time the T/C is not operation to protect your transmission.
    The following very common issue could occur with the EBTCM:
    1. The BPMV pump motor ground bolted in the back of the motor case it gets corroded (because the module is located down low on the subframe out in the element), great for weight distribution not so great for anything else.
    2. The EBTCM connector is known to get soaked in coolant when work is done to the T-stat, hoses, water pump and crossover (kind of impossible to be done with engine in the car how did you pulled that one?).

    I am always surprised how much more I know about my car than the "guru" leed tech of any GM dealership. You then have to realize these cars are quite rare and unlike any other GM cars. They do know a heck lot more than me about Cavaliers, Grand AM, Saturns and so on though.
    Hi NCADDY, well it wasnt that bad and i did it on the hotest day in July with nothing but hand tools,I just removed anything that looked like it would be in the way since this was my first and having been a GM tech i learned to always remove things the 1st time you do anything and then flat rate on the next one as you will see what you didnt have to take off or what didnt matter. But other then the heat was about a 4 hour job and I bought a new Tstat housing as they have a upgraded one out.The only pain was the hidden crossover bolts I had a hard time with as like a dummy i didnt look at a exploded view to see them all...you will have to pull like hell on the wire harness also that crosses over the tranny....but your right the location of the EBTCM is a bad one to say the least..thatnks for your comments

  5. #4
    Marky Thunder's Avatar
    Marky Thunder is offline Cadillac Owners Member
    Automobile(s): 1997 Cadillac ETC
    Join Date
    Apr 2012
    Location
    South Florida
    Age
    53
    Posts
    11

    Re: What I found with my 97 ETC ABS/TC problem

    Hey Racer 704 I am having same problem water pump leaked on connector changed out radiator and hose leaked on it too now I have No 1 st gear and ABS TC lights are on ..I hope pulling switch off and cleaning connector helps me out too. My Email is marky thunder at yahoo dot com. if you have a pic of the proper way to pull connector I would greatly appreciate it. Many Thanks.




    Quote Originally Posted by Racer704 View Post
    Hello all of you members ,I have been a member for sometime now and a ETC owner for 12 years. Been a great car but has it like many cars some quirks that were difficult to sort out.I would like to thank all the board member with all there responses to others here with there problems as its helped me many times.

    I am a ex GM tech. from late 70's to early 90's but the Northstar was something i have learned over time and love it. To the point here,I had to replace a water pump and i decided to at the same time replace the leaking crossover seals.

    Went well but after about a week and 200 plus miles i got and forgive me as i dont remember the codes but the ABS/TC lights came on and I also noticed I had no low gear. Talked to a few differant Caddy tech at differant dealers and was told the tranny issues were seperate...didnt belive them for a minute and I dont debate i just move on.

    I do remember that there was a open and a short to ground code for the ABS/TC so when i started to do a pin check I noticed that those and 5 other pins were all messed up from the antifreeze as my controll unit sets under the water pump housing so all leaks from hoses and or pump went right down onto that connector.

    Cleaned them very good and added dilectric grease and presto chango all is fixed and happy including my low gear that came back...I knew they were related as i down shift manuly all the time but was told it was the shift noids and there was a upgraded kit...anyway i hope this may help others as it was a simple fix ...

  6. #5
    basscatt's Avatar
    basscatt is offline Cadillac Owners Master
    Automobile(s): 89 Coupe DeVille, 95 Sedan DeVille, 03 SLS, two 02 DHS's
    Join Date
    Feb 2004
    Location
    Minnesota
    Age
    63
    Posts
    9,891

    Re: What I found with my 97 ETC ABS/TC problem

    Quote Originally Posted by Marky Thunder View Post
    Hey Racer 704 I am having same problem water pump leaked on connector changed out radiator and hose leaked on it too now I have No 1 st gear and ABS TC lights are on ..I hope pulling switch off and cleaning connector helps me out too. My Email is marky thunder at yahoo dot com. if you have a pic of the proper way to pull connector I would greatly appreciate it. Many Thanks.
    ------------------------------------
    don't expect a reply -

    this thread is almost 3 years old -

    and racer704 hasn't been around in almost a year -

    oh - you should NEVER put your email on ANY public forum -
    spam harvesters LOVE working emails -
    you might start getting LOTS of garbage -

    if you MUST display your email - spell it out -
    so the spambots don't recognize it - like this -

    someone AT something DOT COM -

  7. #6
    N*Caddy's Avatar
    N*Caddy is offline Cadillac Owners Master
    Automobile(s): 1997 Cadillac STS (BOSE w/AUX In, Massage Seats, URPAS, "Z")
    Join Date
    Nov 2006
    Location
    Toronto, Canada
    Age
    36
    Posts
    6,405

    Re: What I found with my 97 ETC ABS/TC problem

    There is only one way you can insert the connector, if one way doesn’t work then tun it 180*. However there is a easy way to tell as the harness is pretty difficult to bend to connect wrong, also that metal lock tab (looks like a handle) should be on top. There is also a small locking tab that locks in place the tab (double protection ensuring the connector does not come off).

  8. #7
    Marky Thunder's Avatar
    Marky Thunder is offline Cadillac Owners Member
    Automobile(s): 1997 Cadillac ETC
    Join Date
    Apr 2012
    Location
    South Florida
    Age
    53
    Posts
    11

    Re: What I found with my 97 ETC ABS/TC problem

    Thank You I tried this several times still no luck with getting First gear back I guess I must read codes and find out what must be replaced The switch connector is very clean on pins no corrosion visible and not sure how to pull codes I will read on in forums Thanks.

  9. #8
    Submariner409's Avatar
    Submariner409 is offline If it won't run, stick on fender vents
    Automobile(s): 2002.5 F55 STS/65500mi, 2004 Ford F150 SuperCab4x4
    Join Date
    Feb 2006
    Location
    MD Eastern Shore - Kent Island
    Age
    74
    Posts
    44,692

    Re: What I found with my 97 ETC ABS/TC problem

    Just above this post/thread - the sticky "How to pull codes". Use the proper year/model group of instructions and then return to the sticky to open the link to definitions of all OBD2 codes.

  10. #9
    Marky Thunder's Avatar
    Marky Thunder is offline Cadillac Owners Member
    Automobile(s): 1997 Cadillac ETC
    Join Date
    Apr 2012
    Location
    South Florida
    Age
    53
    Posts
    11

    Re: What I found with my 97 ETC ABS/TC problem

    I just read codes I have a TCS C1233 CURRENT code any Ideas? I also have no first gear I know its the EBTCM but connector seems fine hope I can get it going again I do Love my car. Thanks Guys .

  11. #10
    MoistCabbage's Avatar
    MoistCabbage is online now Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    21,534
    What's the code definition?

    In pre '00 cars, the transmission will start out in second if TCS is disabled.

  12. #11
    Marky Thunder's Avatar
    Marky Thunder is offline Cadillac Owners Member
    Automobile(s): 1997 Cadillac ETC
    Join Date
    Apr 2012
    Location
    South Florida
    Age
    53
    Posts
    11

    Re: What I found with my 97 ETC ABS/TC problem

    Not sure definition Code is TCS C1233 current code.

  13. #12
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,487

    Re: What I found with my 97 ETC ABS/TC problem

    See the DTC Sticky and use the OBDI link to decipher the codes.

  14. #13
    Marky Thunder's Avatar
    Marky Thunder is offline Cadillac Owners Member
    Automobile(s): 1997 Cadillac ETC
    Join Date
    Apr 2012
    Location
    South Florida
    Age
    53
    Posts
    11

    Re: What I found with my 97 ETC ABS/TC problem

    Quote Originally Posted by Ranger View Post
    See the DTC Sticky and use the OBDI link to decipher the codes.
    C1233 - Right Front Wheel Speed Circuit Open or Shorted


    CAN THIS MAKE MY TRANS NOT HAVE FIRST GEAR FROM SPEED SENSOR OUT my ABS and Traction control light is on and NO first gear I thought it may be my ABS control module.

  15. #14
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,487

    Re: What I found with my 97 ETC ABS/TC problem

    A bad WS sensor disables the ABS and TC (ABS is used in TC). I believe it may take out 1st gear. You need to replace the hub & bearing assembly anyway so see if that solves your problem.
    Marky Thunder likes this.

  16. #15
    MoistCabbage's Avatar
    MoistCabbage is online now Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    21,534
    Yup, as posted. The transmission starts out in second gear when TCS is disabled on pre '00 cars.
    Marky Thunder likes this.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting