1978 Seville flooding
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 5 of 5
Cadillac Seville / Cadillac Eldorado Forum Discussion, 1978 Seville flooding in Past Cadillac Vehicle Discussion; Hi to everyone, and thanks for reading this post. I have a 1978 Cadillac Seville with 350 EFI. CAr was ...
  1. #1
    78cadi is offline Cadillac Owners Member
    Automobile(s): 1978 cadillac seville
    Join Date
    Jul 2010
    Posts
    1

    Unhappy1978 Seville flooding

    Hi to everyone, and thanks for reading this post. I have a 1978 Cadillac Seville with 350 EFI. CAr was running fine and just shut off while driving. The engine floods profusely with the ECU plugged up. I have already checked the coolant and air temp sensors (both read 1100 ohms), fuel pressure (38 PSI), and pressure regulator is fine. I have a Chiltons guide on this vehicle but it gives no info on troubleshooting the TPS sensor (only adjustment). After a couple of hrs. I noticed one of the TPS mounting screws had fallen out and the other was very loose. The car will flood upon trying to start, if I disconnect the ECU it will start and run until all fuel is spent. With the car running I connect the ECU and it shuts off immediately. Any help will be greatly appreciated. I have experience troubleshooting late model vehicles with plenty of diagnostic equipment but I have no way of connecting to this vehicles ECU. Kind of stuck on his one. Thanks.


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    acefrede is offline Cadillac Owners Member
    Join Date
    Nov 2010
    Location
    Cincinnati, Ohio
    Posts
    6

    Re: 1978 cadillac seville flooding

    78Cadi
    Did you ever get to the bottom of your problem? I have a 78 seville that is doing the same thing, I thought you were writing about this one . I have tried a different ECU but it was used and not sure if it was a good one. I have had to change the oil twice now just from all the testing.
    Thanks

  4. #3
    Submariner409's Avatar
    Submariner409 is offline If it won't run, chrome it
    Automobile(s): 2002.5 F55 STS - 67,500 miles, 2014 Explorer XLT FWD
    Join Date
    Feb 2006
    Location
    MD Eastern Shore, Kent Island
    Age
    77
    Posts
    57,162

    Re: 1978 cadillac seville flooding

    Quote Originally Posted by acefrede View Post
    78Cadi
    Did you ever get to the bottom of your problem? I have a 78 seville that is doing the same thing, I thought you were writing about this one . I have tried a different ECU but it was used and not sure if it was a good one. I have had to change the oil twice now just from all the testing.
    Thanks
    Most of what's in this Seville forum will be 4.9 or 4.6 Northstar engine - for the 350, try down in Discussions; Engines - there's a 350 forum there.

  5. Remove Advertisements
    Cadillac Forums
    Advertisements
     

  6. #4
    hjlint is offline Cadillac Owners Member
    Automobile(s): 1978 Cadillac Seville
    Join Date
    Jul 2011
    Location
    Hummelstown, Pa.
    Posts
    10

    Re: 1978 cadillac seville flooding

    Check for Vacuum at the ECU.Check the vacuum hose back to the engine, no splits, loose or blocked.
    If ok. hook up a hand vacuum pump to the ECU port, as soon as you start the engine, applyy 18 inches of vacuum to this and see f this clears the problem, if not ECU (map sensor)is bad. Be sure there is Vacuum comming out of the engine for that hose.

  7. #5
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    69
    Posts
    82,386

    Re: 1978 Seville flooding

    I suspect it's fixed by now as this thread is 3 years old.

  8. Remove Advertisements
    Cadillac Forums
    Advertisements
     

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

What Cadillac(s) do you own? (Or type NONE)

Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •