Idle Speed High?
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 12 of 12
Cadillac Seville / Cadillac Eldorado Forum Discussion, Idle Speed High? in Past Cadillac Vehicle Discussion; So I cleaned my TB and the Idle Speed Sensor and now I am getting the engine light to come ...
  1. #1
    badrhino's Avatar
    badrhino is offline Cadillac Owners Member
    Automobile(s): 1999 Cadillac STS
    Join Date
    Aug 2009
    Location
    Hays, Kansas
    Posts
    55

    Idle Speed High?

    So I cleaned my TB and the Idle Speed Sensor and now I am getting the engine light to come on and a code P0507 to show up. I have messed with it for over a week now and the same thing. I took the sensor back out today and looked it over and replaced it. Everything is hoked up right and it is still throwing the P0507 code andthe car does seem to idle faster.

    What can be done to get it to run normal and quit throwing the code? The damn thing never done it until I decided to clean the Throttle Body.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    70,478

    Re: Idle Speed High?

    When you say sensor do you mean the IAC valve? Is the throttle linkage hanging up? Did you clean the throttle plate perimeter as well as the bore?

  4. #3
    stgry1 is offline Cadillac Owners Member
    Automobile(s): 99 seville
    Join Date
    Jul 2009
    Age
    44
    Posts
    52

    Re: Idle Speed High?

    Sounds like you may have damaged the IAC or a piece of carbon/dirt may have lodged inside. Try a new IAC. I think they're relatively inexpensive.

  5. #4
    badrhino's Avatar
    badrhino is offline Cadillac Owners Member
    Automobile(s): 1999 Cadillac STS
    Join Date
    Aug 2009
    Location
    Hays, Kansas
    Posts
    55

    Re: Idle Speed High?

    Yes, I am talking about the IAC sensor. And they are not inexpensive, I heard the were quite costly! The sensor looks clean and yes I did clean around the throttle plate parimeter also.

    I had the wife turn the key on and off when I had the IAC out (but still hooked up to harness) and it would worm itself back and forth when turned on and off.

  6. #5
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    70,478

    Re: Idle Speed High?

    Just for clarity, that is a valve, not a sensor. Sounds like it is working OK. How about the linkage? When it is idling high, can you force the throttle plate closed a little more? If so, that is your problem. If not, check the over pressurization valve at the other end of the manifold. It's a spring loaded flapper door so to speak. Listen for a vacuum leak. It's tucked way back in behind the P/S pump.

  7. #6
    badrhino's Avatar
    badrhino is offline Cadillac Owners Member
    Automobile(s): 1999 Cadillac STS
    Join Date
    Aug 2009
    Location
    Hays, Kansas
    Posts
    55

    Re: Idle Speed High?

    Ranger, that could be the culprit. I have had a loud whinning noise come from around the P/S pump area ever since this has been happening. The whinning could be a vacuum leak. I will check it tomorrow and let you know. Thanks!

  8. #7
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    70,478

    Re: Idle Speed High?

    Bingo! Have you had a backfire lately? Maybe you can just pull it open and let it snap closed or push it closed. Maybe just reseat the seal, but you'll probably have to pull the manifold.

  9. #8
    badrhino's Avatar
    badrhino is offline Cadillac Owners Member
    Automobile(s): 1999 Cadillac STS
    Join Date
    Aug 2009
    Location
    Hays, Kansas
    Posts
    55

    Re: Idle Speed High?

    Ranger, it is definately that flap your are talking about on the other side of the manifold. I don't know if I can open it or close it from where it is whithout removing the darn manifold. I have got a screw driver in there and pushed on it to close it and it will stop making the noise but once you rev up the motor it will open up a bit and make the high pitched squeeling agian. Well on the positive side I guess it isn't my P/S pump going out.

    How difficult is it to remove the manifold? Looks like it might be a chore. Anything I should look out for, etc.?

  10. #9
    badrhino's Avatar
    badrhino is offline Cadillac Owners Member
    Automobile(s): 1999 Cadillac STS
    Join Date
    Aug 2009
    Location
    Hays, Kansas
    Posts
    55

    Re: Idle Speed High?

    I got it. I spayed some TB CLeaner while I was moving it slightly and got it to seal back up. Yeeha!

  11. #10
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    70,478

    Re: Idle Speed High?

    Hard to believe that could cure it. Keep an eye on it. Removing the manifold is not too bad of a job if it becomes necessary.

  12. #11
    badrhino's Avatar
    badrhino is offline Cadillac Owners Member
    Automobile(s): 1999 Cadillac STS
    Join Date
    Aug 2009
    Location
    Hays, Kansas
    Posts
    55

    Re: Idle Speed High?

    Well i am still getting the "idle speed high" code and a service engine light. I have checked all of the vacuum lines and have made sure the Throttle Body plate was closing and the cable is not hanging up. Any other thoughts?

  13. #12
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    70,478

    Re: Idle Speed High?

    I think you are going to have to pull the manifold and probably replace the over pressurization door seal.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting