: keyless entry and TPM DOA Twice! Story inside



Wife_took_my_Cadi
01-09-07, 12:08 AM
Well I thought I would post my experince here and see what you guys have to say. I took the V into the dealer for TPM DOA and keyless entry not working. Wife get a call stating that thy are not going to cover it under warranty. They told her that "You must have and after market amp or something. Because you cut into the harness........" I knew right away what they were talking about. It is the AUX Input I installed like in the FAQ. Except I used solder and heat shrink. Now im pissed so I go down to the dealer. I ask to speak with a manger and my service writer. Manger had left for the day but the service writer comes out and says, "Mr.XXXXXXX your car is fix just need to take a minute to reset the TPM" WTF........... I thought you were not going to cover it? No, it is fine no problem it's all fixed.

Fast forward 2 days

Wife calls me after she gets to work and says " The TPM and Keyless entry are not working again" So I call the service writer up to schedule a time to bring it in. He says well when you bring it in the tech and I will go over what you did to those wires and find out why they are causing the problem. WTF how is the TPM connected to XM radio??????? How is it my fault???? The Aux input has been installed in the car since it was 5 days old. Now how all of a sudden does this cause a problem? Btw aux input still works bitchin'. Is the tech just guessing? I cant see any where on the wiring diagram the the two systems connect. I just dont want to have any suprises.

Adam
01-09-07, 12:13 AM
mine quit working today and i dont have anything installed. now i have to get a new key fob. they looked at it and i dont remember what they said exactly, something to do with a contact? i dont remember now, but its 65 for a new key fob and 35 to program it. chances are it has nothing to do with your install.

lawfive
01-09-07, 12:16 AM
The TPM and Keyless entry are not working again. I cant see any where on the wiring diagram the the two systems connect.
The two systems connect at the antenna. Check the snap connector into the array at the top of the rear window, on the driver's side.

ctsvett
01-09-07, 12:20 AM
Ok, this is BS... the XM input has NOTHING to do with the keyless entry... Assuming that the aux input is working right (which means its hooked up right)...

Call BS and make them prove it... E-mail me if you need help. Is there another dealer nearby? These guys sound like morons....

Few more dumb questions:
1. Did you change the battery in the fob?
2. Does the second FOB work?
3. Did they try reprogramming the FOBs?
4. Any other issues (especially with personalization, radio stations, etc)?

Reed

Wife_took_my_Cadi
01-09-07, 12:36 AM
Reed the I pod input has been working and is still working right now. The things that do not work TPM, and keyless entry, both fobs. These guys suck but nearest other dealer =50 miles away:bomb: .

lawfive
01-09-07, 12:40 AM
Did you check the connector, and is it still attached to the rear window? The TPS and keyless entry share the same rear window antenna array. If the snap connector is still tight on the window, I suppose the break could be somewhere else. Unfortunately I haven't traced the wiring harness and so don't know where "somewhere else" might be.

ctsvett
01-09-07, 12:47 AM
from what you are saying it sounds like the rear body module is dead/dying... I have heard of this happening on other Cars... It just happens, but has NOTHING (i repeat NOTHING) to do with the aux input mod.

Fight them on it and make them prove that the aux input killed it (which they cant)... Burden of proof is on them. Again, e-mail me if you have issues still.

The aux input is not even plugged into the rear body module in ANY way. Wires that you spliced into for the aux input go directly to the radio input in the back of the radio (just fyi).

Do you mean Aux input or R&M ipod kit, just for my info?

Reed

ctsvett
01-09-07, 12:49 AM
lawfive makes a good point I didnt think of.. Check the window antenna connector. This has been known to fail as well...

the TPS, keyless, etc are all on the same antenna out of the rear body module...

Nice one Lawfive!


Reed

Wife_took_my_Cadi
01-09-07, 12:50 AM
Lawfive: antenna wires still connected to glass

Reed: Aux input

lawfive
01-09-07, 01:00 AM
Meh... 'course it couldn't be easy!

lawfive
01-09-07, 01:01 AM
Reed: clock off by 46 minutes on the server.