: Missing Hitch cover panel



rsbrandt
12-24-06, 11:44 PM
I use my 07 ESV to pull my ATV and Snowmobile trailers. I was taking the hitch cover on and off. I noticed it had 2 plastic fasteners at the bottom on each side and had fingers that fit into the top of the lower part of the bumper. Well one day I whent to go take it off and it was GONE! The dealer is fighting me on this since I used the hitch. This piece of plastic must cost a ton plus it probably will need to be painted. Anyone know of a good place to get one inexpensively?

When I first used it I thought " this is crappy plastic and it's gonna come off some day. That was in early October. Here we are 3 months later and sure enough it's gone.

Nice truck, hauls butt! I don't know why the spedometer goes to 160, I can only get mine up to 106 before it cuts out. The Spedo must be there for looks!

OICU812
12-31-06, 12:14 PM
I damaged mine on my O7 Escalade. Quote from dealer and body shop for unpainted cover = $94.00 Then, to paint they figure another 1.5 hrs but that was high. I think it was another $75.00 for painting/coating. Very simple. I do not think the replacement came with the turn clips so be sure to verify since you do not have any.

TMW597
12-31-06, 01:05 PM
Yep! OICU812, that's sounds about right.

rsbrandt, if you want to go faster than 106 mph, pick up one of these: http://www.autoanything.com/performance-chips/60A2342A0A0.aspx

I bought one for my 07' Yukon XL. It's great, changes your shift points, gives you a bit more horsepower, and just a little better fuel mileage.

hcvone
01-08-07, 11:00 AM
I had better luck with the Preditor than the Superchip on my 03', just waiting for Preditor to fix their problem, of send out my computer to Ed Wright at Fast Chips. :)