: 1989 Deville Stereo ?????



madapple33
12-18-06, 08:26 AM
Hello,
I have been a car guy all my life ( I'm 52), I just bought a
1989 Deville from an estate, it only has 67k miles and looks
like new. I love the car but have a problem with the stereo,
everything else works like new.
The car has the Delco Bose Gold stereo and I have no sound
from the left side speakers. I am trying to figure out if I can just
put in a new head unit with CD, and fix the problem, but have
been reading about a "amp" for the speakers and now don't know
if it is the stereo, or speakers, or amps causing the problem. I
know you guys can head me down the right road. I am used to
working on a more normal stereo.
Thanks
Darrell

ps. The Deville is white, w/white vynal top, and white leather.

CadillacSTS42005
12-18-06, 09:22 AM
both left amps blown
theres one for each speak
replace'm

dp102288
12-18-06, 12:18 PM
madapple33-nice name! Sounds like you got a nice car too. You can introduce yourself in the lounge to the rest of the board.

Oh yeah what he said! :p

AnimalRick
01-14-07, 01:38 AM
I too have an 89 deville...and found that 3 of the speakers are blown... front ones from sun damage (paper is falling apart). I have an AM/FM/CD to put in it (not a caddy radio) and speakers.... I read about what to take apart to swap the speakers, anything else I need to know?

Rick

AnimalRick
01-16-07, 07:55 AM
Update:

After wrestling with the back seat to get to the rear speakers, it turns out they are fine.... Pioneer 250 watts on each side.

I havent worked on the front speakers yet... there is loud cracking on the right side, I hear it in the back since the front speakers are rotted.

Rick