: Helpppp!! (programmer)



nofinga911
12-13-06, 07:40 PM
I just tried programming my car with the new preditor programmer and everytime i try, it makes a backup file and never lets me actually install a tune...why is this?? and now my check engine light is on..

nofinga911
12-14-06, 03:22 AM
anyone? please....i cant beleive its not working...what could i be doing wrong?? this is the third one i have used and i never had a problem before..

TheCaddyKidd
12-14-06, 03:56 AM
what year escalade? i know on my 06 you had to remove fuses for the programmer to actually work...

hcvone
12-14-06, 05:43 AM
I have a Preditor for the 07' but have not even opened the box yet. It makes a backup file of your stock settings first, then allows you to program your changes in. I will try to get to do my truck in the next few days if I have the time. :) You can call the people at Preditor too, they are pretty helpful. As the TheCaddyKidd said did the instructions say anything about the fuses, because on my 03' they had to be removed to get it to work.

nofinga911
12-14-06, 06:37 PM
I have a Preditor for the 07' but have not even opened the box yet. It makes a backup file of your stock settings first, then allows you to program your changes in. I will try to get to do my truck in the next few days if I have the time. :) You can call the people at Preditor too, they are pretty helpful. As the TheCaddyKidd said did the instructions say anything about the fuses, because on my 03' they had to be removed to get it to work.

yea i have an 07' and it said the fuses for the onstar needed to be removed...but i have had instructions for other programmers say that in the past but i heard it wasnt necessary so i never did it and they always worked...did anyone else try it without removing the fuses and then have it work when removing the fuses? I will try removing the fuses tomorrow and see if it works....thanks guy, i never used predator so it prob. is the fuse issue...

TheCaddyKidd
12-14-06, 06:47 PM
on my 06 it said to remove the fuses and it didnt work when i tried to do it without removing them... then i removed them and it worked perfectly.. but i remember i had to remove like 3 fuses.. there is the radio, BC1 or something and some others.. the directions should list all the fuses that have to be removed.. then jsut match them up to the fuse diagram..

nofinga911
12-14-06, 08:26 PM
ok im gonna check it out prob. tomorrow...thanks a lot guys!

nofinga911
12-14-06, 10:16 PM
I couldn't just sit here and watch my programmer be worthless so I went outside to remove the fuses and give it another shot with the fuses removed...The problem is I cannot locate the following fuses, neither under the driver dash, under the hood, or in the manual... RADIO , RADIO AMP , INFO , SEO 1 , SEO IGN , RDO 1 , RAP 2 , TBC ACCY ....can anyone help?

TheCaddyKidd
12-14-06, 10:25 PM
on my 06 i know for a fact that the radio fuses were under the hood.. take off the fuse panel cover and look underneath.. there si a diagram with each fuse's label to say what it is for... if it is the same layout than the radio fuses should be in the right bottom corner when standing on the side of the vehicle..

nofinga911
12-14-06, 10:34 PM
on my 06 i know for a fact that the radio fuses were under the hood.. take off the fuse panel cover and look underneath.. there si a diagram with each fuse's label to say what it is for... if it is the same layout than the radio fuses should be in the right bottom corner when standing on the side of the vehicle..

what the heck is the INFO fuse?

TheCaddyKidd
12-14-06, 10:58 PM
its all in there... i was confused at first too but once i looked in the manual and also under the hood at the bottom of the fuse panel cover i found the fuses in 2 seconds..

nofinga911
12-14-06, 11:12 PM
its all in there... i was confused at first too but once i looked in the manual and also under the hood at the bottom of the fuse panel cover i found the fuses in 2 seconds..

yes but none of the fuses are labled or marked INFO ...and the manual doesnt list it either...could it also be marked as something else?

TheCaddyKidd
12-14-06, 11:19 PM
i dont think so.. mine was listed as INFO

nofinga911
12-14-06, 11:43 PM
i dont think so.. mine was listed as INFO

on the manual or on the fuse? I'm starting to think the 07' fuse box is different

TheCaddyKidd
12-14-06, 11:46 PM
i think it was on both.. but i def remember it being on the bottom of the lid.. im starting to wonder if they just copied the instructions over from previous years thinking it would be the same..

nofinga911
12-14-06, 11:51 PM
i think it was on both.. but i def remember it being on the bottom of the lid.. im starting to wonder if they just copied the instructions over from previous years thinking it would be the same..

yeah i was thinking they might have copied it from older years as well...but hey i could be wrong..i was rushing..ill give it another shot tomorrow and le you know how things work out

jamesmbond
12-21-06, 08:07 PM
I think Diablo is pulling our leg on the 2007 Predator--I have the same problems with the device constantly backing up my existing (OEM) settings and never letting me to the Install Tune part.

I've used Predators on my two others cars so I believe I have an idea what I'm doing (and I broke down and read the manual which seems to indicate I'm doing everything correctly).

The manual is CLEARLY not written with any knowledge of the 2007 Escalade as the fuses are not all labeled the same. I was able to find the RDO and Info fuses and pulled them but no change--still won't program. There is no SEO IGN, RAP 2, TBC ACCY, or Onstar as mentioned in the manual.

Has anyone gotten a Predator to work on you 2007 Escalade yet?

jamesmbond
12-23-06, 05:35 PM
called tech support at Diablo---apparently they have a problem with all 6.2L V8 (i.e. 2007 Escalade and Denali). ... Guess they started shipping product a little too soon. No solution as of yet according to Diablo

Don't buy the Predator yet if you have a 2007 Escalade/Denali with 6.2L!!!

zx6racer
12-23-06, 07:32 PM
Maybe thats why there for sale on Ebay.... Everyone is ditching them.