: Reduced power mode......



MadMike
11-27-06, 05:24 PM
So, were cruising down the highway today and all was well....for a minute...suddenly "pop" and no power.....says reduced(or whatever) power mode on the nav screen.......luckily we were just past a major intersection and was in a slower lane. Just had time to get off to the right. NO power NO chance of going anywhere. rough idle and a big lurch when trying to go even at idle. Hullo Onstar! No problem found said the diagnosis. but it still wouldn't go anywhere. After a while I tried again and it seemed to fix itself. So, off we go down the road to the next major intersection (405X101) and guess what?...POP again and no power....this time it got off the highway thanks to the guy from the tow company (thanks H & H) and got towed to the nearest dealer, luckily it was the one we got the car from (Casa De Cadillac) These
guys never even questioned it. Boom, heres a rental cts, and we will call when its ready. All this happened at about 2PM friday after thanksgiving and by the time we got home, about 4:30P they had called and the car was ready to go. crankshaft position sensor went out and replaced
Picked it up the next day all washed up and ready to go....
great service and clean and fast too!
Casa De Caddilac = good guys
Mike

CIWS
11-27-06, 05:29 PM
Good to know, where are they at ?

roadracerx72
11-27-06, 07:03 PM
Ventura Blvd near Sepulveda

BeagleBrains
11-27-06, 09:09 PM
I had the same problem with my 1991 Jeep 4.0 Wrangler. The TPS would last for about five years. After the second failure, I bought two. Installed the spare after four years. Not more stalls. Throttle Position Sensors appear to have a finite service life. Sounds like I need to find the TPS in the V and put the part and a screw driver in the glove box.