: Ping



Timothy60
10-30-06, 04:23 PM
Hello,
Recently, my 93 Fleetwood (161,000 miles) has started mild "pinging" at moderate throttle settings. The timing is dead-on. Shouldn't the knock sensor detect the pinging and retard the spark? It does not throw any codes. I've tried a tankful of high-test but it made no difference. Any ideas? Your suggestions are appreciated.
Tim

caddycruiser
10-30-06, 05:08 PM
When our '93 did it, and did it pretty badly, the EGR valve was bad and replacing it & the solenoid cured it completely. Of course, ours also registered the -32 code for EGR, which was how the dealer figured it out, so it may not be your problem. But you never know.

90Brougham350
10-30-06, 07:39 PM
Be very weary of exhuast leaks. In the right places, they can sound identical to pinging. Then you spend weeks pulling your hair out trying to get the timing perfect, checking for for codes, wondering if you have bad wiring somewhere.....ask me how I know!

BCs71
10-31-06, 03:07 PM
If you still have the original knock sensor then I would be weary of the frequencies it is sending now... probably a good maintenance item to swap out at 100K+ miles.

Also, (edit) excessive carbon build-up which would not be uncommon for your mileage can reduce combustion chamber volume and "timing being right on" becomes relative. Pinging results. You may be able to band-aid the problem by stepping up to higher octane fuel. Best fix is to decarbon the piston tops through the shadetree method (can of Seafoam for $5) or the pro way for $100-150 via Motorvac at a mechanic's shop.

First thing I'd try is a new knock sensor. Be sure to get torque setting correct as it can affect sensitivity levels from what I understand...

Timothy60
10-31-06, 06:11 PM
Looks as if I need to narrow it down to an EGR, knock-sensor, exhaust leak, or carbon build-up. Also, could it be that old plugs are creating hot spots in the combustion chambers? I'll adress the easiest things first and see what happens. Gentleman, I appreciate your input. I read about misting some distilled water into the throttle venturi at about 2000 RPM to "steam clean" the carbon from the heads. Have you ever tried that?

90Brougham350
10-31-06, 06:39 PM
Seafoam is much more effective. It works very well.

Timothy60
11-01-06, 09:17 PM
The knock is gone! I decided to try the easiest, cheapest solutions first. I was even too cheap to buy a can of Seafoam or GM TEC spray, but I did spring for a gallon of distilled water. I got the engine up to operating temperature and trickled 8 ounces/30 seconds of water down into the throttle bores at 2000 RPM. A mushroom cloud of steam came out of the tailpipe. Buttoned up the air cleaner and took the Caddie for a spin. Knock completely gone. I read about how to do this in the September 2000 Car Talk archives. Tomorrow on my way to work I'll do a WOT blast just for good measure.