: 95 concours stalling



jones105n
10-23-06, 05:23 PM
Hello,

my 95 concours (125K) has just begun stalling while driving at various speeds but always while at operating temp. restarts fine after about 1 min. doesn't die at idle. replaced fuel filter obviously but help. any ideas? dealer says probably crank pos. sensor.

thanks

Ranger
10-23-06, 09:34 PM
Your symptoms are that of CKP (Crankshaft Position) sensors. They should set a DTC when they fail. Have you pulled the codes?

jones105n
10-24-06, 05:00 PM
No I have not pulled codes but the local garage said none were set and replaced the fuel filter. I am assuming to check this I need to turn on the key and press the "off" and "warmer" buttons on the hvac controls is this correct?

Ranger
10-24-06, 08:22 PM
Not positive about the Concourse but I think that is correct.

jones105n
11-12-06, 02:26 PM
Thanks. Had no codes. Gave up and took it to the dealer. thery had it three days and found the contacts on the fuel pump/sender module had corroded to the point they were only barely making contact. Changed out sender/pump for $700.00 and no more problems. Woke up this morning with coolant under left front and found bad bearing and inner seal on water pump leaking. Have gone through TWO of the special tools and still can't remove old pump. ANY suggestions????????

Ranger
11-12-06, 03:51 PM
Are you using the cheap stamped steel tools from Lysle? You might be better off with a good machined one from KentMoore, Snap-On or such. Sometimes the cheap turns out expensive. A few short bursts from an impact wrench should break it free.

jones105n
11-12-06, 05:46 PM
Yes on the Lisle tool. I tapped on the tangs (straight on, NOT trying to turn it) all the way around with small brass punch and finally got the second tool to break it free. Everything re-installed now and the wife is now on her way to the grocery store.:thumbsup: