: hating my caddy right now



caddyhater
10-14-06, 07:31 AM
I have had nothing but problems with my '04 SRX. besides having the dealer replace a power steering pump, 3 window actuators and 4 defunked tire pressure sensors (all under warrenty) I now have issues with the car having no heat.

the dealer claims there is oxydation clogging up the heater core. The oxydation comes from, they claim, a reaction between the coolant and the hose that feeds the core. Their fix - install a filter inline with the heater core. The catch - I have to return every 1000 miles or so to have the filter replaced. What's that about? sounds like a band aid fix to me. has anyone else had this problem? I know there is a TSB out the HVAC system, but cannot get the details.

I callled a lemon law lawyer yesterday. He claims I can some compensation for my troubles. He's going to try to get a total vechicle repurchase, we'll see what happens. I will update when I get more info. Hopefully I can get rid of this car. :banghead:

First American car I lease, not impressed. my '96 Nissan runs better. I will not buy another GM product...workmanship questionable.

MortnCyn
10-14-06, 08:17 AM
We had an '04 with no major problems but I did tend to keep notes on those with problems and one dealt with poor or no HVAC heat. The following was from GM's Techlink that we that pay the bills for GM no longer have access to. Regrettably, many GM dealers have no clue how to use their own system to solve problems. Anyhow, here it is:

Owners of some 2004 Cadillac CTS and SRX models may experience poor or no HVAC heat.

Check the thermostat housing (P/N 12573977) for casting flashing. Remove the flashing from the thermostat housing. If the material cannot be removed without damaging the housing, replace the housing.

caddyhater
10-14-06, 08:36 AM
cool...thanks.

b4z
10-16-06, 11:59 AM
Don't you mean, that's HOT, thanks! LOL.

Smokin' SRX
10-16-06, 05:30 PM
I have had nothing but problems with my '04 SRX. besides having the dealer replace a power steering pump, 3 window actuators and 4 defunked tire pressure sensors (all under warrenty) I now have issues with the car having no heat.

the dealer claims there is oxydation clogging up the heater core. The oxydation comes from, they claim, a reaction between the coolant and the hose that feeds the core. Their fix - install a filter inline with the heater core. The catch - I have to return every 1000 miles or so to have the filter replaced. What's that about? sounds like a band aid fix to me. has anyone else had this problem? I know there is a TSB out the HVAC system, but cannot get the details.

I callled a lemon law lawyer yesterday. He claims I can some compensation for my troubles. He's going to try to get a total vechicle repurchase, we'll see what happens. I will update when I get more info. Hopefully I can get rid of this car. :banghead:

First American car I lease, not impressed. my '96 Nissan runs better. I will not buy another GM product...workmanship questionable.


Never heard such nonsense! Why not flush the system out?? Change dealers!!! He's "cashing" in on GM's liberal warranty work program!!! Many dealers do!

I recently caught an "unauthorized" peek at the invoice for my minor front oil leak. It said "replace pan gasket and oil". They charged GM $907 dollars for this!!!!! I was never supposed to see the invoice that GM gets! (girl screwed up) They padded it big time! And GM never checks!!!! DUH!

Jim1751
11-19-06, 01:00 PM
I've owned a 2004 SRX since March '04. After 18K the sunroof began squeaking. It's been in 11 times for the same problem as the repair that they do is always short-lived. At about 45K began getting foul odor after hard driving then coming to a complete stop. It's been in 5 times for this problem and they CLAIM they can't recreate it. Everyone that gets in the car smells it except the service tech and advisor.

stlgasman
11-19-06, 09:27 PM
They have a good fix for the sunroof now.

Cadboy425
11-19-06, 09:51 PM
I've owned a 2004 SRX since March '04. After 18K the sunroof began squeaking. It's been in 11 times for the same problem as the repair that they do is always short-lived. At about 45K began getting foul odor after hard driving then coming to a complete stop. It's been in 5 times for this problem and they CLAIM they can't recreate it. Everyone that gets in the car smells it except the service tech and advisor.

I'm up to 4 times for repairing the squeaking sunroof. Just brought it in last week and the noise is back, its getting really annoying already. Not looking forward to 7 more visits ! BTW, mine is a '05 with 15k on it.

Smokin' SRX
11-25-06, 06:50 PM
I'm up to 4 times for repairing the squeaking sunroof. Just brought it in last week and the noise is back, its getting really annoying already. Not looking forward to 7 more visits ! BTW, mine is a '05 with 15k on it.

Hi! I had same problem and while talking to parts manager, during an oil chanfe, he throws me a can of GM Super-Lube, spray. (looks like WD- 40 to me!) I open the roof all the way, lay plastic on my seats, and carefully spray all rubber, hinges, tracks, etc on this cocktail table size roof! Wipe up the mess, open/close 4-5 times and Presto! No squeaks or rattles. That was 7K miles ago (6 mos. ago and I just heard a creek yesterday. Open and closed/closed the roof just 3-5 inches and it's gone!
Give a try.