: Need Help Please!!



txcaddycat
10-02-06, 10:20 AM
Yesterday I put a new oil cooler in my catera. Today when I went outside to start it up it wouldn't start. After like 15 tries it finally started up but I had to keep my foot on the gas pedal. Another weird thing is that when I slam my gas pedal all the way down the rpm's will go to like 1500-1800 and no more. Also my traction control and the light with exclamation point is on and it wasn't before. After a while of holding the gas down I finally let off and the engine was idling very weird. Like the rpm's would go up and down and it sounded like the engine was tryin to take deep breaths over and over. When I try to put it into gear it just shuts off. Any advice would be useful right now, thanks.

guardian
10-02-06, 10:43 AM
Did you check for codes? It's probably throwing some codes. This could point you in the right direction.

Changing that heat exchanger (oil cooler) is a pretty big deal. Maybe something didn't get hooked back up right. I'd look things over really, really closely. Or else maybe something was knocked loose while you were working on her.

Hey wait a second. I got a question:

You said you did the work yesterday. Did the car run OK yesterday after you were done?

Or is today the first you have tried to start her up?

txcaddycat
10-02-06, 11:07 AM
Today was the first time I tried to start her up. I'm at school right now, when I get back home I'll try again and keep you guys updated.