: Help!!! Asap!!!



AKPsiMC03
04-05-03, 01:22 AM
My car stalled on my tonight. twice.

it is throwing code P037: Front sort term fuel trim

what does that mean?!??!?!?! i need ot fix it asap cus i need my car for work tomorrow!

it is also telling me there is a history of P095 which isnt in this guide from caddyinfo.com.


PLEASE HELP ME FIX THIS!!!

AKPsiMC03
04-05-03, 10:14 AM
diagnosis: dead coil pack :mad:

elwesso
04-05-03, 11:16 AM
Thats weird, coils dont NORMALLY fail. Could it be possible you damaged it a little while you took your plugs out?

AKPsiMC03
04-05-03, 11:25 AM
well the #2 and the #5 are not firing. they are both on the 4th coil. My guess is is that the coil went bad. I check both plugs. both were soaked in gas. so there is no spark... the car will run... but it sounds like on 6 cylinders.

but i also still need 02 sensors. are both on the 95 northstar motor the same part number? I want to order them from GM parts direct.

kcnewell
04-05-03, 11:40 AM
Originally posted by elwesso
Thats weird, coils dont NORMALLY fail. Could it be possible you damaged it a little while you took your plugs out?

That's not weird at all Wes, Coils are subject to failure just like any other component. Nothing NORMALLY fails. I see coils fail all the time, It's not the most common failure in the world but it's not uncommon at all....

I would check the plug wires for those two cylinders before replacing the coils though, as a precaution!

AKPsiMC03
04-05-03, 02:08 PM
i replaced the coils and check all the wires and it still doesnt FU****G run! what the hell is is with me and cars that break all the time? all i want is a car that runs right for once... im screwed without a car that runs. god damnit.

i need help on this asap... any help... PLEASE im desperate here.

its code P036

elwesso
04-05-03, 03:37 PM
You could always put a match over the spark plug wire :D

What do you mean by "you checked the wires", did you just make sure they were hooked up right. Maybe its time for some new wires??

AKPsiMC03
04-05-03, 04:43 PM
well when wires go bad it is very gradual... this was about as un expected as a kick in the balls from a best friend. it happed all of a sudden.

i think its the 02 sensor causing it all... i have a new one and it is going in tonight. I hope its warm out though cus im doing it outside

AKPsiMC03
04-05-03, 06:04 PM
okay... coil packs are new. front 02 sensor is new. rear, didnt have another in stock. all cylinders are getting spark. battery was unpluged for an hour while we worked on it.... it had trouble starting.... now it starts and idles like crap:

codes i get now: P036, P052, P106. I dont know what 052 and 106 are.

i really need help with this. please

AKPsiMC03
04-05-03, 08:06 PM
all fixed... no one ever told me it takes an hour and a half of te battery being unplugged to reset the computer haha...

she purrs like a kitten now.... well a kitten on drugs anyway :banana:

mnymaker
04-07-03, 02:53 PM
Bravooooooo!!! So was it the O2 sensors or the coils what? I guess you wont know since you changed both huh?

AKPsiMC03
04-07-03, 04:22 PM
it was the front 02 sensor... when the other ones come form GM parts direct i will do the rear too. but it works fine now. I just had to let the comouter reset for an hour and a half before it would run right.


as for the coils, i guess im out $80 now... oh well.

Chuck C
04-07-03, 06:39 PM
hey, better than being out a grand from taking it to a dealer!