: Cluster light problem on 2000 catera PLEASE HELP!!!



absar_siddiqui
09-25-06, 02:34 PM
Hey i bought my catera 2 weeks ago and i am a new member here. I love the car but there is a problem. the guage cluster lights all the way down to the A/C and radio lights dont work. i cannot see my spedometer or any ac or radio buttons at night. Lights light the check engine light and brake lights work fine. just spedometer and the ac and radio lights. Also i just had a new sunroof motor put in and sometimes it doesnt work same as radio. what could this be? the radio and sunroof arent main issue just the spedometer and cluster lights. anyone have the same problem or no what i can do?

Thanks
-Absar

guardian
09-25-06, 04:45 PM
Absar several answers:

Very short term, like tonight if you do not have time to pursue the below:

Use a flashlight so you can see instruments and drive car.

OK, now looking toward actually fixing the problem:

It's most likely either a fuse or else the dimmer control could have become intermittant or actually failed. Also it's possible a wire has become disconnected, perhaps pulled loose. First. do a thorough visual exam beneath the dash. With luck the problem will be self-evident.

But if not:

You can try without it, but you would be helped by a wiring diargram of the car which will give you a guide to circuit trace the problem with a VOM. If you cannot circuit trace this problem yourself an auto electric shop should be able to help you.

Failing all else, you might have to take the car into a Cadillac dealer. If so, be sure the dealer used to sell Cateras; not all did!:bigroll:

Good luck and I hope you can achieve a quick fix.:thumbsup:

absar_siddiqui
09-25-06, 06:34 PM
i checked the fuses they are all good i dont kno if the wiring had been pulled but i think it should be that because if not only the spedometer but the other lights are off as well they might be connected. but i can check fuses but i am clueless when it comes to wiriing

guardian
09-25-06, 07:12 PM
I agree with your thinking.

If all the fuses check out you might have to try an auto electric shop. You need to locate a place that can circuit trace and get to the bottom of your situation. If they have a wiring diagram the work will go a lot faster.

Or else you need to buy a case of beer, or whatever bribe is appropriate, for a friend who knows about this stuff!:)


Good luck!

aarcher
09-25-06, 10:14 PM
The auxiliary water pump could be on it's way out, when mine went all kinds of strange things happened for example: One bulb behind the speedo worked intermittently, the sun roof had a mind of it's own, the radio stopped working, the passenger and drivers windows would not auto open/close.. In my case there was one fuse that would blow, it was the fuse that controlled the radio and the interior lights, I think it was called clamp 15

- Adam

Warez
09-27-06, 11:33 AM
The auxiliary water pump could be on it's way out, when mine went all kinds of strange things happened for example: One bulb behind the speedo worked intermittently, the sun roof had a mind of it's own, the radio stopped working, the passenger and drivers windows would not auto open/close.. In my case there was one fuse that would blow, it was the fuse that controlled the radio and the interior lights, I think it was called clamp 15

- Adam

The Catera does not have an auxilary water pump.

Warez
09-27-06, 11:37 AM
the guage cluster lights all the way down to the A/C and radio lights dont work. i cannot see my spedometer or any ac or radio buttons at night. Lights light the check engine light and brake lights work fine. just spedometer and the ac and radio lights.
-Absar

Just to clear this up, in the actual guage cluster only the speedo does not light up and everything else does (fuel guage, rpm etc)? Aditioanlly the HVAC control lights are all off in addition to the radio?

Does the radio, HVAC controls and interior dome lights work?

aarcher
09-27-06, 02:46 PM
The Catera does not have an auxilary water pump.

Well, this guy apparently has one:

http://www.cadillacforums.com/forums/cadillac-catera-cimarron-forum/66363-interesting-discovery-auxiliary-water-pump.html#post606271

I know the 98 catera has one , even held in my hand after having to return the primary water pump that the mechanic ordered by accident as he didn't know the car had one..

stevehogan
09-27-06, 03:03 PM
I believe that you have two seperate problems.

1: You say that the only light that is out in the instrument cluster is the speedo light and the fuel gauge, oil gauge, etc are all lit. All of the lamps in the cluster are wired together internal to the cluster and few through the same wire and fuse. So it is either 1) a bad bulb or two; 2) bulbs are loose or missing; 3) cracked circuit board in the cluster; or 4) some other broken connection within the cluster. It is definitely within the cluster. You need to pull the cluster and take a look.

2: The radio and A/C lighting is fed separately, but all are fed from the dimmer. The dimmer is undoubtedly OK, since the cluster lamps light. I do not have access to my service manuals and wiring diagrams, but as I recall, there is a single feed to the area of the AC and radio for the backlights where it splits off to each device. I'm betting that a wire is broken or a connector is loose (a bad crimp, or a pin has pulled back from the connector housing when someone had it disassembled.). Someone with the wiring diagrams handy can give you a circuit ID and where to look.

BTW, this really points out that you need the service manuals to handle this kind of issue with a Catera. The wiring is a bit convoluted and it is not as simple as just glancing under the dash and looking for a broken wire.

Hope this helps