: Engine Light came on



scottimartini
08-23-06, 05:01 PM
According to the manual, this is probably due to some imbalance with the smog crap. Before I take it to the dealer and let them charge me an arm and a leg to reset it (and probably not actually fix anything) is there anything I can do to get it back to normal? It is on all the time - not flashing.
Thanks

2004ctsv
08-23-06, 05:45 PM
Ask OnStar to run a diagnostic for you. Get the code and cross check on the forum.

CIWS
08-23-06, 06:20 PM
Go to Autozone and have them check the code ? (for Free)

Wizzle
08-23-06, 06:26 PM
I would just stop by Autozone, Advanced, or O'Reilly's (whichever is your favorite) like mentioned above and have them delete the code from your PCM if you just want the light off. You can get an OBDII scanner for about $100 at any of the parts houses that way you can check and delete the codes (they come with a book that tells you what the codes mean). 100 bucks now might save you in the future from having to go to the dealer. Just an idea...

dqw1
08-23-06, 07:29 PM
...and make sure your gas cap is screwed on tightly.

Wizzle
08-23-06, 08:20 PM
...and make sure your gas cap is screwed on tightly.

That'll do it! :bang2:

DILLIGAF
08-23-06, 08:54 PM
That'll do it! :bang2:Hes not joking:worship:

CIWS
08-24-06, 07:41 AM
...and make sure your gas cap is screwed on tightly.


Yep was the same in my Murano (and I'm sure many other vehicles) as well as the V.

http://smilies.vidahost.com/contrib/edoom/toilet_claw.gif

scottimartini
08-24-06, 09:27 AM
Thanks everyone. I didn't ever think about OnStar running the diagnostics. That's pretty cool