: Sluggish when driving



chiefster
02-10-04, 07:59 PM
I have a 1998 Deville, with the NorthStar Engine. I have had it since July last year. I have maintained a regular maintanence schedule, and have been putting in the top grade fuel. I have been using synthetic mix oil, only because my mechanic stated it is better. I haven't really had a problem with it, except for a couple of weeks ago my battery died all of the sudden. I was informed that the first cell went bad, so I replaced it. Now, all of a sudden, this week my car is now kinda sluggish when driving it. At first it started only at 50mph, but over a period of a few hours it has gotten progressively worse, and is now stuttering when driving at 35 - 46mph...only periodically though. I am afraid that there is something wrong with the transmission, but I do not see any leakage nor is the trans fluid discolored. My friend suggested that it might be the fuel injector, but I am not sure. It drives perfectly fine when I am above 55mph, but anything below that, and it periodically stutters when I press on the accelerator. Can you please help?

chiefster
02-10-04, 08:01 PM
oh, by the way. I do not get any error codes, and when I run a system check it states all Monitored systems OK....please help

zonie77
02-10-04, 10:39 PM
I'd suggest checking the fuel pressure regulator first. Take off the vacuum line and let the car run for several minutes. Any gas or fumes is a sign it needs to be replaced. It is in the fuel line near the intake manifold.

Realtor1
02-11-04, 12:13 PM
Also check plugs and wires as a fouled plug / bad wire can cause hestation..