: Decreased Performance ???



codewize
08-04-06, 02:26 PM
I'm a little concerned that something is different. When I got my DTS (24k) I was thrilled with the acceleration and the massive steering torque created above 3000 RPM coming off the line. I'm not feeling that anymore (34k).

Am I just used to it or is something wrong? No codes or anything, car seems to run fine. It gets plenty of driving and WOT treatment. Is there anything I could look at or check to give me answers.

It almost feels like I downgraded to a standard 275HP DeVille engine. That extra punch isn't there anymore. Hmm would a broken motor mount increase steering torque, cuz that's been fixed.

codewize
08-04-06, 10:03 PM
No coments on this? Am I just nuts?

caddydaddy
08-04-06, 10:31 PM
I think you are just used to it now. My STS doesn't seem as fast as it used to be, so I guess it's just me!

unruley247
08-05-06, 10:04 PM
The power is still there. All you have to do is just pull up to a light n just blow everyone off the line and you will know

J.A.O.
08-07-06, 10:51 PM
Another thought,

It is summer time and with those warmer temps, come less dense air for the fuel to work with.

JimLucky
08-12-06, 01:46 PM
Another thought,

It is summer time and with those warmer temps, come less dense air for the fuel to work with.

So true !!! Air temp and humidity play a big roll in engine performance.When I need to check her performance in summer I wait for a cool evening and let her rip.Since your in upstate NY your evening temps should be droping give it a try!!

Also check your air filter.

codewize
08-12-06, 09:03 PM
I think we're fine. Yes the temps have gotten back to normal. It was hanging around 95 for a few days here and that's when I was noticing a difference.

No that it's cool in the mornings and evenings I feel better.

Thanks