: Hard Start/ Fuel Odor



Cadi Homer
07-19-06, 09:44 AM
Hi Guys,

Just recently I have been noticing that my í97 DeVille takes longer to start. It will crank for several seconds before it starts. The car has 102k miles and it would always start right away. I check the battery terminals and they are clean and properly secured in the battery, I also looked at the fuel filter for any signs of leaking fuel and none was found. However, I did notice that the engine has a strong gasoline smell and sometimes when Iím driving I get that same smell inside the car. After the car finally starts I get a huge cloud of smoke coming from the tail pipe. I am really consfused and concern any ideas?? I just recently replaced the starter and alternator. The only thing I have not replaced since I have the car (47k miles) is the fuel filter. Should I replace the fuel filter?? If so any ideas on how to get it out of the black cover that holds the fuel filter in place or instructions on how to do this??

Thanks guys, for all your help!!! :bigroll:

boricuacaddy
07-19-06, 10:24 AM
Hi, check the FPR (Fuel Pressure Regulator) Most likely than not, it is the problem. plus it is the simplest thing to change yourself. I also had the same problem on my 97 Seville. I changed the FPR and I was good to go.. Hope this helps!

Here is a link on the subject.. http://www.cadillacforums.com/forums/cadillac-tech-tips/61600-how-check-faulty-fpr-fuel-pressure.html

David

Frost
07-19-06, 01:20 PM
Guess what just went "south" on my 1997 sedan Deville with 98.8K showing on the old odo? Yep, the FPR!

Symptom: Hard start when cold (usually in the morning or after sitting all day in the parking lot @ work) but once the car warmed up, no probs at all with starting - but the smell was always present.

. Strong gas smell around the front of the car - and as it gets worse, that gas smell creeps into the interior. It got changed yesterday, as there was becoming a real issue with a fire starting (yes, it was THAT bad!)

longisland516
07-19-06, 05:22 PM
My '97 Deville had a hard start problem (without fuel odor) and replacing the fuel pump fixed it.

Cadi Homer
07-19-06, 06:00 PM
my only concern is that the car has a hard time starting when it is cold and hot, however, after the car starts it runs great. After reading the thread I notice that this problem only applied on hot starts .... should I still replace FPR??

Ranger
07-19-06, 08:34 PM
Check it before you replace it. See the Tech Tips section.

longisland516
07-20-06, 11:10 AM
My '97 had the same problem for 30k miles. Went away when the fuel pump was replaced.

Cadi Homer
07-24-06, 12:23 PM
I just replaced the FPR and that corrected the problem. My only issue now is that I get a huge cloud of smoke from the tile pipe from time to time any ideas on what can be causing that??

Thanks Guys for all your help!!!!

Ranger
07-25-06, 02:36 AM
Black smoke? Blue smoke? White smoke? During start up? While driving? At WOT?

Cadi Homer
07-25-06, 12:10 PM
Its white smoke and like I said its only from time to time.... I've seen that smoke more often during start-up and at idle .... Also, I stop by the dealer and I was notified that the fuel line was never taken in for recall so am getting that done this afternoon. Do you think that might contribute to the white smoke Ranger??

Ranger
07-25-06, 02:37 PM
White smoke is actually fuel vapor (excessivly rich). I'd bet if you smell the "smoke", it will smell like fuel. You probably did something wrong on the FPR installation, but it will be corrected when the fuel rail is R & R'd.

Cadi Homer
07-27-06, 01:00 PM
I just had the fuel rail replaced and still the same problem with "white smoke". I created a new thread...

http://www.cadillacforums.com/forums/cadillac-deville-1985-2005-including-1985/80758-white-smoke.html#post761898

EcSTSatic
07-27-06, 05:05 PM
Could be a sticking injector