: Suddenly running rough



paintedalley
02-06-04, 07:15 PM
we just bought a 1998 Deville ( feb 1st) had it checked out, A great one owner car, all service records..always serviced at a Cad dealer.. 99,900 miles this car ran like a brand new showroom car..UNTIL "LOL".. yesterday 2 things happened, 10 bucks worth of gas ( was about empty too) and I had the air cond recharged..the service a/c message came on..now the car idles fine in park..but accelarates horrible, missing poping sounds kinda like a back fire..just horrible!, it runs good at 70 cruise on just fine just don't hit the gas or it's gutless.. miles are now 100,080 ..MPG went from 24 to 14 also .. we changed the fuel filter just now thinking the gas was bad, and filled her with the best 93 octane we could find..but no change what now? I don't know how to read codes?? I did buy new platinum plugs today but haven't installed them yet..what should we do next? THanks for this great forum!!

elwesso
02-07-04, 12:23 AM
Check your DTCs..... OBDII is very good about detecting whats happening......

Its possible you fried an injector (maybe by some bad gas)..... When you do your plugs <and wires> look at them to see if you can notice any variation in how they look (misfiring cylinder, etc.)

akaz87
02-07-04, 03:21 AM
Definitly sounds like you need new Spark Plugs and wires. AC Delco ONLY on the Plugs

paintedalley
02-07-04, 09:21 AM
Check your DTCs..... OBDII is very good about detecting whats happening......

Its possible you fried an injector (maybe by some bad gas)..... When you do your plugs <and wires> look at them to see if you can notice any variation in how they look (misfiring cylinder, etc.)

OK Thanks! How do I pull the codes from this car? I've found info on a few others here but "so far" not on a 1998 Deville.. This has been going on for 3 days, and today I go the SES light, up until now no light just terrible missing on accelleration.

elwesso
02-07-04, 11:25 AM
You can do it via the on board system, but probably the easiest way would be to go to an autoparts store (autozone) and have them run a free OBDII test... They plug it in, the scanner gives them the codes, and you bring them here!!!

paintedalley
02-07-04, 11:49 AM
we are in a real rual part of Texas and are about 30 to 45 min from any autoparts stores, I hate to drive it and damage anything..My husband did get the read out for the codes and emailed from work..this is what showed up.. P300,P463,P603 and B3108 any of thos a clue to running so badly and so quickly, this car was perfect 3 days ago it didn't start running sota bad or a miss here and there, it got ugly fast :annoyed:

JimD
02-07-04, 02:37 PM
Your drop in fuel mileage might be pointing you toward a leaking fuel pressure regulator? Would allow unmetered fuel to enter the intake system.

None of your codes provide a clue to your problem:
P0300 - misfire (but you know that already)
P0463 - Fuel level sensor circuit high voltage
P0603 - control module long term memory reset (the battery has been disconnected at some point)

B3108 - transmitter synchronization failure (remote battery was changed)

Good luck....