: help wilth coede PO23



laurieH
02-05-04, 12:16 PM
Hi

Anyone know what code PO23 is??? I looked it up but couldn't find it. Thanks

onecad
02-05-04, 03:46 PM
well.....my book says that it is an "ignition control circuit problem". I got the code from my 1993 eldorado service manual. There is a bout 4 pages of information on it.

And what the conclusions of the code could be are 1. an open in ckt 423 2. an opem in ckt 424, 3. a bad icm (ignition control module) that needs to be replaced. Or possibly 4. a bad pcm (powertrain control module)

BeelzeBob
02-05-04, 04:12 PM
Hi

Anyone know what code PO23 is??? I looked it up but couldn't find it. Thanks

It relates to some sort of problem with the electronic control module that is under the coils in the direct fire coil pack. The module interpretes the crank shaft sensor signals, feeds reference signals to the PCM and fires the ignition based on feedback from the PCM. Could be a circuit problem with the communication line to the PCM or the module itself. I would start by disconnecting the wire connectors at the coil pack and checking for corrosion, loose pins, loose wires, moisture, etc... indicating a poor connection.

laurieH
02-06-04, 11:17 AM
Hi



Thanks, I really don't know where this is located, any helkp would be appreciated. This is my third code this month and I am frustrated to say the least, first it was my egr then my idle speed motor went out now this, any relation???????? I don't know.



My car seems fine (excpet it is still idling weird ) and when I go over a bump or snow (we have about 3 feet total snow here) my engine light comes on with the PO23 code. I am thiking something must be loose, I am not that great at cars. I am learning but need lots of help. LOL!!!!!!

Where do I look for the ignition module? Where is it and then what? I am someone who owns a car out of her league, lol. i love this car but I have more money wrapped up in it than I care to mention and it keeps having problems, one after te other. I am trying to do lots of the work myself , I cleaned the egr and I changed the idle speed motor, so far so good, All I want is for my car to run right for maybe 4 weeks w/o repairs, that would be great. This is getting to be ridiculos. I mention before that the day before I started getting error codes I had my cars oil problem fixed for $2250 and not sure if something they did casuses this but I am suspicious. I had to get a carbon cleaning done since then and all this too. Any help would be greatly apprciated.



Laurie

onecad
02-06-04, 11:47 AM
hey laurie...
whenever you start a new thread please state what car you have along with the engine. Not just 4.6 North star because although the engines may be the same on the most part some things are different form one year to the next.

Not everyone is going to remember what car you have one thread to the next, as bbobynski said to me, its hard to rememebr who has what car after reading so many posts.

On a 93 eldorado, the icm is located on the top of the rear camshaft cover. Its what holds the coils with all the spark plugs on it. A long black rectangular unit below the 4 coils.

Check to make sure all electrical harnesses there and spark plug wires are pushed in tight, and if they are, check for loose or corroded wires leading into the actual plug and maybe gently wiggle the wires to see if there is any change.

Just for the hell of it, erase the code, and see if it comes back as the same code.

laurieH
02-09-04, 04:27 PM
Hi



Sorry, I have a 94 seville sts, 4.6 northstar. I always forget that.

My car is still getting the PO2 code, When I am driving sometimes I get a jerky feeling in my car like it is pulling forward a bit and then the engine light immedialtey comes on and gives me the PO 23 code. I will try checking all the connections and go from there, thanks. I will probably be writing again soon. I am doing my best to figure this one out but may need to take it in to a shop, I am hoping it doesn't come to that this time.

Thanks,

Laurie




















hey laurie...
whenever you start a new thread please state what car you have along with the engine. Not just 4.6 North star because although the engines may be the same on the most part some things are different form one year to the next.

Not everyone is going to remember what car you have one thread to the next, as bbobynski said to me, its hard to rememebr who has what car after reading so many posts.

On a 93 eldorado, the icm is located on the top of the rear camshaft cover. Its what holds the coils with all the spark plugs on it. A long black rectangular unit below the 4 coils.

Check to make sure all electrical harnesses there and spark plug wires are pushed in tight, and if they are, check for loose or corroded wires leading into the actual plug and maybe gently wiggle the wires to see if there is any change.

Just for the hell of it, erase the code, and see if it comes back as the same code.