: 93 fleetwood surges



bigmikelilmike
06-15-06, 04:29 AM
well its got me stumped it surges when im at a redlight or stop like a fuel problem .....have done complete tune up and replaced just about every sensor ...new fuel filter .....rebuilt the fuel pressure regulator ....been running 93 gas ......several injector cleaners ....looks like both injectors good both spraying a faned out pattern .....any suggestions guys ...almost 97000 miles thanks

N0DIH
06-20-06, 08:49 PM
EGR flow leaking?? That would do it for sure.

Check that the EGR valve isn't sticking open, or a vacuum hose misrouted to it.

bigmikelilmike
06-30-06, 09:06 PM
well egr valve is new ac delco part .........its puzzling me .........sometimes its surges at a light sometimes it misses .......almost every sensor replaced .......no engine light on ......any other ideas guys

caddydream
07-08-06, 11:48 PM
Have you replaced the MAP sensor?

bigmikelilmike
07-11-06, 07:16 PM
yes i replaced the map sensor,egr valve ,coolant temp sensor, tps sensor, iac , plugs, wires, cap , rotor , fuel filter,pcv,breather filter ....got me stumped

N0DIH
07-14-06, 08:14 AM
In general I have only seen 2 things be causes for surging. EGR, which really ties into the #1, lean fuel mixture.

I did get it to surge with DFCO (Deceleration Fuel Cutoff), but that was something else.

Is TPS set correctly? Is timing set correctly?

Is the IAC causing it? Watch it when it is surging, is it the CAUSE or just trying to keep up and fix it? Ultimately probably making it worse.

Check fuel pressure, is filter and pump ok?

bigmikelilmike
07-16-06, 12:55 AM
i already checked the timing its good ...iac is new tps is new when i changed the tps i just put it back how it was is there sumthing special i need to do ...thanks