: Leaking anti-freeze poss waterpump area



newetc
06-03-06, 11:10 AM
Hello folks, my 96 eldo has been good to me but lately little greamlings...
It has 70k on the clock and it is the 4.6 northstar.

It is leaking from the water pump area.. any suggestions.. i'll be taking her apart to look closer but wanted to know if this area has known problems.
It leaks not only when running but also when it is parked.
I have to fill the reservoir everyday now, i get the low coolant message.
Thank you in advance for your help.

TIA

Bruce Nunnally
06-03-06, 12:26 PM
This is not unusual if the waterpump needs to be replaced I think. You need a special socket tool to remove/replace the water pump, but your local Pep Boys or AutoZone may carry the tool and have it available to borrow. Replacing the pump is not a hard job most people report.

Ranger
06-03-06, 05:47 PM
Also the water pump front cover gaskets are known to leak and have been redesigned.

Mountie
06-04-06, 02:02 PM
I replaced my Northstar..... I re-did everything. I recieved a lot of advice from some experienced Northstar dealer mechanics. A new waterpump costs around $130. It comes with a replacement 'o' ring. If I remember correctly, the 4" dia. removal socket is designed to fit against specific tabs on the pump. Removal is CLOCKWISE. Using a 1/2" breaker bar. CLEAN the pump pully opening edges.
Installation: GREASE THE PUMP-TO-HOUSING OPENING, where the belt pully pokes through and where the tabs slip under the casting-tabs, using a heavy grease. ( This avoids corrosion at the seal).
BE CAREFUL!!!!! Installing the waterpump, notice the little tabs that 'poke up'....these tabs are THE STOPS. Don't tighten anymore!! ( remember, you have an 'o' ring..... If you slightly over-tighten, you'll flatten these "tab-stops", and spin past the tabs on the housing. ( You have too much leverage with the breaker bar!!)
Also, the thermostat housing is replaced of you have the plastic style . I put in an aluminum one. The housing has an 'o' ring gasget, and to the eye, the thermostat housing will not be completly against the waterpump housing, becaus the 'o' ring will do the sealing. ( Don't over tighten.)

Then smoke a cigarrette.

newetc
06-05-06, 07:19 AM
Thank you everyone for the good information. I'm going to take her apart now and will report back the findings.... sounds like the gasket is gone..
I did replace the belt and the thermostat last year when the belt snapped.
I saw pumps for 66 bucks online.. is there an advantage with oem vs aftermarket..

As far as the gaskets re-designed.. if i buy the new ones will i get the re-designed ones.. don't know what is different.

Thank you.

Ranger
06-05-06, 10:50 AM
If you buy the gasket from the dealer, ($12) you'll get the redesigned one. I believe it has little nibs on it and is black. Not sure what the original one looked like.

I think the OEM pump is made by Airtec.

newetc
06-07-06, 10:25 AM
Good news everyone.. just replaced my wp, o-ring and the other gasket.
The wp did not look that bad but the o ring was gone... the other gasket was going real fast.. so now i got the new re-designed gasket, it is black and has the little studs.. nice fit... so i'm good to go for a while.. i already have the aluminum housing and i had replaced my thermostat last year so she is good.

Thank you everyone for the help.. this job went real smooth..

Next project, suspension and all filters.. :bigroll:

newetc
06-07-06, 10:29 AM
btw.. my dealer gave me a good deal... 65 wp and 7 for the gasket..

the old gasket was orange and flat.. the new looks much more robust.:thumbsup:

Captsolo
06-17-06, 12:47 PM
I have a 1993 Eldorado. People that read this are gonna criticize what I say now. I changed the coolent a few years ago and found a leak by my water pump. After purchasing a new pump and surfing the net, I found somewhere that from the factory Cadillac adds an "radiator sealer" to the coolent on their brand new cars. I added some to my leaking Caddy water pump and the leaking stopped.

My feeling is I caused the problem when I had the GM dealer changed the coolent. They didn't know about Cadillac adding something (Aluminum something) to coolent from factory.

Anyway, the car has been running for 4 years without that leaking problem.

Don't believe me, but if you changed your coolent - that's what caused your leak.

As you all know, once a "regular waterpump" starts to leak, you have to replace it. But a Cadillac waterpump on the 4.6 leter Northstar is anything but a "standard" water pump.

Mines been in there for 13 year (from new) and still pumping without failure!
:stirpot: